Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo fornisce una risoluzione per il problema della mancanza di memoria e delle disconnessioni di rete che si verificano quando sono caricati molti file PST nei client Outlook di Microsoft Dynamics CRM.
Si applica a: Microsoft Dynamics CRM
Numero KB originale: 2015877
Sintomi
Questo problema può manifestarsi con più sintomi o uno dei sintomi elencati di seguito.
Disconnessioni frequenti dai server Microsoft Dynamics CRM. L'icona della barra delle applicazioni client di Microsoft Dynamics CRM mostrerà "Si è verificato un problema durante la comunicazione con Microsoft Dynamics CRM Server. Il server potrebbe non essere disponibile. Riprovare. Se il problema persiste, contattare l'amministratore di sistema."
Disconnessioni frequenti da Microsoft Office Communicator (se installato) ai server di Microsoft Exchange. Questo si verifica spesso con Microsoft Office Communicator, mostrando uno stato di disconnessione e visualizzando messaggi come "Tentativo di connessione".
Disconnessioni all'interno di Microsoft Outlook ai server di Microsoft Exchange. Questo può essere visualizzato come "Cartella ultimo aggiornamento x giorno e ora" nell'angolo inferiore destro di Microsoft Outlook, dove x giorno e ora è un giorno e un'ora che non è attuale o possibilmente un'ora o due prima del giorno e dell'ora attuali.
Il processo di Microsoft Outlook può avere più di 10.000 handle aperti (visibili tramite Gestione attività di Windows o l'utilità Microsoft Sysinternals, Process Explorer).
Se la traccia della piattaforma Client di Microsoft CRM Dynamics è stata abilitata (generazione di file di traccia per il supporto, potrebbero verificarsi errori aggiuntivi nei file di traccia della piattaforma Microsoft Dynamics CRM. In genere, gli errori indicati di seguito verranno visualizzati nei file denominati MachineName-OUTLOOK-Client-YYYYMMDD-#.log dove AAAA = anno, MM = mese e DD = data di creazione del file di log. Si noti che alcuni di questi messaggi verranno registrati anche nel registro eventi dell'applicazione dal computer client con i problemi.
Impossibile inizializzare l'impostazione della lingua dell'utente nel componente aggiuntivo Microsoft CRM Outlook. Riavviare Microsoft Outlook e riprovare. HR=0x8007000e. Context=. Function=CEnableState::Activate. Riga=169.
Errore durante il recupero dei dati dal server Microsoft CRM per l'elaborazione dei messaggi di posta elettronica correlati a Microsoft CRM. Non tutti i messaggi di posta elettronica correlati a CRM possono essere contrassegnati in modo appropriato. Verificare che l'utente corrente disponga delle autorizzazioni appropriate e della connettività del server e ritentare l'azione. HR=0x80131534. Context=. Function=CEmailTagger::Run. Linea=414.
Eccezione durante l'interoperabilità di Outlook: System.Net.WebException: La richiesta non è riuscita con stato HTTP 401: Non autorizzato.
Eccezione durante l'interoperabilità di Outlook: Microsoft.Crm.CrmException: Risorsa non trovata(301).
Eccezione durante l'interoperabilità di Outlook: System.Net.WebException: Impossibile connettersi al server remoto ---> System.Net.Sockets.SocketException: una connessione stabilita è stata interrotta dal software nel computer host 192.168.1.1.1:443
Eccezione durante l'interoperabilità di Outlook: System.Net.WebException: Impossibile connettersi al server remoto ---> System.Net.Sockets.SocketException: è stata tentata un'operazione socket per un host non raggiungibile 192.168.1.1.1:443
Eccezione durante il tentativo di verificare se l'utente è autenticato System.Net.WebException: Impossibile connettersi al server remoto ---> System.Net.Sockets.SocketException: è stata tentata un'operazione socket a un host non raggiungibile 192.168.1.1.1:443
LoadMetadataForRichClient() ha riscontrato un'eccezione: System.OutOfMemoryException: è stata generata un'eccezione del tipo 'System.OutOfMemoryException'.
Annotazioni
I passaggi seguenti per l'acquisizione di un dump della memoria sono facoltativi perché i sintomi visualizzati devono essere acquisiti con errori del registro eventi o i log degli errori di traccia della piattaforma client di Microsoft Dynamics CRM.
Se è stato acquisito un dump della memoria del processo di Microsoft Outlook attenendosi alla procedura seguente:
Aggiungere il percorso del Registro di sistema: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework
Chiave: GCBreakOnOOM
Tipo: DWORD
Valore: 2
L'impostazione della chiave precedente causa un DebugBreak all'interno del processo quando si verifica un'eccezione System.OutOfMemoryException. Configurare lo strumento di diagnostica di debug:
- Scaricare e installare DebugDiag in un'unità con almeno 4-5 GB di spazio su disco.
- Aprire DebugDiag. Se viene richiesto di selezionare una regola, selezionare Crash. Altrimenti, selezionare il pulsante Aggiungi regola e selezionare Crash.
- Selezionare Avanti e selezionare Un processo specifico.
- Selezionare il nome del processo, nel caso Outlook.exe. Seleziona Avanti.
- In Impostazioni avanzate selezionare Eccezioni, quindi selezionare Aggiungi eccezione.
- Nell'elenco delle eccezioni selezionare 80000003 Eccezione del punto di interruzione.
- Impostare il tipo di azione su Full userdump e il limite di azione su 1. Seleziona OK.
- Fare clic sul pulsante Salva e chiudi.
- Selezionare Avanti e specificare un nome per la regola e il percorso in cui salvare i file di dump.
- Selezionare Avanti e quindi il pulsante Fine.
È possibile che venga visualizzata un'eccezione System.OutOfMemoryException elencata nei thread gestiti quando si analizza quel dump della memoria con Windbg e il comando SOS !threads. È anche possibile che venga visualizzato un errore System.Net.WebException.
Causa
Questo problema si verifica perché Outlook 2003 e Outlook 2007 allocano più memoria per la memorizzazione nella cache dei file pst rispetto alle versioni precedenti di Microsoft Outlook. Dopo aver abilitato questa chiave del Registro di sistema, Outlook 2003 o Outlook 2007 allocherà la stessa quantità di memoria delle versioni precedenti di Outlook per la memorizzazione nella cache dei file PST. Questo è in genere visto solo con un numero maggiore di file PST aperti caricati in Microsoft Outlook, ad esempio 50 o più file PST caricati.
Risoluzione
La risoluzione primaria è elencata di seguito:
Avviso
Se si modifica il Registro di sistema in modo errato tramite l'Editor del Registro di sistema o con un altro metodo, possono verificarsi gravi problemi Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di tali problemi. La modifica del Registro di sistema è a esclusivo rischio dell'utente.
Se si usa Microsoft Outlook 2003:
- Uscire da Outlook 2003.
- Fare clic su Start, selezionare Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
- Individuare e selezionare la sottochiave seguente del Registro di sistema:
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\PST
- Scegliere Nuovo dal menu Modifica, quindi fare clic su Valore DWORD.
- Digitare UseLegacyCacheSize e quindi premere INVIO.
- Fare clic con il pulsante destro del mouse su UseLegacyCacheSize e quindi scegliere Modifica.
- Nella casella dati Valore digitare 1 e quindi selezionare OK.
- Scegliere Esci dal menu File per uscire dall'editor del Registro di sistema.
Se si usa Microsoft Outlook 2007:
- Uscire da Outlook 2007.
- Fare clic su Start, selezionare Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
- Individuare e selezionare la sottochiave seguente del Registro di sistema:
HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\PST
- Scegliere Nuovo dal menu Modifica, quindi fare clic su Valore DWORD.
- Digitare UseLegacyCacheSize e quindi premere INVIO.
- Fare clic con il pulsante destro del mouse su UseLegacyCacheSize e quindi scegliere Modifica.
- Nella casella dati Valore digitare 1 e quindi selezionare OK.
- Scegliere Esci dal menu File per uscire dall'editor del Registro di sistema.
Se si usa Microsoft Outlook 2010:
- Uscire da Outlook 2010.
- Fare clic su Start, selezionare Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
- Individuare e selezionare la sottochiave seguente del Registro di sistema:
HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\PST
- Scegliere Nuovo dal menu Modifica, quindi fare clic su Valore DWORD.
- Digitare UseLegacyCacheSize e quindi premere INVIO.
- Fare clic con il pulsante destro del mouse su UseLegacyCacheSize e quindi scegliere Modifica.
- Nella casella dati Valore digitare 1 e quindi selezionare OK.
- Scegliere Esci dal menu File per uscire dall'editor del Registro di sistema.
Risoluzioni secondarie che devono essere applicate e che possono essere applicate oltre alla risoluzione primaria:
Le disconnessioni di rete o l'impossibilità di connettersi ai server Microsoft CRM potrebbero non avere abbastanza connessioni WinInet aperte disponibili. Questa operazione può essere risolta automaticamente usando la funzionalità FixIt o implementando manualmente le modifiche del Registro di sistema corrispondenti.
È anche possibile aumentare le prestazioni correlate alla rete e ridurre al minimo i problemi di rete impostando le due chiavi del Registro di sistema seguenti nel computer client. Queste chiavi devono essere create come chiavi DWORD se non sono già impostate. Creare queste chiavi e impostare i valori corretti:
HKEY_LOCAL_MACHINE\System\CurrectControlSet\services\Tcpip\Parameters\MaxUserPort
Valore: 65000 decimaleHKEY_LOCAL_MACHINE\System\CurrectControlSet\services\Tcpip\Parameters\TCPTimedWaitDelay
Valore: 30 decimali
Ulteriori informazioni
- Generazione di file di traccia della piattaforma per il supporto
- I download di Windbg sono disponibili qui sia per Windows a 64 bit che per Windows a 32 bit (in genere windbg a 32 bit viene usato per il debug client di Microsoft Outlook perché è disponibile solo una versione a 32 bit di Microsoft Outlook con Microsoft Outlook 2003 e Microsoft Outlook 2007).