Condividi tramite


Errore di convalida durante l'impostazione dell'integrazione di SharePoint basata su server per Microsoft Dynamics CRM Online e SharePoint Online

Questo articolo illustra la procedura per risolvere il problema che si verifica un errore di convalida quando si tenta di impostare l'integrazione di SharePoint basata su server per Microsoft Dynamics CRM Online e SharePoint Online.

Si applica a: Microsoft Dynamics CRM 2013
Numero KB originale: 2978295

Sintomi

Quando si tenta di configurare l'integrazione di Microsoft SharePoint basata su server per Microsoft Dynamics CRM Online e SharePoint Online, viene visualizzato il messaggio di errore seguente:

Errore di convalida

Questo errore blocca la configurazione dell'integrazione di SharePoint basata su server.

Causa

Quando si usa la nuova integrazione di SharePoint basata su server, gli URL assoluti non sono più supportati quando si creano o si usano percorsi di documenti di SharePoint in Microsoft Dynamics CRM.

Nell'integrazione precedente di Microsoft Dynamics CRM List Component con SharePoint, i percorsi dei documenti in Microsoft Dynamics CRM potrebbero essere stati creati usando un URL assoluto per fare riferimento a una cartella di SharePoint. Ad esempio, per creare un percorso di documento per un record dell'account usando il componente elenco di CRM, selezionare Aggiungi posizione e quindi digitare un URL completo (ad esempio, si digita https://contoso.sharepoint.com/ExampleAccount) nel campo 'URL del sito'. Questo URL assoluto è diverso dall'URL relativo usato nell'integrazione di SharePoint basata su server. Un URL relativo viene creato in un record del percorso del documento quando si crea una cartella in un sito padre specificato.

Risoluzione

Prima di configurare la nuova integrazione di SharePoint basata su server, tutti i percorsi dei documenti creati tramite URL assoluti devono essere modificati in modo da usare URL relativi o rimossi da Microsoft Dynamics CRM.

Passaggio 1 - Verificare il tipo di URL

Per verificare quali posizioni dei documenti in Microsoft Dynamics CRM hanno URL assoluti, seguire questa procedura:

  1. In Microsoft Dynamics CRM aprire la pagina Impostazioni .

  2. Selezionare Gestione documenti dall'elenco Impostazioni nella barra di spostamento.

  3. Selezionare i percorsi documento di SharePoint.

  4. Selezionare il pulsante con i puntini di sospensione sulla barra dei comandi di Microsoft Dynamics CRM e quindi selezionare Visualizza.

    Annotazioni

    Viene visualizzata una finestra di dialogo per la modifica della visualizzazione corrente.

  5. Seleziona Aggiungi colonne.

  6. Selezionare URL assoluto nell'elenco delle colonne disponibili.

  7. Selezionare Salva e chiudi.

Passaggio 2 - Modificare o eliminare i percorsi dei documenti

Usare uno dei metodi seguenti, a seconda del risultato desiderato.

Metodo 1 - Aggiornare gli URL assoluti

Utilizzare questo metodo per aggiornare tutti i riferimenti alla posizione del documento esistente. Dopo aver eseguito questa operazione, l'integrazione sarà già connessa a SharePoint quando si accede al record Regarding. In questo caso, all'utente non viene richiesto di connettersi a una nuova posizione del documento.

Per aggiornare gli URL assoluti, seguire questa procedura:

  1. Determinare l'URL assoluto per una posizione del documento. A tale scopo, effettuare i passaggi seguenti:

    1. In Microsoft Dynamics CRM aprire la pagina Impostazioni .
    2. Sulla barra di spostamento selezionare Gestione documenti dall'elenco Impostazioni .
    3. Selezionare i percorsi documento di SharePoint.
    4. Nella sezione Percorsi documenti di SharePoint, selezionare un percorso del documento che punta a un URL assoluto.
    5. Seleziona Modifica
    6. Nel modulo di modifica, copiare l'URL specificato nel campo URL assoluto per il proprio riferimento. Ad esempio, copiare https://contoso.sharepoint.com/account/exampleAccount.
  2. Creare un percorso del documento in modo che punti alla raccolta documenti trovata nell'URL assoluto. A tale scopo, effettuare i passaggi seguenti:

    1. Sulla barra dei comandi di Microsoft Dynamics CRM, selezionare Nuovo nella sezione Percorsi documento di SharePoint.
    2. Immettere il nome del nuovo percorso del documento. Ad esempio, immettere Account per fare riferimento alla raccolta documenti Account in https://contoso.sharepoint.com/account/exampleAccount.
    3. In Tipo di URL selezionare URL relativo.
    4. Assicurarsi che il campo Sito padre o Percorso punti al sito di SharePoint in cui si trova la raccolta documenti. Ad esempio, verificare o immettere https://contoso.sharepoint.com.
    5. Nel campo URL relativo digitare il nome della raccolta documenti di SharePoint a cui si fa riferimento. Ad esempio, digitare Account per fare riferimento alla raccolta documenti Account in https://contoso.sharepoint.com/account/exampleAccount.
    6. Selezionare Salva e chiudi.
  3. Modificare la posizione originaria del documento che è configurato per usare un URL assoluto in modo che utilizzi invece un URL relativo. A tale scopo, effettuare i passaggi seguenti:

    1. Riaprire la posizione del documento che viene discussa nel passaggio 1.
    2. In Tipo di URL selezionare URL relativo.
    3. Nel campo Sito padre o campo Posizione, selezionare la posizione del documento che fa riferimento alla raccolta documenti in cui si trova la cartella. Ad esempio, selezionare il record della posizione del documento denominato Account e creato nel passaggio 2.
    4. In URL relativo digitare il nome della cartella di SharePoint a cui si fa riferimento. Ad esempio, digitare exampleAccount per la cartella rappresentata in https://contoso.sharepoint.com/account/exampleAccount.
    5. Selezionare Salva e chiudi.

Metodo 2 - Eliminare GLI URL assoluti

Utilizzare questo metodo per rimuovere i percorsi dei documenti associati ad alcuni record. Dopo aver eseguito questa operazione, un utente che accede a tali record riceverà nuovamente la richiesta seguente di creare un percorso del documento per i record.

Screenshot che mostra la richiesta di creare un percorso del documento per i record.

Per eliminare gli URL assoluti, seguire questa procedura:

  1. In Microsoft Dynamics CRM aprire la pagina Impostazioni .
  2. Sulla barra di spostamento selezionare Gestione documenti dall'elenco Impostazioni .
  3. Selezionare i percorsi documento di SharePoint.
  4. Nella sezione Percorsi documento di SharePoint selezionare tutti i record dei percorsi documento che usano URL assoluti.
  5. Selezionare Elimina.

Dopo aver sostituito tutti i percorsi dei documenti che usano URL assoluti tramite URL relativi o dopo aver rimosso le posizioni dei documenti che usano URL assoluti, provare a abilitare di nuovo l'integrazione di SharePoint basata su server.