Condividi tramite


Risoluzione degli errori in Business Portal per Microsoft Dynamics SL

Questo articolo fornisce una soluzione agli errori che si verificano quando si tenta di accedere a Business Portal per Microsoft Dynamics SL o passare a una delle pagine Web del portale aziendale.

Si applica a: Microsoft Dynamics SL 2011
Numero KB originale: 2788387

Sintomi

Quando si tenta di accedere a Business Portal per Microsoft Dynamics SL o si passa a una delle pagine Web di Business Portal, è possibile che venga visualizzato un errore simile a uno dei messaggi seguenti:

Errore del server nell'applicazione '/'.
Errore di runtime
Descrizione: si è verificato un errore dell'applicazione nel server. Le impostazioni di errore personalizzate correnti per questa applicazione impediscono la visualizzazione remota dei dettagli dell'errore dell'applicazione (per motivi di sicurezza). Può tuttavia essere visualizzato dai browser in esecuzione nel computer server locale.

Si è verificato un errore imprevisto.
Risolvere i problemi relativi all'ID correlazione di Microsoft Sharepoint Foundation: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

Causa

Si è verificato un problema con Business Portal. Tuttavia, il messaggio ricevuto non descrive adeguatamente il problema.

Risoluzione

Per ricevere un messaggio più descrittivo e utile per la risoluzione dei problemi, modificare il file web.config. A tale scopo, seguire questa procedura:

  1. Nel server che ospita il sito Web di Business Portal passare alla directory inetpub nel server BP.

  2. Trovare il file web.config (in genere nella C:\inetpub\wwwroot\wss\VirtualDirectories\80 cartella ).

  3. Creare una copia di backup del file web.config.

  4. Aprire il file web.config nel Blocco note.

  5. Individuare il valore Callstack="False" e modificarlo in Callstack="True".

  6. Individuare il valore CustomErrors mode= "On" e impostarlo su CustomErrors mode="Off".

  7. Salvare il file Web.config.

  8. Per abilitare le modifiche nel file Web.config, eseguire il iisreset comando . Per effettuare questa operazione, seguire questi passaggi:

    1. Nel server in cui è installato Business Portal selezionare Avvia e quindi selezionare Esegui.

    2. Digitare il comando seguente nella casella Apri e quindi premere INVIO:

      iisreset
      
  9. Accedere a Business Portal o alla pagina Web e prendere nota del messaggio generato.