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Exchange Server 2013 o Exchange Server 2016 reindirizza a Exchange 2010 per OWA, Outlook sul web ed ECP

Numero KB originale: 2931385

Sintomi

Quando si tenta di connettersi alla pagina di Microsoft Exchange Server 2016 Outlook sul web, Exchange Server 2013 Outlook Web App (OWA) o interfaccia di amministrazione (EAC), si viene reindirizzati a Exchange Server 2010 OWA o Exchange Pannello di controllo (ECP). Questo problema si verifica nelle circostanze seguenti:

  • Exchange Server 2013 o Exchange Server 2016 viene installato in un'organizzazione di Exchange Server 2010 esistente.
  • Di recente è stato eseguito l'accesso a Outlook Web App o al Pannello di controllo di Exchange quando la cassetta postale era su Exchange Server 2010.
  • Spostare la cassetta postale da Exchange Server 2010 a Exchange Server 2013 o Exchange Server 2016.

Causa

Esistono tre scenari in cui questo comportamento imprevisto può verificarsi quando si tenta di connettersi a Outlook sul web, OWA o EAC:

Scenario 1: il servizio accesso client di Exchange Server contatta un controller di dominio che non dispone degli attributi più recenti dell'oggetto utente dopo lo spostamento della cassetta postale.

Scenario 2: il servizio accesso client di Exchange Server usa informazioni memorizzate nella cache per il percorso della cassetta postale.

Scenario 3: l'ereditarietà delle autorizzazioni è bloccata nell'oggetto utente.

Risoluzione

La risoluzione di questo problema corrisponde allo scenario elencato in precedenza nella sezione "Causa":

Soluzione 1: verificare che la replica di Active Directory sia stata completata controllando l'attributo homeMDB dell'oggetto utente. Questo valore deve contenere il valore DN del database delle cassette postali di Exchange Server 2013 o Exchange Server 2016

Soluzione 2: in Exchange Server 2013 o Exchange Server 2016 attendere 30 minuti affinché la cache cancella o riavvii MSExchangeOWAAppPool. Fare riferimento allo screenshot seguente in Exchange Server 2013

Screenshot della finestra gestione IIS con MSExchangeOWAAppPool selezionato.

Annotazioni

Anche il client riceve un cookie dal server di Accesso Client di Exchange 2013 con il percorso del server back-end. Questo cookie è valido per 10 minuti. Il riavvio di MSExchangeOWAAppPool potrebbe non risolvere il problema se si tenta di connettersi entro 10 minuti dallo spostamento della cassetta postale. In questo scenario, è necessario rimuovere i cookie dal browser. Per rimuovere i cookie in Microsoft Internet Explorer, seguire questa procedura:

  1. Passare a Internet Explorer, aprire Opzioni Internet.
  2. Nella scheda Generale fare clic su Elimina.
  3. Selezionare l'opzione Cookie e dati del sito Web e quindi fare clic su Elimina.

Soluzione 3: Riabilitare l'ereditarietà delle autorizzazioni per l'oggetto utente che presenta problemi durante l'accesso a OWA o ECP

  1. Avviare ADSI Edit facendo clic su Start, su Esegui, digitare adsiedit.msc e quindi fare clic su OK.
  2. Individuare l'oggetto utente in questione, fare clic con il pulsante destro del mouse sull'oggetto e quindi scegliere Proprietà.
  3. Nella scheda Sicurezza fare clic su Avanzate.
  4. Fai clic su Consenti alle autorizzazioni ereditabili dall'elemento padre di propagarsi a questo oggetto e a tutti gli oggetti figlio per riabilitare l'ereditarietà delle autorizzazioni.
  5. Fare clic su OK due volte per applicare la modifica.
  6. Attendere che la replica di Active Directory propaghi le modifiche, oppure forzare la replica di Active Directory, se necessario.

Se l'opzione Consenti autorizzazioni ereditabili viene disabilitata automaticamente entro 60 minuti, verificare se l'account utente si trova nel gruppo protetto di Active Directory, come AdminSDHolder. In caso affermativo, rimuovere l'account dal gruppo protetto di Active Directory.

Soluzione alternativa

Per risolvere questo problema, è possibile accedere all'interfaccia di amministrazione di Exchange aggiungendo la versione di Exchange all'URL. Ad esempio, per accedere all'interfaccia di amministrazione di Exchange la cui directory virtuale è ospitata nel server Accesso client di Exchange Server 2013, usare l'URL : https:///ecp?ExchClientVer=15.

Se si desidera accedere a Exchange 2010 ECP e la cassetta postale si trova in un server Cassette postali di Exchange 2013, usare l'URL: https:///ecp?ExchClientVer=14.

Per altre informazioni sull'interfaccia di amministrazione di Exchange, vedere Interfaccia di amministrazione di Exchange in Exchange 2013.