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"Impossibile reimpostare la password dell'utente" quando un amministratore reimposta la password di un utente membro di dominio

Problema

Si consideri lo scenario seguente: un utente non può accedere a un servizio cloud Microsoft, ad esempio Microsoft 365, Microsoft Azure o Microsoft Intune usando un ID utente membro di un dominio del servizio cloud precedentemente configurato per l'accesso Single Sign-On (SSO). In questo scenario, quando un amministratore del servizio cloud tenta di reimpostare la password dell'utente usando il portale del servizio cloud o il modulo di Azure Active Directory per Windows PowerShell, l'amministratore riceve il messaggio di errore seguente:

Impossibile reimpostare la password dell'utente. Riprova più tardi.

Motivo

Questo problema si verifica se l'utente è membro di un dominio del servizio cloud precedentemente abilitato per l'accesso Single Sign-On (SSO) e se l'ID utente non è stato convertito per l'uso dell'autenticazione standard.

Ad esempio, questo problema può verificarsi se è stato usato il cmdlet di Windows PowerShell seguente:

convert-MSOLDomainToStandard –skipuserconversion:$true 

Annotazioni

I moduli Azure AD e MSOnline PowerShell sono deprecati a partire dal 30 marzo 2024. Per maggiori informazioni, consultare l'aggiornamento sulla disattivazione. Dopo questa data, il supporto per questi moduli è limitato all'assistenza per la migrazione a Microsoft Graph PowerShell SDK e alle correzioni di sicurezza. I moduli deprecati continueranno a funzionare fino al 30 marzo 2025.

È consigliabile eseguire la migrazione a Microsoft Graph PowerShell per interagire con Microsoft Entra ID (in precedenza Azure AD). Per domande comuni sulla migrazione, consultare le Domande frequenti sulla migrazione. Nota: le versioni 1.0.x di MSOnline potrebbero subire interruzioni dopo il 30 giugno 2024.

Soluzione

Per risolvere questo problema, convertire l'ID utente in un tipo standard (non federato). Per fare questo, segui questi passaggi:

  1. Nella stessa console di Windows PowerShell usata per verificare il problema, digitare il cmdlet seguente e quindi premere INVIO:
    Convert-MsolFederatedUser -userprincipalname < user ID > 
    

    Annotazioni

    In questo cmdlet, il segnaposto <ID utente> rappresenta l'ID utente.

  2. Assegnare all'utente una password temporanea. La volta successiva che l'utente accede al servizio cloud, deve modificare la password temporanea prima di poter accedere alle risorse del servizio cloud.

Maggiori informazioni

Annotazioni

I cmdlet di Windows PowerShell in questo articolo richiedono il modulo Azure Active Directory per Windows PowerShell.

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