Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Numero KB originale: 2984311
Sintomi
In Microsoft Outlook non è possibile eseguire una ricerca immediata. I tentativi di ricerca immediata restituiscono i messaggi seguenti:
In Outlook 2010
Nessuna corrispondenza trovata per "<stringa di ricerca>".
Riprovare a eseguire la ricerca in Tutti gli elementi di posta elettronica
Se si seleziona Riprovare a eseguire la ricerca in Tutti gli elementi di posta, viene restituito:
Nessuna corrispondenza trovata per "<stringa di ricerca>".
In Outlook 2013
Non siamo riusciti a trovare quello che cercavi.
Trova di più sul server.
se il client Outlook è attualmente connesso a Microsoft Exchange Server. Se funziona offline, è possibile che venga visualizzato quanto segue:
Nessuna corrispondenza trovata. La ricerca è limitata agli ultimi 12 mesi perché il server non è disponibile.
Inoltre, in entrambi i casi, le opzioni di indicizzazione di Windows Search possono segnalare il completamento dell'indicizzazione.
Causa
Questo comportamento può verificarsi se è configurato il seguente valore del Registro di sistema:
HKEY_CURRENT_USER \Software\Microsoft\Office\x.0\Outlook\OST
Nome: NoOST
Tipo: qualsiasi tipo diverso da REG_DWORD
Dove x.0 è 15.0 per Outlook 2013 o 14.0 per Outlook 2010.
Il NoOST
valore del Registro di sistema deve essere creato come DWORD. Se configurato in modo non corretto, Windows Search non eseguirà l'indicizzazione dei dati di Outlook locali, con conseguente assenza di risultati restituiti nei tentativi di ricerca.
Risoluzione
Eliminare il NoOST
valore del Registro di sistema e, se necessario, ricrearlo come DWORD seguendo questa procedura.
Importante
In questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Se, tuttavia, si modifica il Registro di sistema in modo errato, possono verificarsi gravi problemi. Pertanto, assicurarsi di osservare attentamente la procedura seguente. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Successivamente, è possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e il ripristino del Registro di sistema, vedi Come eseguire il backup e il ripristino del Registro di sistema in Windows.
Uscire da Outlook.
Avviare l'editor del Registro di sistema seguendo i passaggi appropriati.
Windows 7
Dal menu Start selezionare Esegui, digitare regedit nella casella Apri e quindi selezionare OK.
Windows 8/8.1
Nella schermata Start digitare regedit e premere INVIO.
Individuare e selezionare la seguente chiave del Registro di sistema:
HKEY_CURRENT_USER \Software\Microsoft\Office\x.0\Outlook\OST
Dove x.0 è 15.0 per Outlook 2013 o 14.0 per Outlook 2010.
Fare clic con il pulsante destro del mouse sul valore NoOST, scegliere Elimina e selezionare Sì per confermare l'eliminazione.
Se necessario, dal menu Modifica selezionare Nuovo e selezionare Valore DWORD (32 bit).
Digitare NoOST e premere INVIO.
Scegliere Esci dal menu File per chiudere l'editor del Registro di sistema.