Condividi tramite


Le soluzioni MAPI non funzionano perché Outlook.exe non è registrato correttamente nella chiave \Percorsi app nel Registro di sistema

Numero KB originale: 2698523

Sintomi

Se si utilizza una soluzione MAPI personalizzata,ad esempio un componente aggiuntivo di Outlook, la soluzione potrebbe non funzionare perché Outlook.exe non è registrato correttamente nel Registro di sistema di Windows.

Nota

Il problema effettivo riscontrato con la soluzione personalizzata dipende dal modo in cui usa le informazioni di registrazione Outlook.exe.

Causa

Questo problema può verificarsi se Outlook.exe non è registrato correttamente nelle chiavi seguenti nel Registro di sistema di Windows:

  • Versioni a 32 bit di Windows

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths

  • Versioni a 64 bit di Windows

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths

Se Outlook.exe è registrato correttamente, troverai una sottochiave \Outlook.exe sotto la chiave precedente e nella sottochiave \Outlook.exe troverai un valore stringa chiamato Path i cui dati fanno riferimento al percorso corretto per Outlook.exe sul tuo computer. La figura seguente mostra la registrazione Outlook.exe corretta in una versione a 32 bit di Windows.

Screenshot della registrazione di Outlook.exe.

Nota

Il percorso di Outlook.exe nel computer può variare rispetto alla figura precedente se Office è stato installato in un percorso non predefinito.

Risoluzione

Per risolvere questo problema, ripristinare l'installazione di Office.