Rimozione o eliminazione di un elemento o di un progetto

Si applica a: SQL Server (tutte le versioni supportate) Database SQL di Azure Istanza gestita di SQL di Azure Azure Synapse Analytics Piattaforma di strumenti analitici (PDW)

Gli elementi nei progetti di SQL Server Management Studio sono query, connessioni e file esterni. È possibile rimuovere dalla soluzione query di progetto e file esterni senza cancellare i file dall'archivio. Rimuovere un progetto o un elemento quando non è utile nella soluzione corrente, ma si desidera includerlo in un'altra soluzione.

Per rimuovere un elemento di progetto

  1. In Esplora soluzioni selezionare l'elemento del progetto che si desidera rimuovere.

  2. Scegliere Rimuovi dal menu Modifica.

  3. Nella finestra di conferma fare clic su Rimuovi per rimuovere l'elemento dal progetto.

Un elemento rimosso rimane comunque nel file system. È pertanto possibile aggiungerlo alla soluzione originale o a un'altra soluzione.

Per rimuovere un progetto

  1. In Esplora soluzioni selezionare il progetto che si desidera rimuovere.

  2. Scegliere Rimuovi dal menu Modifica.

  3. Nella finestra di conferma fare clic su OKper rimuovere il progetto dalla soluzione.

È possibile eliminare un progetto in modo definitivo. In questo caso è necessario prima rimuovere tutti i riferimenti al progetto dalle soluzioni SQL Server Management Studio e quindi usare Esplora risorse per eliminare definitivamente i file associati dall'archivio.

Per eliminare un progetto

  1. In Esplora soluzioni rimuovere dalla soluzione il progetto che si desidera eliminare.

  2. In Esplora risorse individuare e selezionare i file associati al progetto o all'elemento da eliminare.

  3. Scegliere Elimina dal menu File.

Vedere anche

Esplora soluzioni
Aggiunta di nuovi elementi a un progetto
Aggiunta di elementi esistenti a un progetto