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Risolvere i problemi relativi al codice di errore "PublicIPCountLimitReached"

Questo articolo illustra come identificare e risolvere l'errore "PublicIPCountLimitReached" che si verifica quando si tenta di aggiornare un cluster servizio Azure Kubernetes (servizio Azure Kubernetes).

Prerequisiti

Questo articolo richiede l'interfaccia della riga di comando di Azure versione 2.0.65 o successiva. Per trovare il numero di versione, eseguire az --version. Se è necessario installare o aggiornare l'interfaccia della riga di comando di Azure, vedere Come installare l'interfaccia della riga di comando di Azure.

Per informazioni più dettagliate sul processo di aggiornamento, vedere la sezione "Aggiornare un cluster del servizio Azure Kubernetes" in Aggiornare un cluster servizio Azure Kubernetes (servizio Azure Kubernetes).

Sintomi

Un aggiornamento del cluster del servizio Azure Kubernetes non riesce e viene visualizzato un messaggio di errore "PublicIPCountLimitReached".

Causa

L'errore si verifica se è stato raggiunto il numero massimo di indirizzi IP pubblici consentiti per la sottoscrizione.

Soluzione

Per aumentare il limite o la quota per la sottoscrizione, passare alla portale di Azure, presentare un ticket di supporto per i limiti del servizio e della sottoscrizione (quote) e impostare il tipo di quota su Rete.

Dopo l'applicazione della modifica della quota, provare ad aggiornare il cluster alla stessa versione a cui si è tentato in precedenza di eseguire l'aggiornamento. Questo processo attiverà una riconciliazione.

az aks upgrade --resource-group <ResourceGroupName> --name <AKSClusterName> --kubernetes-version <KUBERNETES_VERSION>

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