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Risolvere i problemi relativi al codice di errore TooManyRequestsReceived o SubscriptionRequestsThrottled

Questo articolo illustra come identificare e risolvere l'errore TooManyRequestsReceived o SubscriptionRequestsThrottled che si verifica quando si tenta di eliminare un cluster microsoft servizio Azure Kubernetes (servizio Azure Kubernetes).

Sintomi

Quando si tenta di eliminare un cluster del servizio Azure Kubernetes, viene visualizzato il messaggio di errore seguente:

internalErrorCode: TooManyRequestsReceived

StatusCode: 429

{

messaggio: "Numero di richieste di lettura per la sottoscrizione '.....''' ha superato il limite di '....' per l'intervallo di tempo 'XX:XX:XX'. Riprovare dopo "....." secondi.

}

Causa

Ogni operazione a livello di sottoscrizione e di tenant è soggetta a limiti di limitazione. Questi limiti si applicano a ogni istanza di Azure Resource Manager. Quando si raggiunge il limite, si riceve una risposta HTTP che indica il codice di stato 429: "Troppe richieste".

Soluzione

La risposta HTTP include un Retry-After valore. In questo modo viene specificato il numero di secondi di attesa (o sospensione) dell'applicazione prima che invii la richiesta successiva. Se si invia una richiesta prima che sia trascorso il valore di ripetizione dei tentativi, la richiesta non viene elaborata e viene restituito un nuovo valore di ripetizione dei tentativi. Per altre informazioni sui limiti di limitazione, vedere Limitazione delle richieste Resource Manager richieste.

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