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Windows non può avviare Microsoft Monitoring Agent

Questo articolo consente di risolvere uno scenario in cui Windows non avvia Microsoft Monitoring Agent (l'agente di Log Analytics per Windows) nel computer locale. Quando si verifica questo problema, viene visualizzato un messaggio di errore "Il servizio Microsoft Monitoring Agent terminato con l'errore specifico del servizio Accesso negato".

Prerequisiti

Sintomi

Quando si apre lo snap-in Servizi (services.msc) per tentare di avviare il servizio Microsoft Monitoring Agent , viene visualizzata una finestra di dialogo che visualizza il messaggio di errore seguente:

Impossibile avviare Microsoft Monitoring Agent nel computer locale. Per altre informazioni, vedere registro eventi di sistema. Se si tratta di un servizio non Microsoft, contattare il fornitore del servizio e fare riferimento al codice di errore specifico del servizio 5.

Nello snap-in Visualizzatore eventi (eventvwr.msc), il registro eventi di sistema corrispondente mostra una voce di errore "Accesso negato":

Log Name:      System
Source:        Service Control Manager
Date:          8/19/2021 3:03:27 PM
Event ID:      7024
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      ContosoServer2k8R2
Description:
The Microsoft Monitoring Agent service terminated with service-specific error Access is denied.

Causa

Il Registro di sistema nega l'accesso in lettura/scrittura da Microsoft Monitoring Agent al parametro SecureStorageManager . Per verificare questo scenario, seguire questa procedura dopo che viene visualizzato il messaggio di errore "Accesso negato":

  1. Aprire Monitoraggio processo.

  2. Cercare una voce con i valori seguenti:

    Colonna Valore
    Nome processo HealthService.exe
    Operazione RegOpenKey
    Percorso HKLM\SYSTEM\CurrentControlSet\Services\HealthService\Parameters\SecureStorageManager
    Risultato ACCESSO NEGATO
    Dettagli Accesso desiderato: lettura/scrittura
  3. Selezionare Start, immettere regedit e quindi selezionare Registro di sistema Editor.

  4. In Registro di sistema Editor selezionare il menu Visualizza. Se accanto alla barra degli indirizzi non è presente alcun segno di spunta, selezionare tale voce di menu.

  5. Nella barra degli indirizzi (sotto il menu e sopra il riquadro di spostamento) eliminare il testo esistente, immettere HKLM\SYSTEM\CurrentControlSet\Services\HealthService\Parameters\SecureStorageManager e quindi premere INVIO.

  6. Scegliere Modifica>autorizzazioni dal menu.

  7. Nella finestra di dialogo Autorizzazioni per SecureStorageManager verificare che la casella Nomi di gruppo o utente contenga voci per SYSTEM e Administrators (ComputerName).In the Permissions for SecureStorageManager dialog box, assicurarsi che la casella Group or user names has entries for SYSTEM and Administrators (<ComputerName>). Per ognuna di queste voci, esaminare la riga Controllo completo nella casella Autorizzazioni per <GroupOrUserName> per verificare se la colonna Consenti è selezionata.

Il controllo completo non è consentito in modo esplicito per l'utente di sistema o il gruppo di amministratori? In caso affermativo, qualcuno ha modificato le autorizzazioni predefinite. A causa di questa modifica, Microsoft Monitoring Agent non dispone più dell'autorizzazione per accedere al parametro SecureStorageManager .

Le autorizzazioni predefinite possono essere modificate se si verificano le condizioni seguenti:

  • Il server è sottoposto a protezione avanzata.

  • Un utente, un'applicazione o uno script modifica le autorizzazioni predefinite in modo da essere inferiori al livello di lettura/scrittura all'interno del Registro di sistema.

Soluzione

Ripristinare il controllo completo nel parametro SecureStorageManager per l'utente di sistema e gli amministratori. A tal fine, attenersi alla seguente procedura:

Avviso

L'errata modifica del Registro di sistema tramite l'editor o un altro metodo può causare seri problemi. che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di tali problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

  1. (Scelta consigliata) Eseguire il backup del Registro di sistema.

  2. Tornare o riaprire il Editor del Registro di sistema.

  3. Nella barra degli indirizzi immettere nuovamente il percorso del Registro di sistema per il parametro SecureStorageManager (HKLM\SYSTEM\CurrentControlSet\Services\HealthService\Parameters\SecureStorageManager), quindi premere INVIO.

  4. Selezionare Modifica>autorizzazioni e quindi riapplicare l'autorizzazione predefinita in Controllo completo (Consenti) per l'utente SYSTEM e il gruppo Administrators (<ComputerName>).

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