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Errore AADSTS750054: SAMLRequest o SAMLResponse deve essere presente come parametri della stringa di query nella richiesta HTTP per l'associazione di reindirizzamento SAML

Questo articolo descrive un problema in cui viene visualizzato il messaggio di errore "Error AADSTS750054 - SAMLRequest or SAMLResponse must be present as query string parameters in HTTP request for SAML Redirect binding." (Errore AADSTS750054 - SAMLRequest o SAMLResponse deve essere presente come parametri di stringa di query nella richiesta HTTP per l'associazione di reindirizzamento SAML)." quando si tenta di accedere a un'app configurata per l'accesso Single Sign-On (SSO) basato su SAML integrata con Microsoft Entra ID.

Sintomi

Viene visualizzato un errore AADSTS750054 durante il tentativo di accedere a un'applicazione configurata per l'uso di Microsoft Entra ID per la gestione delle identità tramite l'accesso SSO basato su SAML.

Causa

Microsoft Entra ID non è stato in grado di identificare la richiesta SAML all'interno dei parametri URL nella richiesta HTTP. Ciò può verificarsi se l'applicazione non usa l'associazione di reindirizzamento HTTP quando invia la richiesta SAML a Microsoft Entra ID.

Risoluzione

L'applicazione deve inviare la richiesta SAML codificata nell'intestazione della posizione usando l'associazione di reindirizzamento HTTP. Per altre informazioni su come implementarlo, vedere la sezione Associazione di reindirizzamento HTTP nel documento di specifica del protocollo SAML.

Molto spesso, l'errore è dovuto a uno dei problemi seguenti:

  1. Assicurarsi che l'accesso Single Sign-On sia abilitato sul lato applicazione.
  2. L'applicazione deve supportare l'accesso Single Sign-On avviato dal provider di servizi (noto anche come SSO avviato da SP). Quando si immette un URL di accesso per un'applicazione che supporta solo l'accesso Single Sign-On avviato dal provider di identità, può causare un rimbalzo dall'applicazione senza una risposta SAML.
  3. Verificare che l'URL di accesso sia configurato correttamente.

Uso della funzione SSO di test nel Interfaccia di amministrazione di Microsoft Entra

Il Interfaccia di amministrazione di Microsoft Entra consente di risolvere gli errori di configurazione SAML.

Screenshot della funzionalità Test SSO in Interfaccia di amministrazione di Microsoft Entra.

  1. Nella Interfaccia di amministrazione di Microsoft Entra passare ad Applicazioni aziendali e fare clic sull'applicazione che richiede la risoluzione dei problemi.
  2. Passare alla pagina Single Sign-On usando il menu di spostamento a sinistra
  3. Fare clic su Test questa applicazione per usare la funzionalità Test SSO.
  4. Copiare e incollare l'errore ricevuto nella sezione Risoluzione degli errori e fare clic su Ottieni indicazioni sulla risoluzione
  5. Seguire la procedura per risolvere gli errori AADSTS750054

Ulteriori informazioni

Per un elenco completo dei codici di errore di autenticazione e autorizzazione di Active Directory, vedere Microsoft Entra codici di errore di autenticazione e autorizzazione

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