Gli utenti non possono più accedere dopo aver eseguito il comando Convert-MSOLDomaintoFederated per convertire un dominio esistente

Questo articolo fornisce informazioni sulla risoluzione di un problema per cui gli utenti non possono più accedere a Office 365, Azure o Microsoft Intune dopo aver eseguito il Convert-MSOLDomaintoFederated comando per convertire un dominio esistente dall'autenticazione standard all'autenticazione federata.

Versione originale del prodotto: Servizi cloud (Ruoli Web/Ruoli di lavoro), Microsoft Entra ID, Microsoft Intune, Backup di Azure, Gestione delle identità di Office 365
Numero KB originale: 2662960

Nota

I moduli di PowerShell di Azure AD e MSOnline sono deprecati a partire dal 30 marzo 2024. Per altre informazioni, vedere l'aggiornamento della deprecazione. Dopo questa data, il supporto per questi moduli è limitato all'assistenza per la migrazione a Microsoft Graph PowerShell SDK e alle correzioni per la sicurezza. I moduli deprecati continueranno a funzionare fino al 30 marzo 2025.

È consigliabile eseguire la migrazione a Microsoft Graph PowerShell per interagire con Microsoft Entra ID (in precedenza Azure AD). Per domande frequenti sulla migrazione, vedere Domande frequenti sulla migrazione. Nota: Le versioni 1.0.x di MSOnline potrebbero verificarsi interruzioni dopo il 30 giugno 2024.

Sintomi

Durante la configurazione dell'accesso Single Sign-On (SSO) in un servizio cloud Microsoft, ad esempio Office 365, Microsoft Azure o Microsoft Intune, eseguire il Convert-MSOLDomaintoFederated comando per convertire un dominio esistente dall'autenticazione standard all'autenticazione federata. Tuttavia, dopo aver eseguito questa operazione, gli utenti associati a tale dominio non possono più accedere al servizio cloud.

Causa

Questo problema si verifica se l'accesso SSO non è configurato correttamente o se l'installazione non è stata completata.

Avviso

È consigliabile microsoft avere sempre almeno un ID utente amministratore associato al dominio predefinito in modo che l'accesso amministrativo all'organizzazione non vada perso se l'accesso SSO viene compromesso.

Risoluzione

Per risolvere il problema, utilizzare uno dei metodi seguenti, a seconda della situazione.

Metodo 1: Risolvere i problemi di installazione dell'accesso SSO

Utilizzare questo metodo solo se tutte le condizioni seguenti sono vere:

  • Il problema non è causato da un'interruzione del servizio.
  • Il ripristino immediato dell'accesso utente non è necessario.

Per diagnosticare e risolvere i problemi di installazione dell'accesso Single Sign-On, vedere Risolvere i problemi di installazione dell'accesso Single Sign-On in Office 365, Intune o Azure.

Metodo 2: Ripristinare l'autenticazione standard della federazione del dominio se il server AD FS non è disponibile

Utilizzare questo metodo solo se tutte le condizioni seguenti sono vere:

  • Il problema è causato da un'interruzione del servizio che richiede il ripristino immediato dell'accesso utente.
  • Il server AD FS non è disponibile.

Se queste condizioni sono vere, reimpostare l'impostazione di autenticazione per il dominio e per ogni account utente in modo che usi l'autenticazione standard. A tal fine, attenersi alla seguente procedura:

  1. Avviare il modulo Azure Active Directory per Windows PowerShell. A tale scopo, selezionare Start, tutti i programmi, Windows Azure Active Directory, fare clic con il pulsante destro del mouse sul modulo Windows Azure Active Directory per Windows PowerShell e quindi scegliere Esegui come amministratore.

  2. Per convertire il dominio, eseguire i comandi seguenti nell'ordine in cui vengono presentati. Premere INVIO dopo aver digitato ogni comando.

    $cred = Get-Credential
    

    Quando viene richiesto, immettere le credenziali di amministratore del servizio cloud non abilitate per l'accesso SSO.

    Connect-MsolService -credential $cred
    
    Set-MSOLDomainAuthentication -Authentication Managed -DomainName <federated domain name>
    

    Nota

    In questo comando, il nome> di dominio federato segnaposto <rappresenta il nome del dominio per il quale l'accesso SSO non funziona.

  3. Per ogni utente con un suffisso UPN (User Principal Name) associato al dominio, eseguire il comando seguente:

    Convert-MSOLFederatedUser -UserPrincipalName <string>
    

    Nota

    In questo comando la stringa> segnaposto <rappresenta il valore dell'UPN per l'utente che viene convertito.

Ulteriori informazioni

Importante

Negli scenari in cui all'ultimo amministratore dell'organizzazione dei servizi cloud Microsoft viene assegnato il suffisso di dominio di un dominio federato e in cui tale amministratore diventa abilitato per l'accesso SSO, i successivi errori di AD FS limiteranno l'esecuzione del comando connect-MSOLService e potrebbero impedire la correzione dei problemi di accesso SSO. È consigliabile che gli amministratori dell'organizzazione dei servizi cloud Microsoft mantengano sempre almeno un account amministratore globale non abilitato per l'accesso Single Sign-On per la risoluzione dei problemi relativi all'accesso Single Sign-On usando il modulo Azure Active Directory per Windows PowerShell.

Se si verifica questo problema, contattare supporto tecnico Microsoft per annullare temporaneamente la federazione del dominio in modo che l'amministratore (che non è più abilitato per l'accesso SSO) possa ottenere nuovamente l'accesso per risolvere i problemi correlati all'accesso SSO.

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