Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Si applica a: ✔️ macchine virtuali di Windows
Numero KB originale: 4010137
Questo articolo fornisce una soluzione a un problema per cui la macchina virtuale Windows non inizia con il codice di errore 0xc0000098.
Sintomi
Windows non viene avviato. Il sistema genera invece un errore simile al seguente:
File: \<BINARY>
Stato: 0xc0000098
Info: Windows non è riuscito a caricare perché un driver di sistema critico è mancante o danneggiato.
In questo messaggio <BINARY> rappresenta il file binario effettivo trovato.
Causa
Questo problema si verifica se un file binario proviene da una versione diversa di Windows rispetto al sistema operativo della macchina virtuale.
Risoluzione
Suggerimento
Se hai un backup recente della VM, puoi provare a ripristinare la VM dal backup per risolvere il problema di avvio.
Per risolvere il problema, seguire questa procedura.
Passaggio 1: collegare il disco del sistema operativo della macchina virtuale a un'altra macchina virtuale come disco dati
- Eliminare la macchina virtuale.Delete the virtual machine (VM). Assicurarsi di selezionare l'opzione Mantieni i dischi quando si esegue questa operazione.
- Collegare il disco del sistema operativo come disco dati a un'altra macchina virtuale (una macchina virtuale per la risoluzione dei problemi). Per altre informazioni, vedere Come collegare un disco dati a una macchina virtuale Windows in portale di Azure.
- Connettersi alla VM per la risoluzione dei problemi. Apri Gestione computer>Gestione disco. Assicurarsi che il disco del sistema operativo sia online e che alle relative partizioni siano assegnate lettere di unità.
Passaggio 2: Ripristinare o sostituire il file binario
Ripristinare o sostituire il file binario di sistema (.sys) seguendo questa procedura:
Ripristinare il file binario danneggiato
Aprire un prompt cmd con privilegi elevati ed eseguire chkdsk sul disco:
chkdsk <drive-letter>: /F
Sostituire il file binario danneggiato
Nel disco collegato passare al percorso del file binario mostrato nel messaggio di errore.
Rinominare il file da binary-name>.sys in< binary-name>.sys.old.<
Sul disco collegato passare alla cartella \Windows\WinSxS . Cercare quindi il file binario mostrato nel messaggio di errore. Per effettuare questa operazione, eseguire il seguente comando dal prompt di comandi:
dir <binary-name> /s
Il comando elenca tutte le diverse versioni del file binario insieme alla data di creazione. Copiare la versione più recente del file binario nella cartella \Windows\System32\Drivers eseguendo il comando seguente:
copy <drive>:\Windows\WinSxS\<directory-where-file-is>\<binary-name>.sys <drive>:\Windows\System32\Drivers\
Ad esempio, vedere l'output della console seguente:
E:\Windows\WinSxS>dir ACPI.sys /s Volume in drive E has no label. Volume Serial Number is A0B1-C2D3 Directory of E:\Windows\WinSxS\amd64_acpi.inf_0123456789abcdef_6.3.9600.16384_none_cdef0123456789ab 11/21/2014 07:48 PM 94,989 acpi.sys 1 File(s) 94,989 bytes Directory of E:\Windows\WinSxS\amd64_acpi.inf_0123456789abcdef_6.3.9600.16384_none_89abcdef01234567 11/21/2014 07:48 PM 119,547 acpi.sys 1 File(s) 119,547 bytes Directory of E:\Windows\WinSxS\amd64_acpi.inf_0123456789abcdef_6.3.9600.16384_none_456789abcdef0123 11/21/2014 04:06 PM 533,824 acpi.sys 1 File(s) 533,824 bytes Total Files Listed: 3 File(s) 748,360 bytes 0 Dir(s) 123,967,512,576 bytes free E:\Windows\WinSxS>copy E:\Windows\WinSxS\amd64_acpi.inf_0123456789abcdef_6.3.9600.16384_none_cdef0123456789ab\acpi.sys E:\Windows\System32\Drivers\ 1 file(s) copied. E:\Windows\WinSxS>
Note
Se il file binario di sistema non può essere rinominato, assumere la proprietà del file. Questa azione consente l'accesso completo a questo file.
L'output della console di esempio mostra il volume E come esempio. La lettera effettiva deve riflettere l'unità difettosa (il disco del sistema operativo collegato come disco dati nella macchina virtuale per la risoluzione dei problemi).
Se il file binario più recente non funziona, è possibile provare la versione precedente del file per ottenere un livello di aggiornamento del sistema precedente su tale componente.
Se l'unico file binario restituito in questo passaggio corrisponde al file che si sta tentando di sostituire nella macchina virtuale interessata, e se entrambi i file hanno le stesse dimensioni e timestamp, è possibile sostituire il file danneggiato copiandolo da un'altra macchina virtuale funzionante con lo stesso sistema operativo e, se possibile, lo stesso livello di aggiornamento del sistema.
Scollegare il disco ripristinato dalla macchina virtuale per la risoluzione dei problemi. Creare quindi una macchina virtuale dal disco del sistema operativo.
Contattaci per ricevere assistenza
In caso di domande o bisogno di assistenza, creare una richiesta di supporto tecnico oppure formula una domanda nel Supporto della community di Azure. È possibile anche inviare un feedback sul prodotto al feedback della community di Azure.