Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Si applica a: ✔️ macchine virtuali di Windows
Questo articolo illustra come risolvere i problemi relativi all'ID evento 157, uno scenario in cui un disco dati è scomparso, è stato perso o è stato rimosso dal sistema operativo guest Windows di una macchina virtuale (VM) di Microsoft Azure.
Sintomi
È possibile scoprire che si è verificata una rimozione del disco se si verifica uno dei sintomi seguenti:
I dischi sembrano essere collegati nel portale di Azure anche se il sistema operativo guest segnala i dischi come rimossi dalla macchina virtuale.
I dischi all'interno di ambienti cluster SQL e macchine virtuali di Azure vengono rimossi in modo imprevisto, causando interruzioni nei carichi di lavoro.
I server e i dati basati su Microsoft SQL Server vengono compromessi a causa di queste rimozioni impreviste del disco.
Carico di lavoro eccessivo, impostazioni del Registro di sistema configurate in modo errato e memoria insufficiente vengono identificati come potenziali trigger per l'ID evento 157.
Se si verificano questi sintomi, aprire l'app Visualizzatore eventi nella macchina virtuale Windows per esaminare. Selezionare il nodo di sistema Visualizzatore eventi (locale)>Log>di Windows nel riquadro Albero della console. Nell'elenco eventi selezionare l'etichetta di colonna ID evento da ordinare in base all'ID evento, quindi cercare e fare doppio clic sulla voce di log con un valore di ID evento pari a 157. Nella scheda Generale della finestra di dialogo Proprietà evento vengono visualizzate informazioni simili alla tabella seguente.
Campo evento | Valore |
---|---|
Nome log | Sistema |
Origine | disk |
Registrato (data) | <timestamp> |
ID evento | 157 |
Categoria attività | None |
Level | Avviso |
Parole chiave | Classico |
Utente | N/D |
Computer | SERVER-hash-value.domain1.priv<> |
Descrizione | Il numero> del disco <è stato rimosso a sorpresa. |
Causa
La scomparsa del disco si verifica più spesso quando qualcosa interrompe la comunicazione tra il sistema e il disco, ad esempio un errore di infrastruttura di rete di archiviazione (SAN) o un problema del bus SCSI (Small Computer System Interface). In alternativa, è possibile che si verifichi una scomparsa del disco se un disco non riesce o si scollega un disco durante l'esecuzione del sistema operativo.
L'ID evento 157 si verifica all'interno del sistema operativo guest (o durante il funzionamento di un ruolo Windows Failover Clustering). Ciò si verifica in genere a causa dei fattori sottostanti seguenti:
Un carico di lavoro di I/O eccessivo causa ritardi di limitazione e I/O. Questi problemi, a loro volta, causano che il disco raggiunga la soglia di timeout di I/O.
La sottochiave del Registro di sistema HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\disk non è configurata correttamente. In particolare, la voce del Registro di sistema IoTimeoutValue all'interno di tale sottochiave è impostata su un valore troppo piccolo, ad esempio 60 secondi.
Note
Se il valore di timeout è troppo piccolo, aumentare questo valore, ma non usare un valore superiore a 179 secondi. Dopo un ritardo di 180 secondi, il sistema richiama l'ID evento 17 all'interno del nodo host e attiva il riavvio della macchina virtuale.
È stata eseguita una convalida del cluster all'interno del sistema operativo guest per controllare l'archiviazione locale nel nodo del cluster. Ovvero, un'operazione intenzionale ha causato l'ID evento 157.
Esiste una condizione di memoria insufficiente all'interno della macchina virtuale.
Soluzione
Le indicazioni per la correzione del problema di scomparsa del disco variano a seconda che i dischi si trovino in un ambiente cluster o in un ambiente non cluster.
Eseguire lo strumento di diagnostica self-help per PerfInsights .
Se si usa un ruolo Windows Failover Clustering, raccogliere i log del cluster windows per il periodo di tempo interessato. Se PerfInsights non ha raccolto questi log, eseguire il cmdlet Get-ClusterLog in PowerShell.
Ottenere l'impostazione del Registro di sistema per il timeout del disco esaminando il report PerfInsights.
Verificare la presenza di un'impostazione del Registro di sistema non configurata correttamente nel sistema operativo guest. Se è presente anche una limitazione eccessiva delle operazioni di I/O, questo scenario potrebbe spiegare perché viene raggiunta la soglia di timeout.
Eseguire l'aggiornamento da HDD Standard (unità disco rigido) a un tipo di disco gestito di Azure diverso. È consigliabile non eseguire un ruolo del cluster che usa dischi RIGIDI di archiviazione standard perché possono causare problemi come la scomparsa del disco.
Contenuto correlato
Contattaci per ricevere assistenza
In caso di domande o bisogno di assistenza, creare una richiesta di supporto tecnico oppure formula una domanda nel Supporto della community di Azure. È possibile anche inviare un feedback sul prodotto al feedback della community di Azure.