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Si applica a: ✔️ macchine virtuali di Windows
Questo articolo aiuta a risolvere il problema quando non è possibile connettersi a una macchina virtuale di Azure (VM) perché non è disponibile un server licenze Desktop remoto per fornire una licenza.
Sintomi
Quando provi a connetterti a una macchina virtuale, potresti riscontrare i seguenti scenari:
Lo screenshot della VM mostra che il sistema operativo è completamente caricato e in attesa delle credenziali.
Quando si tenta di stabilire una connessione Microsoft Remote Desktop Protocol (RDP), vengono visualizzati i seguenti messaggi di errore:
La sessione remota è stata disconnessa perché non sono disponibili server licenze Desktop remoto in grado di fornire una licenza.
Non è disponibile alcun server licenze Desktop remoto. Servizi Desktop remoto smetterà di funzionare perché questo computer ha superato il periodo di tolleranza e non ha contattato nessun server di licenze Windows Server 2008 valido. Selezionare questo messaggio per aprire Configurazione server host sessione Desktop remoto per utilizzare Diagnosi gestione licenze.
Si è verificato un errore di licenza durante il tentativo di connessione del client (licenza scaduta). Prova a connetterti nuovamente al computer remoto.
La connessione RDP sembra essere bloccata nello stato "Configurazione sessione remota".
Causa
Questo problema si verifica se un server licenze Desktop remoto non è disponibile per fornire una licenza per avviare una sessione remota. Può essere causato da diversi scenari, anche se sulla VM è stato impostato un ruolo Host sessione Desktop remoto:
- Non è mai stato presente un ruolo Servizio licenze Desktop remoto nell'ambiente e il periodo di grazia di 180 giorni è terminato.
- Una licenza Desktop remoto è stata installata nell'ambiente, ma non è mai stata attivata.
- Una licenza Desktop remoto dispone di licenze di accesso client (CAL) ed è stata attivata. Tuttavia, vi sono più utenti attivi rispetto alle CAL disponibili.
- Una licenza Desktop remoto nell'ambiente non prevede l'inserimento di licenze CAL per configurare la connessione.
- Nell'ambiente è stata installata una licenza Desktop remoto. Sono disponibili CAL, ma non sono state configurate correttamente.
- Una licenza Desktop remoto dispone di CAL ed è stata attivata. Tuttavia, alcuni altri problemi sul server licenze Desktop remoto gli impediscono di fornire licenze nell'ambiente.
Soluzione
Per risolvere questo problema, esegui il backup del disco del sistema operativo e segui questi passaggi:
Connettersi alla macchina virtuale tramite una sessione amministrativa. Per fare ciò, utilizzare uno dei seguenti modi:
Esegui questo comando:
mstsc /v:<Server>[:<Port>] /admin
Nel portale di Azure, vai alla macchina virtuale, seleziona Connetti in Impostazioni. Nel pannello di destra, seleziona Scarica file RDP per scaricare un file di connessione.
Se non riesci a connetterti alla macchina virtuale tramite una sessione amministrativa, puoi usare la Virtual Machine Serial Console in Azure per accedere alla macchina virtuale come segue:
Accedere a Console seriale selezionando Supporto e risoluzione dei problemi>Console seriale. Se la funzionalità è abilitata sulla macchina virtuale, è possibile connettere correttamente la macchina virtuale.
Crea un nuovo canale per un'istanza CMD. Immettere CMD per avviare il canale e ottenere il nome del canale.
Passa al canale che esegue l'istanza CMD. In questo caso, dovrebbe essere il canale 1:
ch -si 1
Seleziona di nuovo Invio e inserisci un nome utente e una password validi, un ID locale o di dominio, per la VM.
Controlla se la VM ha un ruolo Host sessione Desktop remoto abilitato. Se il ruolo è abilitato, assicurati che funzioni correttamente. Apri un'istanza CMD con privilegi elevati e segui questi passaggi:
Utilizzare il comando seguente per verificare lo stato del ruolo Host sessione Desktop remoto:
reg query "HKLM\SOFTWARE\Microsoft\ServerManager\ServicingStorage\ServerComponentCache\RDS-RD-Server" /v InstallState
Se questo comando restituisce un valore pari a 0, significa che il ruolo è disabilitato e puoi andare al passaggio 3.
Utilizzare il seguente comando per verificare le politiche e riconfigurare secondo necessità:
reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core" /v LicensingMode reg query "HKLM\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers" /v SpecifiedLicenseServers
Se il valore LicensingMode è impostato su qualsiasi valore diverso da 4, per utente, imposta il valore su 4:
reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core" /v LicensingMode /t REG_DWORD /d 4
Se il valore SpecifiedLicenseServers non esiste o contiene informazioni sul server delle licenze non corrette, modificarlo come segue:
reg add "HKLM\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers" /v SpecifiedLicenseServers /t REG_MULTI_SZ /d "<FQDN / IP License server>"
Dopo aver apportato modifiche al registro, riavviare la VM.
Se non disponi di licenze CAL o non hai bisogno di più di due utenti simultanei, rimuovi il ruolo Host sessione Desktop remoto. Quindi RDP verrà ripristinato per consentire solo due connessioni RDP simultanee alla VM:
dism /ONLINE /Disable-feature /FeatureName:Remote-Desktop-Services
Se la VM ha il ruolo di licenza Desktop remoto e non è utilizzata, puoi anche rimuovere quel ruolo:
dism /ONLINE /Disable-feature /FeatureName:Licensing
Assicurati che la macchina virtuale possa connettersi al server licenze Desktop remoto. Puoi testare la connettività alla porta 135 tra la VM e il server delle licenze:
telnet <FQDN / IP License Server> 135
Se nell'ambiente non è presente un server licenze Desktop remoto e se ne desidera uno, è possibile installare un servizio ruolo di licenza Desktop remoto. Quindi configurare la licenza RDS.
Se un server licenze Desktop remoto è configurato e integro, assicurati che il server licenze Desktop remoto sia attivato con licenze CAL.
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