Condividi tramite


Avvio del sistema operativo: il computer è stato riavviato in modo imprevisto o si è verificato un errore imprevisto

Si applica a: ✔️ macchine virtuali di Windows

Questo articolo fornisce i passaggi per risolvere i problemi in cui la macchina virtuale (VM) riscontra un riavvio imprevisto o un errore durante l'installazione di Windows.

Sintomo

Quando utilizzi Diagnostica di avvio per visualizzare lo screenshot della VM, vedrai che lo screenshot mostra l'errore di installazione di Windows con il seguente errore:

Il computer è stato riavviato in modo imprevisto o si è verificato un errore imprevisto. L'installazione di Windows non può procedere. Per installare Windows, fare clic su "OK" per riavviare il computer, quindi riavviare l'installazione.

Screenshot dell'errore durante l'installazione di Windows.

Screenshot dell'errore quando il programma di installazione di Windows sta avviando i servizi.

Causa

La macchina sta tentando di eseguire un avvio iniziale di un'immagine generalizzata, ma riscontra problemi a causa dell'elaborazione di un file di risposta personalizzato (Unattend.xml). I file di risposta personalizzati non sono supportati in Azure.

Il file di risposte è un file XML speciale che contiene definizioni e valori delle impostazioni per le impostazioni di configurazione che si desidera automatizzare durante l'installazione di un'installazione del sistema operativo Windows Server. Le opzioni di configurazione includono istruzioni su come partizionare i dischi, dove trovare l'immagine di Windows da installare, i codici Product Key da applicare e altri comandi che si desidera eseguire.

Anche in questo caso, i file di risposta personalizzati non sono supportati in Azure. Pertanto, questa situazione si verifica se un'immagine è stata preparata per l'uso in Azure, ma è stato specificato un file Unattend.xml personalizzato utilizzando SYSPREP con un flag, simile al comando seguente:

sysprep /oobe /generalize /unattend:<your file's name> /shutdown

In Azure, utilizzare l'opzione Passare alla Configurazione guidata nella GUI dell'unità preparazione sistema oppure utilizzare sysprep /oobe anziché il file Unattend.xml.

Questo problema viene spesso creato mentre si usa Sysprep con una macchina virtuale locale per caricare una macchina virtuale generalizzata in Azure. In questa situazione, potresti anche essere interessato a come caricare correttamente una VM generalizzata.

Soluzione

Provare a ripristinare la macchina virtuale da un backup

Se hai un backup recente della VM, puoi provare a ripristinare la VM dal backup per risolvere il problema di avvio. Se non è possibile ripristinare la macchina virtuale dal backup, seguire i passaggi della sezione Do not use Unattend.xml.

Non utilizzare Unattend.xml

Per risolvere questo problema, segui le indicazioni di Azure sulla preparazione/acquisizione di un'immagine e prepara una nuova immagine generalizzata. Durante l'installazione sysprep, non utilizzare il flag /unattend:<your file's name>. Utilizzare invece solo i seguenti flag:

sysprep /oobe /generalize /shutdown

  • Out-of-box-experience (OOBE) è l'impostazione supportata per le macchine virtuali di Azure.

È inoltre possibile utilizzare Strumento di preparazione del sistema GUI per eseguire la stessa attività del comando precedente, selezionando le seguenti opzioni:

  • Entra nell'esperienza pronta all'uso
  • Generalizza
  • Arresto

Screenshot della finestra Utilità preparazione sistema con le opzioni Configurazione giuidata, Generalizza e Arresta selezionate.

Contattaci per ricevere assistenza

In caso di domande o bisogno di assistenza, creare una richiesta di supporto tecnico oppure formula una domanda nel Supporto della community di Azure. È possibile anche inviare un feedback sul prodotto al feedback della community di Azure.