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Si applica a: ✔️ macchine virtuali di Windows
Questo articolo fornisce i passaggi per risolvere i problemi in cui la macchina virtuale (VM) non risponde durante l'applicazione del criterio di configurazione dei criteri di controllo, che impedisce l'avvio di una macchina virtuale di Azure.
Sintomo
Quando utilizzi Diagnostica di avvio per visualizzare lo screenshot della VM, noterai che lo screenshot mostra che il sistema operativo (SO) non ha risposto durante un avvio con il messaggio Applicazione del criterio di configurazione del criterio di controllo.
Causa
Ci sono blocchi in conflitto quando il criterio tenta di ripulire i vecchi profili utente.
Note
Questo vale solo per Windows Server 2012 e Windows Server 2012 R2.
Ecco il criterio problematico: Configurazione computer\Criteri\Modelli amministrativi\Sistema/Profili utente\Elimina i profili utente più vecchi di un numero specificato di giorni al riavvio del sistema.
Soluzione
Panoramica processo
Suggerimento
Se hai un backup recente della VM, puoi provare a ripristinare la VM dal backup per risolvere il problema di avvio.
- Crea e accedi a una macchina virtuale di riparazione.
- Disabilitare il criterio.
- Abilita la console seriale e la raccolta di dump della memoria.
- Ricostruisci la macchina virtuale.
- Raccogli il file di dump della memoria e invia un ticket di supporto.
Creare e accedere a una macchina virtuale di ripristino
- Utilizzare i passaggi 1-3 dei comandi di riparazione della VM per preparare una VM di riparazione.
- Utilizzando Connessione desktop remoto, connettiti alla VM di riparazione.
Disabilitare il criterio
Nella VM di riparazione, apri l'Editor del registro.
Individua la chiave HKEY_LOCAL_MACHINE e seleziona File> Carica hive dal menu.
- È possibile utilizzare Carica hive per caricare le chiavi di registro da un sistema non in linea. In questo caso, il sistema è il disco rotto collegato alla VM di riparazione.
- Le impostazioni a livello di sistema sono memorizzate su HKEY_LOCAL_MACHINE e possono essere abbreviate in HKLM.
Nel disco collegato, apri il file
\windows\system32\config\SOFTWARE
.- Quando ti viene richiesto un nome, inserisci BROKENSOFTWARE.
- Per verificare che BROKENSOFTWARE sia stato caricato, espandere HKEY_LOCAL_MACHINE e cercare la chiave BROKENSOFTWARE aggiunta.
Vai a BROKENSOFTWARE e controlla se la chiave CleanupProfiles esiste nell'hive caricato.
- Se la chiave esiste, viene impostato il criterio CleanupProfiles. Il suo valore rappresenta il criterio di conservazione misurato in giorni.
- Se la chiave non esiste, il criterio CleanupProfiles non è impostato. In questa situazione, passare a invio di un ticket di supporto con un file dump della memoria.
Elimina la chiave CleanupProfiles utilizzando questo comando:
reg delete "HKLM\BROKENSOFTWARE\Policies\Microsoft\Windows\System" /v CleanupProfiles /f
Scarica l'hive BROKENSOFTWARE utilizzando questo comando:
reg unload HKLM\BROKENSOFTWARE
Abilita la console seriale e la raccolta di dump della memoria
Consigliato: prima di ripristinare la macchina virtuale, abilitare Console seriale e la raccolta dei dump di memoria eseguendo il seguente script:
Apri una sessione del prompt dei comandi con privilegi elevati come amministratore.
Elenca i dati dell'archivio BCD e determina l'identificatore del caricatore di avvio, che utilizzerai nel passaggio successivo.
Per una macchina virtuale di generazione 1, immettere il comando seguente e prendere nota dell'identificatore elencato:
bcdedit /store <BOOT PARTITON>:\boot\bcd /enum
Nel comando, sostituire
<BOOT PARTITON>
con la lettera della partizione del disco collegato che contiene la cartella di avvio.
Per una macchina virtuale di seconda generazione, immettere il comando seguente e prendere nota dell'identificatore elencato:
bcdedit /store <LETTER OF THE EFI SYSTEM PARTITION>:EFI\Microsoft\boot\bcd /enum
- Nel comando, sostituire
<LETTER OF THE EFI SYSTEM PARTITION>
con la lettera della partizione di sistema EFI. - Potrebbe essere utile avviare la console Gestione disco per identificare la partizione di sistema appropriata etichettata come Partizione di sistema EFI.
- L'identificatore può essere un GUID univoco o potrebbe essere il bootmgr predefinito.
- Nel comando, sostituire
Eseguire i comandi seguenti:
Abilitare la Console seriale:
bcdedit /store <VOLUME LETTER WHERE THE BCD FOLDER IS>:\boot\bcd /ems {<BOOT LOADER IDENTIFIER>} ON bcdedit /store <VOLUME LETTER WHERE THE BCD FOLDER IS>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
Verificare che lo spazio libero sul disco del sistema operativo sia maggiore della dimensione della memoria (RAM) sulla macchina virtuale.
Se lo spazio sul disco del sistema operativo non è sufficiente, modificare la posizione in cui verrà creato il file di dump della memoria e fare riferimento a tale posizione in qualsiasi disco dati collegato alla macchina virtuale che disponga di spazio libero sufficiente. Per modificare la posizione, sostituisci %SystemRoot% con la lettera dell'unità del disco dati, ad esempio F:, nei seguenti comandi.
Configurazione consigliata per abilitare il dump del sistema operativo:
Caricare Hive del Registro di sistema dal disco del sistema operativo danneggiato:
REG LOAD HKLM\BROKENSYSTEM <VOLUME LETTER OF BROKEN OS DISK>:\windows\system32\config\SYSTEM
Abilitare su ControlSet001:
REG ADD "HKLM\BROKENSYSTEM\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f REG ADD "HKLM\BROKENSYSTEM\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f REG ADD "HKLM\BROKENSYSTEM\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Abilitare su ControlSet002:
REG ADD "HKLM\BROKENSYSTEM\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f REG ADD "HKLM\BROKENSYSTEM\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f REG ADD "HKLM\BROKENSYSTEM\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Scaricare il disco del sistema operativo danneggiato:
REG UNLOAD HKLM\BROKENSYSTEM
Ricompilare la macchina virtuale
Utilizzare il passaggio 5 dei comandi di riparazione della VM per ricostruire la VM.
Verifica se la tua VM si avvia normalmente per vedere se il problema è risolto.
- Se il problema non è stato risolto, continua a raccogliere un file dump e inviare un ticket di supporto.
- Se il problema è stato risolto, non sono necessari ulteriori passaggi.
Se il problema è stato risolto, il criterio è ora disabilitato in locale. Per una soluzione permanente, non usare il criterio CleanupProfiles nelle macchine virtuali, poiché eliminerà automaticamente i profili utente. Utilizzare un metodo diverso per eseguire le pulizie del profilo, ad esempio un'attività pianificata o uno script.
Non utilizzare questo criterio:Macchina\Modelli amministratore\Sistema\Profili utente\Elimina i profili utente più vecchi di un numero specificato di giorni al riavvio del sistema.
Il problema dovrebbe ora essere risolto
Testa la tua VM per assicurarti che funzioni normalmente. Se i problemi persistono, puoi passare alla sezione successiva per ulteriore assistenza.
Raccogli il file di dump della memoria e invia un ticket di supporto
Per risolvere questo problema, è necessario prima raccogliere il file di dump della memoria per l'arresto anomalo e quindi contattare l'assistenza con il file di dump della memoria. Per raccogliere il file dump, attenersi alla seguente procedura:
Collega il disco del sistema operativo a una nuova VM di riparazione
- Utilizzare i passaggi 1-3 dei Comandi di riparazione VM per preparare una nuova VM di riparazione.
- Utilizzando Connessione Desktop remoto, collegarsi alla macchina virtuale di ripristino.
Individua il file di dump e invia un ticket di supporto
- Nella VM di riparazione, vai alla cartella Windows nel disco del sistema operativo collegato. Se la lettera del driver assegnata al disco del sistema operativo collegato è etichettata come F, è necessario passare a
F:\Windows
. - Individua il file
memory.dmp
, quindi invia un ticket di supporto con il file dump della memoria. - Se hai problemi a localizzare il file
memory.dmp
, usa invece le chiamate di interrupt non mascherabili (NMI) nella console seriale. Segui la guida per generare un file di crash dump utilizzando le chiamate NMI qui.
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