Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo illustra come risolvere il problema a causa del quale può essere generato un errore di runtime imprevisto quando si tenta di installare un certificato usando Gestione Microsoft Internet Information Services (IIS) 7.0
Versione originale del prodotto: Windows Server 2008 Service Pack 2, Internet Information Services 7.0
Numero KB originale: 959216
Sintomi
Quando si tenta di installare un certificato da un PKCS#7
file usando Gestione IIS 7.0, è possibile che venga visualizzato uno dei messaggi di errore seguenti:
Messaggio di errore 1
Impossibile trovare la richiesta di certificato associata a questo file di certificato. Una richiesta di certificato deve essere completata nel computer in cui è stata creata.
Messaggio di errore 2
Errore durante l'esecuzione di questa operazione
Dettagli: CertEnroll::CX509Enrollment::p_InstallResponse: valore del tag ASN1 non valido soddisfatto.
0x8009310b (ASN:276)
Note
Il certificato viene installato correttamente nonostante il messaggio di errore.
Causa
Questo problema si verifica perché Gestione IIS esegue un'operazione di ricerca per cercare un nome descrittivo del certificato durante l'installazione. Tuttavia, il codice che esegue questa operazione di ricerca non verifica questo caso specifico e non sa come recuperare il nome descrittivo di un certificato in un PKCS#7
file. Ecco perché l'operazione di ricerca ha esito negativo e viene visualizzato il messaggio di errore.
Risoluzione
Per risolvere questo problema, aggiungere un nome descrittivo al certificato. Per risolvere il problema, seguire questa procedura:
- Selezionare Start, selezionare Esegui, immettere MMC e quindi selezionare OK.
- Selezionare File, selezionare Aggiungi/Rimuovi snap-in.
- Selezionare Certificati, selezionare Aggiungi >.
- Selezionare Account computer e quindi Avanti e quindi Fine.
- Seleziona OK.
- Espandere Certificati (computer locale) e Personale, quindi Certificati.
- Fare clic con il pulsante destro del mouse sul certificato e quindi scegliere Proprietà.
- Modificare il campo Nome descrittivo e quindi selezionare OK.
Ulteriori informazioni
Questo problema è pianificato per essere risolto in Windows Server 2008 Service Pack 3.