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Errore 400 o 401 quando si imposta la visibilità della tabella virtuale Dataverse

Codice di errore: SYS81183

Questo articolo descrive i codici di errore (400 e 401) che possono verificarsi quando si imposta la visibilità della tabella virtuale di Microsoft Dataverse per il servizio calcolo imposte in un ambiente RCS (Regulatory Configuration Service). Spiega anche cosa causa i problemi e come risolverli.

Nota

Questo articolo è applicabile alla versione 10.0.38 o precedente.

Errore 400 con "InternalServerError"

Sintomi

Quando si imposta la visibilità della tabella virtuale o si esegue la ricerca dei dati master nella configurazione della funzionalità fiscale, viene visualizzato il messaggio di errore seguente:

Connessione a Microsoft Dataverse non riuscita. Dettagli: il server remoto ha restituito un errore: (400) Richiesta non valida. 0x80048d0b: è stato ottenuto un token per chiamare Finance and Operations, ma Finance and Operations ha restituito un errore di tipo InternalServerError.

Causa

Questo problema si verifica se il servizio finanziario e operativo è inattivo o se l'URL di destinazione finance e operations è impostato in modo errato.

Risoluzione

  1. Verificare che sia possibile accedere alle app finanziarie e operative usando lo stesso account usato per accedere a Dataverse.
  2. Passare aImpostazioni> avanzate dataverse>Amministrazione>origini dati entità virtuali e selezionare l'origine dati denominata finanza e operazioni.
  3. Verificare che l'URL di destinazione possa essere aperto direttamente nel browser. Per altre informazioni, vedere Configurare l'origine dati dell'entità virtuale.

Errore 400 con "Impossibile risolvere il nome remoto"

Sintomi

Quando si imposta la visibilità della tabella virtuale o si esegue la ricerca dei dati master nella configurazione della funzionalità fiscale, viene visualizzato il messaggio di errore seguente:

Connessione a Microsoft Dataverse non riuscita. Dettagli: il server remoto ha restituito un errore: (400) Richiesta non valida. 0x80040224: TokenProvider.AcquireTokenAsync(Clientld '{ApplicationId}', Authority '{IncorrectURL}', Risorsa '000000015-0000-0000-c000-000000000000'): eccezione non gestita: Microsoft.IdentityModel.Clients.ActiveDirectory.AdalServiceException: errore restituito dal servizio. Controllare InnerException per altri dettagli ---> System.Net.WebException: Impossibile risolvere il nome remoto:...

Causa

Questo problema si verifica se l'URL o l'ID tenant OAuth (Open Authorization) non è corretto. Per altre informazioni, vedere Configurare l'origine dati dell'entità virtuale.

Risoluzione

  1. Passare aImpostazioni> avanzate dataverse>Amministrazione>origini dati entità virtuali e selezionare l'origine dati denominata finanza e operazioni.

  2. Verificare che l'URL OAuth e l'ID tenant siano corretti. Per altre informazioni, vedere Configurare l'origine dati dell'entità virtuale.

    • L'URL OAuth è un valore hardcoded: https://login.windows.net/.
    • Per trovare l'ID tenant corretto, accedere al portale di Azure usando lo stesso account usato per accedere a Dataverse e RCS. Selezionare Microsoft Entra ID e quindi selezionare l'istanza di Microsoft Entra ID. L'ID tenant o il dominio primario viene visualizzato nel campo Tenant .

Errore 400 con "Applicazione con identificatore {ApplicationId} non trovata"

Sintomi

Quando si imposta la visibilità della tabella virtuale o si esegue la ricerca dei dati master nella configurazione della funzionalità fiscale, viene visualizzato il messaggio di errore seguente:

Connessione a Microsoft Dataverse non riuscita. Dettagli: il server remoto ha restituito un errore: (400) Richiesta non valida. 0x80040224: TokenProvider.AcquireTokenAsync(Clientid '{IncorrectApplicationId}', Authority '<https://login.windows.net/microsoft.com>', Resource '000000015-0000-0000-c000-00000000000'): eccezione non gestita: Microsoft.IdentityModel.Clients.ActiveDirectory.AdalServiceException: AADSTS700016: Applicazione con identificatore '{IncorrectApplicationId}' non trovata nella directory 'Microsoft'. Ciò può verificarsi se l'applicazione non è stata installata dall'amministratore del tenant o acconsentita da qualsiasi utente nel tenant. È possibile che la richiesta di autenticazione sia stata inviata al tenant errato.

Causa

Questo problema si verifica se l'ID applicazione non è corretto. Per altre informazioni, vedere Configurare l'origine dati dell'entità virtuale.

Risoluzione

  1. Passare aImpostazioni> avanzate dataverse>Amministrazione>origini dati entità virtuali e selezionare l'origine dati denominata finanza e operazioni.
  2. Verificare che l'ID applicazione sia corretto. Per altre informazioni, vedere Configurare l'origine dati dell'entità virtuale.

È consigliabile ottenere l'ID applicazione durante il passaggio Registrare l'app nel passaggio portale di Azure. Assicurarsi di aver immesso l'ID applicazione corretto.

Errore 401

Sintomi

Quando si imposta la visibilità della tabella virtuale, si esegue la ricerca dei dati master nella configurazione della funzionalità fiscale o si esegue la convalida del mapping del modello, viene visualizzato uno dei messaggi di errore seguenti:

Connessione a Microsoft Dataverse non riuscita. Dettagli: il server remoto ha restituito un errore: (401) Non autorizzato.

L'entità warehouse filtrata Connessione all'entità warehouse a Microsoft Dataverse non è riuscita. Dettagli: il server remoto ha restituito un errore: (401) Non autorizzato.

Causa

L'errore "Non autorizzato" 401 si verifica se il processo "Controlla connessione" per le applicazioni connesse in RCS non riesce o se il processo "Controlla connessione" non viene eseguito dopo che sono state apportate modifiche alle impostazioni delle applicazioni connesse in RCS.

Nota

Anche l'account usato per accedere a RCS deve essere in grado di accedere all'istanza di Dataverse.

Risoluzione

  1. Nell'ambiente RCS passare alrecord dell'applicazione Dataverse delleapplicazioni> connesse per la creazione di report> elettronici.
  2. Il campo Applicazione mostra l'URL dell'istanza del database. Verificare che sia possibile accedere a tale istanza di Dataverse usando lo stesso account usato per accedere all'ambiente RCS.
  3. Verificare che il campo Tenant sia impostato sull'ID tenant dell'account (ad esempio , d335a570-a05b-4bc5-8eb3-c42c65f9560d) o sull'URL del tenant (ad esempio, taxserviceint.onmicrosoft.com).
  4. Selezionare Controlla connessione. Il processo deve avere esito positivo.

Importante

Se il processo "Controlla connessione" non ha esito positivo, l'installazione di Dataverse non è corretta. Vedere Abilitare la ricerca dei dati master per la configurazione del calcolo fiscale e assicurarsi che i passaggi 1, 2 e 3 siano tutti eseguiti correttamente.