non è possibile ricevere Email perché la licenza non è valida per l'errore della cassetta postale in Microsoft Dynamics 365

Questo articolo fornisce una risoluzione per l'errore Email non può essere ricevuto perché la licenza non è valida per la cassetta postale che si verifica quando si seleziona il pulsante Test & Abilita cassetta postale in Microsoft Dynamics 365.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4459027

Sintomi

Dopo aver selezionato il pulsante Test & Abilita cassetta postale in Microsoft Dynamics 365, lo stato di Email in ingresso viene visualizzato come Errore e viene registrato un avviso con i dettagli seguenti:

non è possibile ricevere Email perché la licenza non è valida per la cassetta postale <Nome> cassetta postale.
codice di errore del server Email: ErrorInvalidLicense

Causa

Questo errore può verificarsi se si tenta di connettersi a una cassetta postale utente Microsoft Exchange Online e a tale utente/cassetta postale non è assegnata una licenza Exchange Online.

Risoluzione

Assegnare una licenza Exchange Online all'utente/cassetta postale. Per altre informazioni su come assegnare licenze in Office 365, vedere Aggiungere utenti e assegnare licenze contemporaneamente.

Nota

Se lo scopo della cassetta postale è quello di funzionare come coda e non come utente, è consigliabile usare una cassetta postale condivisa in Exchange. Le cassette postali condivise non richiedono una licenza Exchange Online. Se si apre l'interfaccia di amministrazione di Exchange, si selezionano i destinatari e quindi si seleziona Condiviso, verificare se la cassetta postale viene visualizzata in questo elenco. Se la cassetta postale è una cassetta postale normale e la si seleziona, verrà visualizzata un'opzione per la conversione in cassetta postale condivisa.

Ulteriori informazioni

Se si seleziona di visualizzare i dettagli all'interno dell'avviso, vengono visualizzati dettagli simili ai seguenti:

ActivityId: <GUID>
>Errore: <ResponseMessageType xmlns:q1="https://schemas.microsoft.com/exchange/services/2006/messages" p2:type="q1:FindItemResponseMessageType" ResponseClass="Error" xmlns:p2=""><https://www.w3.org/2001/XMLSchema-instanceq1:MessageText>Si è verificato un errore interno del server. L'operazione non è riuscita. La cassetta postale '<MAILBOX ID>' non ha una licenza valida.</q1:MessageText><q1:ResponseCode>ErrorInternalServerError</q1:ResponseCode><q1:DescriptiveLinkKey>0</q1:DescriptiveLinkKey><q1:MessageXml><t:Value Name="InnerErrorMessageText" xmlns:t="https://schemas.microsoft.com/exchange/services/2006/types">La licenza non è valida per questa cassetta postale.</t:Value><t:Value Name="InnerErrorResponseCode" xmlns:t="https://schemas.microsoft.com/exchange/services/2006/types">ErrorInvalidLicense</t:Value><t:Value Name="InnerErrorDescriptiveLinkKey" xmlns:t="https://schemas.microsoft.com/exchange/services/2006/types">0</t:Value></q1:MessageXml></ResponseMessageType>