Condividi tramite


Si è verificato un errore generale di accesso alla cassetta postale durante la ricezione della posta elettronica tramite l'avviso della cassetta postale in Microsoft Dynamics 365

Questo articolo fornisce una risoluzione per l'errore di accesso alla cassetta postale A general mailbox occurred while receiving email through the mailbox warning that'sogged in a Microsoft Dynamics 365 mailbox record.This article provides a resolution for the A general mailbox access error while receiving email through the mailbox warning that'sogged in a Microsoft Dynamics 365 mailbox record.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4340389

Sintomi

Un avviso con il messaggio seguente viene registrato in un record della cassetta postale di Microsoft Dynamics 365:

Si è verificato un errore generale di accesso alla cassetta postale durante la ricezione della posta elettronica tramite il nome> della cassetta postale<. Al proprietario del profilo del server di posta elettronica associato Microsoft Exchange Online è stata inviata una notifica. Il sistema tenterà di ricevere di nuovo il messaggio di posta elettronica in un secondo momento.
Email Codice di errore del server: il server exchange ha restituito l'eccezione ErrorMailboxStoreUnavailable.

Causa

Questo avviso può essere registrato quando si usa la funzionalità di sincronizzazione Server-Side in Microsoft Dynamics 365 per l'integrazione con Microsoft Exchange. Microsoft Dynamics 365 comunica con Microsoft Exchange tramite i servizi Web di Exchange. Se Microsoft Dynamics 365 tenta di recuperare le informazioni per una cassetta postale, Microsoft Exchange può rispondere con errorMailboxStoreUnavailable. Come illustrato nella documentazione di Microsoft Exchange seguente, questa risposta indica che Exchange non è riuscito a elaborare la richiesta perché la cassetta postale non era disponibile al momento:

ResponseCode

Questo errore indica che si è verificata una delle condizioni di errore seguenti:

  • L'archivio cassette postali è danneggiato.
  • L'archivio cassette postali viene arrestato.
  • L'archivio cassette postali è offline.
  • Si è verificato un errore di rete quando è stato effettuato un tentativo di accesso all'archivio cassette postali.
  • L'archivio cassette postali è sovraccarico e non può accettare altre connessioni.
  • L'archivio cassette postali è stato sospeso.

Risoluzione

Se questo messaggio di avviso viene trovato ma non continua a verificarsi e i messaggi di posta elettronica in ingresso/in uscita vengono elaborati correttamente, questo avviso può essere ignorato. Microsoft Dynamics 365 proverà di nuovo ad accedere alla cassetta postale. Se l'avviso persiste, potrebbe essere necessario esaminare il motivo per cui Microsoft Exchange restituisce questo messaggio. Verificare che la cassetta postale di Exchange sia accessibile. Se si usa Exchange Online, accedere al dashboard integrità dei servizi come amministratore Office 365 per verificare che non vengano pubblicati problemi di integrità del servizio noti per il servizio Exchange Online.

Ulteriori informazioni

Se si desidera disabilitare gli avvisi a livello di avviso per la sincronizzazione Server-Side, è possibile disabilitare questi eventi all'interno di Impostazioni di sistema:

  1. In qualità di utente con il ruolo Amministratore di sistema, accedere all'applicazione Web Microsoft Dynamics 365.
  2. Passare a Impostazioni e quindi selezionare Email Configurazione.
  3. Selezionare Email Impostazioni di configurazione. La scheda Email deve essere selezionata per impostazione predefinita.
  4. Nella sezione Configura avvisi rimuovere il controllo Avviso e selezionare OK.