Non è possibile connettersi all'errore del server microsoft Dynamics 365 quando si usa Microsoft Dynamics 365 App per Outlook

Questo articolo fornisce una soluzione per il problema che non è possibile usare Microsoft Dynamics 365 App per Outlook a causa dell'errore Non è possibile connettersi al server Microsoft Dynamics 365.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4341413

Sintomi

Quando si tenta di usare Microsoft Dynamics 365 App per Outlook, viene visualizzato il messaggio seguente:

"Non è possibile connettersi al server microsoft Dynamics 365. Provare a chiudere e riaprire l'app."

Se si seleziona Mostra altro, è possibile che venga visualizzato il messaggio seguente:

"Timeout del caricatore client"

Se si usa l'app in Outlook Web Access (OWA), nella parte inferiore della schermata potrebbe essere visualizzato il prompt seguente:

"Si vuole consentire dynamics.com l'uso di spazio di archiviazione aggiuntivo nel computer?"

Se si cancella la cache del browser Internet Explorer, questo errore potrebbe essere risolto, ma alla fine viene restituito.

Causa

Microsoft è a conoscenza di un problema in cui può verificarsi questo errore perché Internet Explorer è configurato per limitare la quantità di dati che possono essere memorizzati nella cache. Se si visualizza l'app usando Internet Explorer, questa potrebbe essere la causa dell'errore. Se si verifica questo errore con Outlook Desktop, Outlook usa sempre Internet Explorer per visualizzare l'app.

Risoluzione

Microsoft sta lavorando a una modifica per evitare questo problema. Nel frattempo, è possibile usare i passaggi seguenti come possibile soluzione alternativa:

Opzione 1 - Aumentare il limite di database all'interno delle opzioni di Internet Explorer

A seconda della versione del sistema operativo, è possibile modificare il limite all'interno delle impostazioni di Internet Explorer. Se si usa Windows 10, questa opzione non viene visualizzata ed è invece possibile usare l'opzione 2.

  1. Aprire Internet Explorer.
  2. Nell'angolo in alto a destra selezionare l'icona a ingranaggio e quindi selezionare Opzioni Internet.
  3. Nella scheda Generale nella sezione Cronologia esplorazioni selezionare Impostazioni.
  4. Selezionare la scheda Cache e database .
  5. Se viene visualizzata l'opzione Invia notifica quando la cache o il database di un sito Web supera , modificare il valore in 200 e selezionare OK. In alternativa, è possibile selezionare dynamics.com dall'elenco dei siti Web e quindi selezionare Supera limite. Se queste opzioni non vengono visualizzate, passare all'opzione 2.
  6. Cancellare la cronologia e la cache di Internet Explorer. Per i passaggi dettagliati, vedere Visualizzare ed eliminare la cronologia esplorazioni in Internet Explorer.

Opzione 2- Aumentare il limite del database all'interno del Registro di sistema

Importante

Questa sezione contiene i passaggi che indicano come modificare il Registro di sistema. Poiché l'errata modifica del Registro di sistema può causare seri problemi, Di conseguenza, attenersi scrupolosamente alla procedura indicata. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. In questo modo sarà possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire backup e ripristino del Registro di sistema, vedere Backup e ripristino del Registro di sistema in Windows.

Per aumentare il limite di memorizzazione nella cache consentito, creare la voce del Registro di sistema seguente:

Sottochiave: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue
Nome: MaxTrustedDomainLimitInMB
Digitare: REG_DWORD
Dati: 200

Per creare questa voce del Registro di sistema, seguire questa procedura:

  1. Selezionare Start e quindi Esegui, digitare regedit e premere OK.

  2. Individuare e selezionare la sottochiave del Registro di sistema seguente. Se il percorso di questo percorso non esiste, potrebbe essere necessario creare le chiavi indicate:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue

  3. Fare clic con il pulsante destro del mouse su IndexedDBValue, scegliere Nuovo e quindi selezionare Valore DWORD.

  4. Nella casella Nuovo valore n. 1 digitare MaxTrustedDomainLimitInMB e quindi premere INVIO.

  5. Fare clic con il pulsante destro del mouse su MaxTrustedDomainLimitInMB e quindi scegliere Modifica.

  6. Selezionare Decimale, digitare 200 e quindi selezionare OK.

  7. Uscire dal Registro di sistema Editor e quindi riavviare il computer.

  8. Cancellare la cronologia e la cache di Internet Explorer. Per i passaggi dettagliati, vedere Visualizzare ed eliminare la cronologia esplorazioni in Internet Explorer.

Ulteriori informazioni

Esistono più possibili cause per questo errore. Se il problema non viene risolto, vedere l'articolo seguente per altre potenziali soluzioni:

Errore "Non è possibile connettersi al server microsoft Dynamics 365" quando si usa Dynamics 365 App per Outlook