Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo illustra come risolvere un errore imprevisto che si verifica quando si approva, salva o invia una scheda attività in Project Time and Expense in Business Portal.This article provides steps on how to solve the An unexpected error has occurred error that occurred occurred error that occurred when you approve, save, or submit a timesheet in Project Time and Expense in Business Portal.
Si applica a: Microsoft Dynamics GP
Numero KB originale: 2860634
Sintomi
In Business Portal Project Time and Expense potresti riscontrare il seguente problema quando approvi, salvi o invii una scheda attività:
Si è verificato un errore imprevisto. Contattare l'amministratore del sistema.
Causa
In genere questo errore è causato da:
- Modello di registro delle attività danneggiato. I modelli possono essere danneggiati se gli utenti non rimuovono progetti precedenti/chiusi dai modelli. Dopo aver eliminato il modello, il problema dovrebbe essere risolto.
- Una scheda attività o un modello che utilizza progetti che non esistono più o che non sono più assegnati.
- Problema di sicurezza dovuto a un aggiornamento di Windows installato di recente.
Risoluzione
Esaminare i metodi seguenti e testarne uno tra di essi:
Metodo 1: Modello - Quello che puoi fare è rimuovere il modello di scheda temporale per l'utente per vedere se questo risolve il problema: Inserisci l'ID del dipendente al posto del segnaposto XXXX prima di eseguire lo script in SQL Server Management Studio sul database aziendale.
Delete PDK00300 where EMPLOYID='XXXX'
Delete PDK00301 where EMPLOYID='XXXX'
Metodo 2: progetti non validi: questo errore può verificarsi anche se sono presenti progetti che non esistono nel sistema, ma esistono nei modelli di progetto/scheda attività degli utenti. Ecco uno script per verificare quanto segue:
Verificare la presenza di progetti nella riga del foglio presenze che non esistono in GP eseguendo questo script in SQL Server Management Studio sul database aziendale.
select * from PDK10001 where PAPROJNUMBER not in (select PAPROJNUMBER from PA01201)
Verificare che i progetti usati nei modelli esistano in GP:
select * from PDK00301 where PAPROJNUMBER not in (select PAPROJNUMBER from PA01201)
Se si trovano occorrenze nelle istruzioni select precedenti, queste devono essere rimosse dalla scheda attività (accedere a PDK e rimuovere la riga con il progetto non valido) oppure eliminare il modello stesso della scheda attività. Ecco i passaggi da eseguire:
- Se si trovano risultati per lo script 1, sarà necessario accedere a PDK Modify that Timesheet e rimuovere il progetto non valido.
- Se si trovano i risultati per lo script 2, sarà necessario eliminare il modello e crearne uno nuovo. A tale scopo, è possibile eseguire le azioni di eliminazione seguenti:
Delete PDK00300 where EMPLOYID='XXXX'
Delete PDK00301 where EMPLOYID='XXXX'
Metodo 3: Sicurezza di Windows - Le modifiche apportate a una patch di sicurezza recente da Aggiornamenti di Windows per .NET Framework possono anche causare questo errore. Questo problema è attualmente noto a causa dell'aggiornamento della sicurezza seguente ed è in corso un'analisi più approfondita.
Passaggi: la soluzione alternativa temporanea consiste nel disinstallare questi aggiornamenti della sicurezza per .NET Framework e BP Time & Expense funzionerà di nuovo correttamente. Di seguito sono riportati i passaggi per disinstallare questi aggiornamenti:
Nel server BP passare a Programmi e funzionalità nel Pannello di controllo.
Nel margine sinistro selezionare Visualizza aggiornamenti installati.
Esaminare gli aggiornamenti installati e selezionare eventuali aggiornamenti con KB2894843 o KB2894844 o KB2894847 elencati. (f non viene visualizzato nessuno di questi elementi elencati, è possibile eseguire il rollback di eventuali aggiornamenti installati di recente per determinare quale causa il problema).
Con l'aggiornamento selezionato, quindi selezionare il pulsante Disinstalla nella parte superiore.
A questo scopo, eseguire una reimpostazione iis.
Testare di nuovo in BP e il problema deve essere risolto. Non è necessario riavviare il server BP, ma potrebbe provare se non funziona ancora.
Note
Questo articolo verrà aggiornato man mano che vengono trovati altri sviluppi con questo problema oppure è possibile seguire l'articolo di blog seguente su questo problema:
UPDATE: si è verificato un errore imprevisto. Contattare l'amministratore di sistema
Ulteriori informazioni
Vedere anche l'articolo seguente per altri possibili motivi per questo tipo di messaggio. L'articolo verifica inoltre che l'utente sia configurato correttamente in Gp, PDK e Business Portal:
L'articolo precedente è stato pubblicato anche esternamente in questo blog: