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Messaggio di errore "Il paese/area geografica associato alla banca assegnato all'indirizzo di pagamento del fornitore è mancante o inattivo" quando si genera un file EFT per Gestione delle Operazioni Passivi in Microsoft Dynamics GP

Questo articolo fornisce una soluzione a un errore che si verifica quando si genera un file EFT per la gestione dei fornitori in Microsoft Dynamics GP.

Si applica a: Microsoft Dynamics GP
Numero KB originale: 944441

Sintomi

Quando si genera un file EFT (Electronic Funds Transfer) per la gestione dei fornitori in Microsoft Dynamics GP dopo l'aggiornamento da una versione precedente, viene visualizzato il seguente messaggio di errore:

Il paese/area geografica della banca assegnato all'indirizzo di rimessa del fornitore è mancante o inattivo. Assegna il paese o l'area geografica della banca all'indirizzo oppure attiva il formato.

Causa

Questo messaggio di errore può verificarsi per i motivi seguenti:

  • L'ID del checkbook usato non ha una nota predefinita generata. Guarda Metodo 1 per risolvere.
  • Il fornitore non ha un ID indirizzo di rimessa predefinito popolato nella finestra Manutenzione fornitore. Questo ID indirizzo rimittente è indicato come campo VADCDTRO. Vedi il Metodo 2 per risolvere.
  • Il campo VADCDTRO (Vendor Address Code - Remit To) non corrisponde alle tabelle VADCDTRO usate per questo fornitore nelle tabelle PM00200 (PM _Vendor_Master) o PM20100 (PM_Apply_to_OPEN_OPEN_temporary). Vedere Metodo 3 per risolvere.

Risoluzione

Per risolvere il problema, utilizzare uno dei metodi riportati di seguito:

Note

Prima di seguire le istruzioni riportate in questo articolo, assicurarsi di disporre di una copia di backup completa del database che è possibile ripristinare in caso di problemi.

Metodo 1

Questo messaggio di errore può verificarsi se l'ID del checkbook usato non ha avuto una prenotifica generata. Per risolvere il problema, seguire questa procedura:

  1. Sul menu Carte, puntare a Finanziario, e quindi selezionare Libretto degli assegni.

  2. Nella finestra Manutenzione libro di controllo, selezionare l'ID del libro di controllo usando il pulsante Cerca nel campo ID.

  3. Nella finestra Manutenzione libretto degli assegni, selezionare EFT Bank .

  4. Nella finestra Manutenzione banca Checkbook EFT selezionare il pulsante Opzioni debitori.

  5. Nella finestra Checkbook EFT Payables Options seguire una delle opzioni seguenti:

    1. Se la casella di controllo Prenota obbligatoria per Fornitori è selezionata, andare al passaggio 6.
    2. Se la casella di controllo Prenotifica fornitori obbligatoria non è selezionata, passare a Metodo 2.
  6. Nella finestra Opzioni contabilità EFT del Checkbook selezionare Genera Prenotazioni.

  7. Nella finestra Generate EFT Prenotes (Genera prenote EFT) selezionare l'ID del libro di cassa nel campo Checkbook ID (ID libro di cassa), selezionare l'opzione Solo fornitori (Vendors Only) nella sezione per chi sono le prenote (Prenotes For), selezionare l'ID formato di prenote nel campo Prenote Format ID (ID formato prenote) e quindi selezionare Elabora (Process).

Metodo 2

Questo messaggio di errore può verificarsi se non si dispone di un indirizzo di rimessa predefinito per l'ID indirizzo popolato nella finestra Manutenzione fornitore. Per risolvere il problema, seguire questa procedura:

  1. Nel menu Schede scegliere Acquisto e quindi selezionare Fornitore.
  2. Nella finestra Manutenzione fornitore, selezionare l'ID fornitore usando il pulsante Ricerca nel campo ID fornitore.
  3. Nella finestra Manutenzione fornitore selezionare il pulsante Ricerca nel campo Rimessa a e quindi selezionare l'ID di rimessa a indirizzo configurato come EFT.
  4. Seleziona Salva.

Note

A partire da Microsoft Dynamics GP 9.0, è stato aggiunto un nuovo campo alla tabella Pm Transaction Open File (PM20000). Questo campo è il campo VADCDTRO (Vendor Address Code - Rimessa a). Ogni volta che viene immessa una fattura EFT (Electronic Funds Transfer), il campo VADCDTRO viene popolato per registrare le informazioni di rimessa per la fattura.

Metodo 3

Questo messaggio di errore può verificarsi se il campo VADCDTRO (Vendor Address Code - Rimessa a) nella tabella PM20000 per le fatture registrate non corrisponde all'ID indirizzo mappato a EFT. Controllare la tabella PM20000 (PM_Transaction_Open) per assicurarsi che gli indirizzi del fornitore nella colonna VADCDTRO siano gli stessi indirizzi per i fornitori in una versione precedente di Microsoft Dynamics GP se è stato aggiornato di recente. La colonna VADCDTRO nella tabella PM20000 deve corrispondere alla colonna VADCDTRO nella tabella PM00200 (PM_Vendor_Master) per ogni fornitore. Per risolvere il problema, seguire questa procedura:

  1. Avviare la Console di amministrazione del supporto, Microsoft SQL Query Analyzer o SQL Server Management Studio. A tale scopo, usare uno dei metodi seguenti a seconda del programma in uso.

    Metodo 1: per SQL Server 2000

    Se si usa SQL Server 2000, avviare SQL Query Analyzer. A tale scopo, selezionare Start, scegliere Tutti i programmi, Microsoft SQL Server e quindi Query Analyzer.

    Metodo 2: Per SQL Server 2005

    Se si usa SQL Server 2005, avviare SQL Server Management Studio. A tale scopo, selezionare Start, scegliere Tutti i programmi, Microsoft SQL Server 2005 e quindi SQL Server Management Studio.

    Metodo 3: per SQL Server 2008

    Se si usa SQL Server 2008, avviare SQL Server Management Studio. A tale scopo, selezionare Start, scegliere Tutti i programmi, Microsoft SQL Server 2008 e quindi SQL Server Management Studio.

  2. Eseguire lo script seguente nel database aziendale per aggiornare il campo VADCDTRO per i record nella tabella PM20000.

    UPDATE PM20000 SET VADCDTRO = PM00200.VADCDTRO FROM PM20000 INNER JOIN PM00200 ON PM20000.VENDORID = PM00200.VENDORID
    

    Note

    Questo script assegnerà il valore nel campo VADCDTRO per tutte le fatture registrate affinché sia lo stesso dell'ID indirizzo di rimessa nella finestra di manutenzione del fornitore. Questo script presuppone che l'indirizzo da utilizzare per l'ID nella finestra Manutenzione fornitore sia l'ID indirizzo che hai associato a EFT.

    Note

    In alternativa, è possibile usare lo script seguente per aggiornare il campo VADCDTRO per un fornitore specifico nella tabella delle transazioni PM20000.

    UPDATE PM20000 SET VADCDTRO = 'XXX' WHERE VENDORID = 'YYY'
    

    Nota

    XXX è un segnaposto per il codice di indirizzo di rimessa. YYY è un segnaposto per l'ID fornitore.

  3. Inoltre, se sono presenti record per questo fornitore nella tabella delle rimesse PM20100, assicurarsi che la colonna VADCDTRO nella tabella PM20100 (PM_Apply_To_OPEN_OPEN_temporary) combaci con la colonna VADCDTRO nella tabella PM00200 e in quella PM20000 (PM_Transaction_Open). Usare il seguente script contro il database aziendale per aggiornare il campo VADCDTRO per un fornitore specifico nella tabella delle rimessa PM20100.

    Update PM20100 set VADCDTRO='XXX' where VENDORID='YYY'
    

    Note

    XXX è un segnaposto per il codice di indirizzo di rimessa. YYY è un segnaposto per l'ID fornitore.

  4. Testare di nuovo la generazione del file EFT. Quando il campo VADCDTRO corrisponde tra le tabelle PM00200, PM20000 e PM20100 per questo fornitore, non dovrebbe essere visualizzato il messaggio di errore.

Riferimenti

Per ulteriori informazioni e suggerimenti per la risoluzione dei problemi su come generare il file EFT per la gestione dei pagamenti da effettuare in Microsoft Dynamics GP 10.0, vedere KB - Linee guida da seguire quando si generano file EFT o file di nota EFT in Electronic Funds Transfer per la gestione dei pagamenti da effettuare o gestione dei crediti per pagamenti da ricevere in Microsoft Dynamics GP.