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Errore quando si tenta di registrare una transazione contabilità generale: "L'ID tipo di frequenza non è associato all'ID valuta per questa transazione"

Questo articolo fornisce una soluzione a un errore che si verifica quando si pubblica una transazione contabilità generale.

Si applica a: Microsoft Dynamics GP
Numero KB originale: 935381

Sintomi

Quando si tenta di pubblicare una transazione contabilità generale in Microsoft Dynamics GP 9.0 o in Microsoft Business Solutions - Great Plains 8.0, viene visualizzato il messaggio di errore seguente:

L'ID tipo di tariffa non è associato all'ID valuta per questa transazione

Annotazioni

Questo messaggio di errore può verificarsi anche se il batch è stato creato in un modulo secondario.

Causa

Questo problema può verificarsi se uno degli scenari seguenti è true.

Scenario 1

La transazione che si tenta di pubblicare utilizza un account specificato nella finestra di configurazione di Gestione interfinanziare. Per determinare se questo scenario si applica all'utente, seguire questa procedura:

  1. Stampare l'elenco di modifica del batch dopo aver recuperato il batch.

  2. Verificare che gli account utilizzati in tale transazione siano stati effettivamente utilizzati nella finestra di configurazione di Gestione Interfund.

    Per aprire la finestra Di configurazione di Gestione interfinanziare, fare clic su Strumenti, scegliere Imposta, fare clic su Finanziario e quindi fare clic su Gestione interfinanziare.

Scenario 2

Almeno un account utilizzato nella transazione ha un segmento che non è configurato correttamente nella finestra di configurazione di Gestione Interfund. Per determinare se questo scenario si applica all'utente, verificare che un conto sia configurato per ogni conto di fondo nella finestra di configurazione di Gestione interfinanziare.

Per aprire la finestra di configurazione di Gestione Interfondi, fare clic su Strumenti, puntare a Imposta, puntare a Finanziario e quindi fare clic su Gestione Interfondi.

Non è possibile registrare una transazione fino a quando non viene definito un conto per ogni segmento di transazione nella colonna conto Dovuto a/Dovuto da e nella colonna conto Fondo di compensazione.

In genere, i conti vengono definiti per un nuovo conto con un nuovo valore nel segmento di fondo del numero di conto. Ad esempio, gli account vengono definiti se le condizioni seguenti sono vere:

  • Il segmento di fondo è il primo segmento del numero di conto.
  • I valori per il primo segmento sono i seguenti:
    • 100
    • 200
    • 300

Annotazioni

Questo elenco esclude il fondo principale di 000.

Se viene creato un account che usa il valore "111" per il primo segmento, viene allocata una linea per il segmento "111" nella finestra di configurazione di Gestione interfinanzi. Gli account devono essere assegnati a questa riga. In caso contrario, ogni volta che un account usa il valore "111" per il primo segmento, viene visualizzato il messaggio di errore indicato nella sezione Sintomi .

Se si usa il metodo "Single Due To/Due From", tutti i segmenti devono avere un account assegnato nella colonna Due To/Due From Account .

Se si utilizza il metodo "Clearing Fund/Central Treasury", tutti i segmenti ad eccezione del segmento Clearing Fund Number devono avere un conto assegnato nella colonna Clearing Fund Account e nella colonna Due To/Due From Account .

Risoluzione

Per risolvere questo problema, modificare lo stato del batch da registrare. A tale scopo, effettuare i passaggi seguenti:

Annotazioni

Prima di seguire le istruzioni riportate in questo articolo, assicurarsi di disporre di una copia di backup completa del database che è possibile ripristinare in caso di problemi.

  1. Rendere disponibile il batch. Per altre informazioni sul modo in cui un batch può non essere disponibile a causa del relativo stato, vedere Un batch viene mantenuto nello stato Registrazione, Ricezione, Occupato, Contrassegnato, Bloccato o Modificato in Microsoft Dynamics GP.

  2. Usare Microsoft SQL Query Analyzer o supporto tecnico Microsoft Console di amministrazione per eseguire l'istruzione delete seguente nel database aziendale corretto.

    delete IF000005

    Annotazioni

    La tabella IF000005 è la tabella IF_Error_Log o la tabella che contiene i record attività errori. Se questa tabella non è deselezionata, l'elenco di modifica continua a contenere il messaggio di errore seguente:
    "Il Tipo di Tasso ID non è associato all'ID valuta per questa transazione. Il batch non può essere registrato anche se ha lo stato Disponibile."

    • Se si usa Microsoft SQL Server 7.0 o Microsoft SQL Server 2000, eseguire l'istruzione in Query Analyzer. Per avviare Query Analyzer, fare clic su Start, scegliere Programmi, Microsoft SQL Server e quindi fare clic su Analizzatore query.

    • Se si usa Microsoft SQL Server Desktop Engine (noto anche come MSDE 2000), eseguire l'istruzione in Support Administrator Console. Per avviare la console di amministrazione del supporto, fare clic su Start, puntare su Programmi, puntare su Microsoft Support Administrator Console e quindi fare clic su Support Administrator Console.

  3. Accedere al database aziendale come utente sa o come utente che dispone di autorizzazioni equivalenti.

  4. Usare uno dei metodi seguenti, a seconda dello scenario:

    • Metodo 1

      Annotazioni

      In questo scenario si presuppone che sia necessario registrare le transazioni direttamente nei conti specificati nella finestra di configurazione della gestione interfinanziare.

      1. Fare clic su Strumenti, su Personalizza, su Stato personalizzazione, su Gestione interfinanzi e quindi su Disabilita.
      2. Fare clic su Transazioni, fare clic su Financial e quindi su Batch.
      3. Fare clic sul pulsante di ricerca accanto al campo ID batch e quindi fare clic sul batch.
      4. Visualizzare l'elenco di modifica sullo schermo per assicurarsi che nel batch non siano presenti altri errori.
      5. Se l'elenco di modifica non visualizza errori, pubblicare il batch e stampare il giornale di registrazione in base alle esigenze.
      6. Fare clic su Strumenti, su Personalizza, su Stato personalizzazione, su Gestione interfinanzi e quindi su Abilita.
    • Metodo 2

      1. Dopo che gli account sono stati immessi correttamente nella finestra Gestione interfinanziare, stampare l'elenco di modifica sullo schermo per assicurarsi che non ci siano altri problemi che possono causare la mancata pubblicazione del batch. Per stampare l'elenco di modifica, seguire questa procedura:
        1. Fare clic su Transazioni, fare clic su Financial e quindi su Batch.
        2. Fare clic sul pulsante di ricerca accanto al campo ID batch , fare doppio clic sul batch e quindi sul pulsante della stampante.
      2. Se non vengono visualizzati errori nell'elenco di modifica batch, fare clic su Pubblica.
      3. Stampare il giornale di registrazione, se necessario.