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Versione originale del prodotto: Microsoft Entra ID
Numero KB originale: 3092592
Sintomi
Quando si tenta di iscriversi o accedere a un'app configurata per Microsoft Azure B2C, viene visualizzato il messaggio di errore seguente:
Errore del server nell'applicazione '/'
Il codice di stato della risposta non indica l'esito positivo: 404 (Non trovato)
Descrizione: si è verificata un'eccezione non gestita durante l'esecuzione della richiesta Web corrente. Per altre informazioni sull'errore e sul suo punto di origine nel codice, vedere l'analisi dello stack.
Dettagli eccezione: System.Net.WebException: il server remoto ha restituito un errore. 404 (non trovato)
Errore di origine:
Riga 106: {
Riga 107: ...
Riga 108: OpenIdConnectConfiguration config = await mgr. GetConfigurationAsync();
Riga 109: ...
Riga 110: }
Causa
Questo problema si verifica se l'impostazione Nome criterio per l'accesso, la reimpostazione della password o il profilo utente non è presente o non è corretto nel file web.config per l'app.
Risoluzione
Per risolvere il problema, seguire questa procedura:
Aprire il file web.config per l'app.
In questo file verificare quanto segue:
- La chiave dell'app ida:SignInPolicyId esiste ed è stato sostituito il valore con il nome del criterio di accesso fornito nel portale di amministrazione di Azure B2C.
- La chiave dell'app ida:PasswordResetPolicyId esiste ed è stato sostituito il valore con il nome dei criteri di accesso forniti nel portale di amministrazione di Azure B2C.
- La chiave dell'app ida:UserProfilePolicyId esiste ed è stato sostituito il valore con il nome dei criteri di accesso forniti nel portale di amministrazione di Azure B2C.
Il file web.config dovrebbe essere simile al seguente:
<appSettings> ... <add key="ida:SignInPolicyId" value="B2C_Signin_Policy"> <add key="ida:PasswordResetPolicyId" value="B2C_PasswordReset_Policy"> <add key="ida:UserProfilePolicyId" value="B2C_UserProfile_Policy"> ... </appSettings>
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