Condividi tramite


La creazione di report smette di funzionare dopo lo spostamento di un punto di Reporting Services o l'abilitazione di TLS 1.2 in Configuration Manager

Questo articolo illustra come risolvere un problema in cui la creazione di report di Configuration Manager non funziona dopo lo spostamento del ruolo del punto di Reporting Services in un nuovo server o l'abilitazione di TLS 1.2 nei server del sito.

Versione originale del prodotto: Configuration Manager (Current Branch)
Numero KB originale: 4503578

Sintomi

Dopo aver spostato il ruolo del punto di Reporting Services in un nuovo server oppure si abilita TLS 1.2 nei server del sito, la creazione di report non funziona più in Configuration Manager.

I messaggi di errore seguenti vengono registrati nel file Srsrp.log nel punto di Reporting Services:

Creazione di srsserver completata SMS_SRS_REPORTING_POINT
URL di Reporting Services dal Registro di sistema [https://< ServerName.contoso.com/SCCMReportServer/ReportService2005.asmx>] SMS_SRS_REPORTING_POINT
Connessione sottostante chiusa: Errore imprevisto durante un'operazione di ricezione. SMS_SRS_REPORTING_POINT
(!) SRS non rilevato come in esecuzione SMS_SRS_REPORTING_POINT
Errori segnalati durante il controllo di integrità periodico dal server SRS [<NomeServer.contoso.com>]. SMS_SRS_REPORTING_POINT

Causa

Questo problema si verifica perché i server del sito e i sistemi del sito non soddisfano i requisiti descritti in Come abilitare TLS 1.2.

Risoluzione

Per risolvere questo problema e abilitare TLS 1.2 in Configuration Manager, assicurarsi che i server del sito e i sistemi del sito soddisfino i requisiti descritti in Come abilitare TLS 1.2.

A tale scopo, effettuare i passaggi seguenti:

  1. Verificare che .NET Framework sia aggiornato e che la crittografia avanzata sia abilitata in tutti i computer pertinenti.

    A tale scopo, determinare prima di tutto il numero di versione di .NET Framework e quindi seguire queste linee guida:

    • .NET Framework 4.6.2 supporta TLS 1.1 e TLS 1.2. Non sono necessarie modifiche aggiuntive.

    • .NET Framework 4.6 e versioni precedenti devono essere aggiornati per supportare TLS 1.1 e TLS 1.2.

      Se si usa .NET Framework 4.5.1 o 4.5.2 in Windows 8.1, Windows RT 8.1 o Windows Server 2012, gli aggiornamenti e i dettagli pertinenti sono disponibili anche da Microsoft Update Catalog.

    • Tutti i computer client e i sistemi del sito di Configuration Manager devono avere i valori del Registro di sistema seguenti impostati.

      Per le applicazioni a 32 bit in esecuzione su sistemi a 32 bit o applicazioni a 64 bit in esecuzione in sistemi a 64 bit:

      [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v2.0.50727]
      "SystemDefaultTlsVersions"=dword:00000001
      "SchUseStrongCrypto"=dword:00000001
      
      [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
      "SystemDefaultTlsVersions"=dword:00000001
      "SchUseStrongCrypto"=dword:00000001
      

      Per le applicazioni a 32 bit in esecuzione in sistemi a 64 bit:

      [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v2.0.50727]
      "SystemDefaultTlsVersions"=dword:00000001
      "SchUseStrongCrypto"=dword:00000001
      
      [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v4.0.30319]
      "SystemDefaultTlsVersions"=dword:00000001
      "SchUseStrongCrypto"=dword:00000001
      
  2. Verificare che il servizio SMS_Executive venga riavviato dopo l'installazione di eventuali aggiornamenti.