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Questo articolo risolve un problema in cui gli aggiornamenti delle funzionalità non vengono mai offerti nei dispositivi Windows 10 gestiti da Microsoft Intune che eseguono Windows 10 versione 1709 o versione successiva.
Sintomi
Prendi in considerazione lo scenario seguente:
- Si dispone di un computer che esegue Windows 10 versione 1709 o successiva.
- Il computer è gestito da Microsoft Intune.
- Il computer è configurato per ricevere gli aggiornamenti da Windows Update (in genere Windows Update for Business).
In questo scenario, gli aggiornamenti di manutenzione e definizione vengono installati correttamente. Tuttavia, gli aggiornamenti delle funzionalità non vengono mai offerti. Inoltre, nel file di WindowsUpdate.log vengono registrate le voci di errore seguenti:
Agente * START * Ricerca di aggiornamenti CallerId = Aggiornamento; ID taskhostw = 25
Agent Online = Sì; Interattivo = No; AllowCachedResults = No; Ignora priorità download = No
Agent ServiceID = {855E8A7C-ECB4-4CA3-B045-1DFA50104289} Servizio di terze parti
Ambito di ricerca agente = {Utente corrente}
SID del chiamante agente per applicabilità: S-1-12-1-2933642503-1247987907-1399130510-4207851353
Misc Got 855E8A7C-ECB4-4CA3-B045-1DFA50104289 redir Client/Server URL: <https://fe3.delivery.mp.microsoft.com/ClientWebService/client.asmx
>""
Token misc richiesto con 0 ID categoria.
Misc GetUserTickets: nessun ticket utente trovato. Restituzione di WU_E_NO_USERTOKEN.
Metodo Misc *FAILED* [80070426] non riuscito [AuthTicketHelper::GetDeviceTickets:570]
Metodo Misc *FAILED* [80070426] non riuscito [AuthTicketHelper::GetDeviceTickets:570]
Misc *FAILED* [80070426] GetDeviceTickets
Metodo Misc *FAILED* [80070426] non riuscito [AuthTicketHelper::AddTickets:1092]
Metodo Misc *FAILED* [80070426] non riuscito [CUpdateEndpointProvider::GenerateSecurityTokenWithAuthTickets:1587]
Misc *FAILED* [80070426] GetAgentTokenFromServer
Misc *FAILED* [80070426] GetAgentToken
Misc *FAILED* [80070426] EP:Call to GetEndpointToken
Misc *FAILED* [80070426] Failed to get service 855E8A7C-ECB4-4CA3-B045-1DFA50104289 plugin Client/Server auth token of type 0x00000001
Metodo ProtocolTalker *FAILED* [80070426] non riuscito [CAgentProtocolTalkerContext::D etermineServiceEndpoint:377]
ProtocolTalker *FAILED* [80070426] Inizializzazione non riuscita per il contesto di Protocol Talker
Codice di uscita dell'agente = 0x80070426
Agent * END * Ricerca di aggiornamenti CallerId = Aggiornamento; ID taskhostw = 25
Il codice di errore 80070426 viene convertito nel codice seguente:
ERROR_SERVICE_NOT_ACTIVE - # Il servizio non è stato avviato.
Causa
Questo problema si verifica se il servizio di accesso dell'account Microsoft (MSA o wlidsvc) è disabilitato. Il servizio DCAT Flighting (ServiceId: 855E8A7C-ECB4-4CA3-B045-1DFA50104289) si basa sull'account del servizio gestito per ottenere l'ID dispositivo globale per il dispositivo. Se il servizio MSA non è in esecuzione, l'ID del dispositivo globale non viene generato e inviato dal client. Pertanto, la ricerca degli aggiornamenti delle funzionalità non viene mai completata correttamente.
Soluzione
Per risolvere il problema, seguire questa procedura:
Accedere all'interfaccia di amministrazione di Microsoft Intune e selezionare Profili di configurazione>del dispositivo.
Selezionare il profilo assegnato ai dispositivi Windows 10 interessati e quindi selezionare Proprietà>Restrizioni>dispositivo Cloud e Archiviazione.
Impostare Assistente per l'accesso all'account Microsoft su Non configurato.
Ulteriori informazioni
I criteri account/AllowMicrosoftAccountSignInAssistant sono stati aggiunti in Windows 10 versione 1703. Questo criterio consente agli amministratori IT di disabilitare il servizio MSA.
Se il servizio MSA è disabilitato, Windows Update non offre più aggiornamenti delle funzionalità ai dispositivi che eseguono Windows 10 versione 1709 o successiva. Per altre informazioni, vedere Gli aggiornamenti delle funzionalità non vengono offerti mentre sono presenti altri aggiornamenti.