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Sintomi
Quando si crea un collegamento ipertestuale in un documento di Office e quindi si seleziona il collegamento, è possibile che venga visualizzato uno di questi messaggi di errore:
Impossibile aprire <l'URL>. Impossibile individuare il server Internet o il server proxy.
Impossibile aprire <l'URL>. Impossibile aprire il file specificato.
<URL> = collegamento ipertestuale inserito.
Annotazioni
Il collegamento ipertestuale funziona se lo si digita direttamente nel browser o nella casella Apri della finestra di dialogo Esegui (selezionare Avvia e quindi selezionare Esegui).
Motivo
Questo problema si verifica in presenza delle seguenti condizioni:
Si usa Microsoft Internet Explorer:
- Come server proxy - oppure -
- Con un firewall che non consente l'immissione di richieste HTTP nella rete locale
Internet Explorer non è il browser predefinito.
La chiave del Registro di sistema ForceShellExecute non è presente nel percorso seguente o non è impostata su 1:
Per le versioni a 32 bit di Office installate nei sistemi operativi a 64 bit:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\InternetPer le versioni a 32 bit di Office installate in sistemi operativi a 32 bit o versioni a 64 bit di Office installate nei sistemi operativi a 64 bit:
HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\Internet
Annotazioni
Il percorso del Registro di sistema non dipende dalla versione di Office.
Soluzione
Importante
Questa sezione, metodo o attività contiene passaggi che ti spiegano come modificare il registro. Tuttavia, potrebbero verificarsi gravi problemi se si modifica il registro in modo errato. Pertanto, assicurati che segui questi passaggi con attenzione. Per una maggiore protezione, esegui un backup del registro prima di modificarlo. Quindi, è possibile ripristinare il registro se si verifica un problema. Per altre informazioni su come eseguire il backup e il ripristino del Registro di sistema, selezionare il numero di articolo seguente per visualizzare l'articolo della Microsoft Knowledge Base:
322756 Come eseguire il backup e ripristinare il registro di sistema in Windows
Aggiungere la sottochiave Internet al Registro di sistema e impostare i dati del valore
Per risolvere questo problema, aggiungere la sottochiave ForceShellExecute, se non è presente, e impostare il valore dei dati; se invece è già presente, impostare il valore dei dati della sottochiave ForceShellExecute.
Chiudere tutti i programmi in esecuzione.
Seleziona Start, e poi seleziona Esegui. Digitare regedit nella casella Apri, quindi selezionare OK.
Nell'editor del Registro di sistema passare a una delle sottochiavi seguenti (creare le chiavi se non esistono):
Per una versione a 32 bit di Office in una versione a 64 bit di Windows:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\InternetPer una versione a 32 bit di Office in una versione a 32 bit di Windows:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\InternetPer una versione a 64 bit di Office in una versione a 64 bit di Windows:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet
Assicurarsi che la sottochiave Internet sia selezionata. Scegliere Nuovo dal menu Modifica e quindi selezionare Valore DWORD. Aggiungi il seguente valore del registro:
Nome valore: ForceShellExecute
Fare doppio clic su ForceShellExecute e quindi impostare i dati valore su 1. Seleziona OK.
Scegliere Esci dal menu Registro di sistema.
Il problema è stato risolto?
Controllare se il problema è stato risolto. Se il problema è stato risolto, questa sezione è terminata. Se il problema non viene risolto, contattare il supporto.
Altre informazioni
Un collegamento ipertestuale potrebbe non passare a un documento di Microsoft Word o a un foglio di lavoro di Microsoft Excel dopo aver utilizzato questa soluzione alternativa.
Office usa il file Urlmon.dll per gestire tutte le transizioni Internet.
In questo caso, il file Urlmon.dll invia una richiesta per ottenere un file tramite http:// il server proxy. Il server proxy rileva che la richiesta proviene da Internet Explorer, in base al campo Agente utente HTTP di http://request. Viene quindi restituito un errore 403, che indica fondamentalmente "Accesso negato".
Il file Urlmon.dll ottiene questo risultato e restituisce semplicemente il messaggio di errore indicato in precedenza. L'errore indica che la richiesta non è riuscita, ma non indica mai perché non è riuscita.
La soluzione alternativa consiste nell'usare shellExecute() nell'URL. In questo modo il sistema operativo può avviare l'URL nel browser predefinito. Se il browser predefinito non è limitato dal server proxy, viene visualizzata la pagina corretta.