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Errore "Si è verificato un errore durante l'accesso" quando si accede a Dynamics 365 App per Outlook

Si applica a: Dynamics 365 App for Outlook
Numero KB originale: 3064194, 4035750

Questo articolo fornisce soluzioni agli errori di accesso seguenti che possono verificarsi quando si accede a Microsoft Dynamics 365 App per Outlook.

Errore 1

Quando si tenta di aprire Dynamics 365 App per Outlook durante l'uso di Outlook sul desktop, sul Web o sul dispositivo mobile, è possibile che venga visualizzato il seguente messaggio di errore:

Si è verificato un problema durante l'accesso. Riprova. Se il problema persiste, contattare l'amministratore di sistema.

Causa 1

L'app Dynamics 365 per Outlook non è in grado di connettersi al servizio di autorizzazione per assicurarsi di essere autorizzati a usare questa app.

Risoluzione

Per risolvere questo problema, è prima possibile provare a chiudere e riaprire l'app. Se il problema persiste, provare a chiudere e riaprire il browser Internet. Se il problema persiste, provare le opzioni seguenti per assicurarsi che gli URL usati da Dynamics 365 e gli URL di autenticazione usino lo stesso livello di integrità.

Opzione 1: aggiungere ognuno degli URL di Dynamics 365 e degli URL di autenticazione alla stessa area di sicurezza in Internet Explorer
  1. In Internet Explorer selezionare Strumenti>Opzioni Internet.

  2. Selezionare la scheda Sicurezza , selezionare l'area Siti attendibili e quindi selezionare Siti.

  3. In Aggiungi il sito Web all'area digitare gli URL seguenti uno alla volta:

    *.dynamics.com
    *.microsoftonline.com
    https://login.windows.net

    Importante

    Se si usa l'autenticazione federata per accedere a Dynamics 365 usando le credenziali aziendali, è necessario aggiungere anche gli URL di autenticazione usati dall'azienda. Ad esempio, se la società usa Active Directory Federation Services (AD FS) con un URL di autenticazione di https://adfs.contoso.com/..., aggiungere questo URL alla stessa zona o assicurarsi che entrambe le zone abbiano la stessa impostazione Modalità protetta.

  4. Selezionare Aggiungi e quindi OK per salvare i siti.

Opzione 2 - Abilitare la modalità protetta in ogni area di sicurezza di Internet Explorer

Abilitando la modalità protetta in ogni area di sicurezza di Internet Explorer, ogni URL viene caricato nello stesso livello di integrità.

  1. In Internet Explorer selezionare Strumenti>Opzioni Internet.
  2. Seleziona la scheda Sicurezza.
  3. Selezionare ognuna delle zone (Internet, Intranet locale e Siti attendibili).
  4. Durante la selezione di ogni zona, verificare che la casella di controllo Abilita modalità protetta sia selezionata.
  5. Selezionare OK per chiudere la finestra di dialogo Opzioni Internet.

Nota

Quando la modalità protetta è abilitata per un'area di sicurezza, gli URL vengono caricati nel livello di integrità basso (più sicuro). Quando la modalità protetta è disabilitata per un'area di sicurezza, gli URL vengono caricati nel livello di integrità medio. Se un URL non viene aggiunto alle aree Siti attendibili o Intranet locale, per impostazione predefinita viene caricato nell'area Internet, che ha la modalità protetta abilitata per impostazione predefinita.

Causa 2

Questo problema può verificarsi se l'URL di Dynamics 365 (online) viene modificato dopo l'installazione dell'app Dynamics 365 per Outlook. Ad esempio, se l'URL di Dynamics 365 è https://contosocorp.crm.dynamics.com quando si distribuisce l'app, ma si modifica l'URL in https://contoso.crm.dynamics.com un secondo momento.

È possibile verificare se si tratta della causa del problema facendo clic con il pulsante destro del mouse sul collegamento Help me resolve this issue nel messaggio di errore e controllando l'URL. Se l'URL è l'URL precedente anziché l'URL corrente di Dynamics 365, questo potrebbe essere il motivo dell'errore.

Risoluzione

Se si modifica l'URL di Dynamics 365 (online) dopo l'installazione dell'app Dynamics 365 per Outlook, è necessario ridistribuire l'app:

  1. Un utente con il ruolo amministratore di sistema può ridistribuire l'app agli utenti aprendo l'applicazione Web Dynamics 365 e passando all'area Dynamics 365 App for Outlook in Impostazioni.

  2. Selezionare gli utenti che devono ridistribuire l'app e usare uno dei pulsanti Aggiungi app per ridistribuire l'app.

  3. Dopo che lo stato viene modificato in Aggiunta a Outlook, è possibile verificare se il problema è stato risolto. Se l'app è già aperta, chiuderla e riaprirla.

Errore 2

Quando si tenta di aprire l'app Dynamics 365 per Outlook durante l'uso di Outlook sul desktop, è possibile che venga visualizzato il messaggio di errore seguente:

Problemi di accesso?
Si è verificato un problema durante l'accesso. Provare ad aggiungere gli URL seguenti ai siti attendibili:
https://*.dynamics.com
https://login.microsoftonline.com
Se il problema persiste, contattare l'amministratore di sistema.

Causa

Alcuni degli URL necessari per usare l'app Dynamics 365 per Outlook si trovano in aree di sicurezza diverse di Internet Explorer, ad esempio Area Intranet locale, Area siti attendibili o Area Internet.

Quando si usa Dynamics 365 App per Outlook in Outlook sul desktop, Internet Explorer viene usato per visualizzare il contenuto e reindirizzare anche l'utente all'autenticazione in base alle esigenze. Le diverse aree di sicurezza potrebbero usare livelli di integrità diversi, a seconda che la modalità protetta sia abilitata per la zona. Se i diversi URL vengono caricati con livelli di integrità diversi, impedisce che l'autenticazione venga passata correttamente dagli URL di autenticazione a Dynamics 365.

Risoluzione

Per risolvere questo problema, usare una delle opzioni seguenti per assicurarsi che gli URL usati da Dynamics 365 e gli URL di autenticazione usino lo stesso livello di integrità: