Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo fornisce una risoluzione per il problema in cui le azioni di automazione del browser non funzionano in Power Automate per desktop dopo l'aggiornamento di un Web browser.
Si applica a: Power Automate
Sintomi
Le azioni di automazione del browser non possono comunicare con Google Chrome, Microsoft Edge o entrambi.
In fase di progettazione, quando si tenta di acquisire elementi dell'interfaccia utente in uno dei Web browser, viene visualizzato il messaggio "È necessaria l'estensione Power Automate".
In fase di esecuzione, quando si esegue l'azione Avvia nuovo Chrome o Avvia nuova microsoft Edge , viene visualizzato il messaggio di errore seguente:
"Impossibile assumere il controllo di Chrome/Edge (la comunicazione con il browser non è riuscita. Provare a ricaricare l'estensione)."
I Web browser interessati:
- Google Chrome (versione: 113.x)
- Microsoft Edge (versione: 113.x)
Causa
Questo problema si verifica perché il nuovo aggiornamento dei Web browser basati su Chromium (Google Chrome, Microsoft Edge) alla versione 113.x interrompe la comunicazione tra Power Automate per desktop e i rispettivi browser.
Risoluzione
Per risolvere questo problema, è necessario aggiornare Power Automate per desktop alla versione più recente.
Soluzione
Per risolvere il problema, è possibile:
- Impedire l'aggiornamento dei Web browser.
- Eseguire il rollback dell'aggiornamento dei Web browser.