Condividi tramite


Impossibile stabilire una connessione a Access motore di database OLE DB

Questo articolo fornisce una risoluzione a un problema per cui non è possibile stabilire una connessione a Access motore di database OLE DB in Microsoft Power Automate per desktop.

Si applica a: Power Automate
Numero KB originale: 5004577

Sintomi

Si consideri lo scenario seguente in Microsoft Power Automate per desktop:

  1. L'accesso motore di database provider OLE DB non viene visualizzato nell'elenco della finestra Proprietà collegamento dati quando si stabilisce una connessione con le azioni del database.

  2. Quando si usa direttamente un stringa di connessione, è possibile che venga visualizzato il messaggio di errore seguente:

    Impossibile connettersi all'origine dati 'Microsoft.ACE.OLEDB.1x.0'. il provider non è registrato nel computer locale.

Causa

Questo messaggio di errore si verifica perché il driver a 64 bit appropriato non è installato nel computer. Si noti che Power Automate per desktop si basa sull'architettura a 64 bit e pertanto è compatibile solo con i driver di database a 64 bit.

Soluzione

Verificare che nel computer sia installato il driver del database di Access a 64 bit passando all'applicazione ODBC Data Source Administrator (64 bit) in Windows e quindi alla scheda Driver. Se "Microsoft Access Driver" non è presente nell'elenco, è necessario scaricare e installare la versione a 64 bit da Microsoft Access motore di database 2016 Redistributable.

Suggerimento

Se Office a 32 bit è installato nelle finestre e non è possibile eseguire l'aggiornamento alla versione a 64 bit di Office, continuare a leggere il resto dell'articolo.

Seguire questa procedura per coesistere nel computer sia con driver access a 32 bit che a 64 bit:

  1. Disinstallare tutte le versioni del driver di Access dal computer.

  2. Passare all'editor del Registro di sistema sul desktop (è possibile cercarlo nella barra di ricerca) e passare a entrambi i percorsi seguenti, se presenti:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Common\FilesPaths

  3. Controllare se la chiave del Registro di sistema "mso.dll" è presente in entrambi i percorsi precedenti. Se la chiave è presente, significa che non sono stati disinstallati tutti i driver. Verificare i driver nel sistema e disinstallare tutti i driver di Access e verificare di nuovo i percorsi degli editor del Registro di sistema indicati nel passaggio 2.

  4. Scaricare una nuova versione di Microsoft Access motore di database dal sito Web ufficiale di Microsoft e quindi installare il driver a 64 bit usando il prompt dei comandi (CMD) con il comando AccessDatabaseEngine_x64.exe /quiet per 2016 Redistributable.

  5. Tornare all'editor del Registro di sistema ed eliminare la chiave del Registro di sistema "mso.dll" e il relativo valore nel percorso seguente:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Common\FilesPaths

Installare infine il driver a 32 bit usando il prompt dei comandi (CMD) con il comando AccessDatabaseEngine.exe /quiet per 2016 Redistributable. Ciò consentirà la coesistenza dei driver a 32 bit e a 64 bit nel computer.