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Errori che si verificano durante l'abilitazione di Salesforce con flusso da server a server

Questo articolo illustra come risolvere gli errori che possono verificarsi quando si tenta di abilitare Salesforce con un flusso da server a server in Microsoft Copilot for Sales.

Chi è interessato?

Tipo di requisito Descrizione
App client Microsoft Teams
Piattaforma Client Web e desktop
Sistema operativo Windows e Mac
Distribuzione Gestita dall'utente e gestita dall'amministratore
CRM Salesforce
Utenti Amministratori

Non è stato possibile assegnare il set di autorizzazioni perché l'utente di integrazione è inattivo in Salesforce

Sintomi

Quando si tenta di abilitare Salesforce con un flusso da server a server, potrebbe verificarsi il messaggio di errore seguente:

Impossibile assegnare il set di autorizzazioni perché l'utente di integrazione è inattivo in Salesforce.

Motivo

Durante la configurazione del flusso da server a server di Salesforce, un'applicazione connessa viene distribuita nell'organizzazione Salesforce. L'app connessa è associata a un utente di integrazione creato automaticamente. Viene quindi assegnato un set di autorizzazioni all'utente di integrazione. L'errore si verifica quando l'utente di integrazione è inattivo in Salesforce. Il set di autorizzazioni non può essere assegnato a un utente inattivo.

Risoluzione

Per risolvere il problema:

  1. In Salesforce cercare un utente con il copilotforsalesintegrationuser prefisso nel nome utente.

  2. Verificare che l'utente sia attivo.

    • Se inattivo, impostare lo stato dell'utente su attivo.
    • Se non è possibile attivare l'utente, contattare il supporto tecnico Microsoft.

Impossibile creare l'utente perché è stato raggiunto il limite di licenze di integrazione di Salesforce

Sintomi

Quando si tenta di abilitare Salesforce con un flusso da server a server, potrebbe verificarsi il messaggio di errore seguente:

Impossibile creare l'utente perché è stato raggiunto il limite di licenze di integrazione di Salesforce.

Motivo

Durante la configurazione del flusso da server a server Salesforce, un'applicazione connessa viene implementata nell'organizzazione Salesforce. L'app connessa è associata a un utente di integrazione creato automaticamente. A questo utente di integrazione viene assegnata una licenza utente di Salesforce Integration. L'errore si verifica quando è già stato raggiunto il numero massimo di licenze utente di Salesforce Integration.

Risoluzione

Per risolvere questo problema, verificare se è stato raggiunto il numero massimo di licenze utente di Salesforce Integration. In tal caso, è necessario riassegnare gli utenti di integrazione esistenti ad altre licenze o acquistare altre licenze.

Per controllare il numero di licenze utente di integrazione disponibili nell'organizzazione salesforce:

  1. Accedi al portale Salesforce come amministratore.

  2. Passare a Configura>Impostazioni Aziendali>Informazioni Aziendali.

  3. In Licenze utente controllare il numero di licenze di integrazione di Salesforce disponibili nella colonna Licenze rimanenti . Se il numero è 0, è necessario disattivare gli utenti di integrazione esistenti o modificare le licenze in altri tipi. È anche possibile acquistare altre licenze.

Errori imprevisti durante l'abilitazione di Salesforce con un flusso da server a server

Sintomi

Quando si tenta di abilitare Salesforce con un flusso da server a server, è possibile che venga visualizzato uno dei messaggi di errore seguenti:

  • Non è stato possibile ottenere lo stato della distribuzione a causa di un formato ID non corretto.

  • Impossibile trovare l'app connessa.

  • Impossibile creare l'utente di connessione perché manca l'ID licenza utente.

  • Impossibile rimuovere completamente i dati di connessione da Dataverse. Contattare il supporto tecnico vendite per richiedere la pulizia manuale.

  • Impossibile completare la distribuzione dell'app connessa o del set di autorizzazioni a Salesforce. Riprova.

  • Impossibile completare la distribuzione dell'app connessa a Salesforce. Riprova.

  • Impossibile completare la distribuzione del set di autorizzazioni in Salesforce. Riprova.

Motivo

Durante la configurazione del flusso da server a server di Salesforce, un'applicazione connessa viene distribuita nell'organizzazione Salesforce. L'app connessa è associata a un utente di integrazione creato automaticamente. Viene quindi assegnato un set di autorizzazioni all'utente di integrazione. In questo processo potrebbero verificarsi alcuni errori imprevisti.

Risoluzione

Per risolvere il problema, ripetere l'operazione. Se il problema persiste, raccogliere i dettagli dell'errore e contattare il supporto tecnico Microsoft.

Non sono state apportate modifiche

Sintomi

Quando si tenta di abilitare Salesforce con un flusso da server a server, potrebbe verificarsi il messaggio di errore seguente:

Non sono state apportate modifiche.

Motivo

Durante la configurazione del flusso da server a server, un'app connessa viene distribuita nell'organizzazione Salesforce. L'app connessa è associata a un utente di integrazione creato automaticamente. Viene quindi assegnato un set di autorizzazioni all'utente di integrazione. L'errore si verifica quando lo stesso set di autorizzazioni è già stato assegnato all'utente.

Risoluzione

Per risolvere questo problema, verificare la presenza di eventuali modifiche manuali all'app o ai profili connessi con il CopilotForSales prefisso . Se le modifiche non erano intenzionali, ripristinarle. In caso contrario, ripetere l'operazione. Se il problema persiste, contattare il supporto tecnico Microsoft.

Il nome del profilo è già in uso. Selezionare un nome diverso o rinominare il profilo esistente in Salesforce

Sintomi

Quando si tenta di abilitare Salesforce con un flusso da server a server, potrebbe verificarsi il messaggio di errore seguente:

Il nome del profilo è già in uso. Selezionare un nome diverso o rinominare il profilo esistente in Salesforce.

Motivo

Durante la configurazione del flusso da server a server Salesforce, viene creato un profilo denominato Copilot For Sales Integration Profile nell'organizzazione Salesforce. L'errore si verifica quando esiste già un profilo con lo stesso nome, impedendo il processo di creazione.

Risoluzione

Per risolvere questo problema, verificare se esiste già un profilo con lo stesso nome nell'organizzazione Salesforce. Se è stato creato prima di abilitare il flusso da server a server, rinominare il profilo esistente e riprovare. Se il profilo non è stato creato in precedenza, contattare il supporto tecnico Microsoft.

Maggiori informazioni

Se il problema non è ancora risolto, passare a Copilot for Sales - Microsoft Community Hub per coinvolgere gli esperti.

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I prodotti di terze parti illustrati in questo articolo sono prodotti da aziende indipendenti da Microsoft. Microsoft non offre alcuna garanzia, implicita o espressa, sulle prestazioni o sull'affidabilità di questi prodotti.