Condividi tramite


Non è possibile aggiornare i record a causa dell'accesso agli oggetti mancante in Salesforce CRM

Questo articolo consente di risolvere i problemi quando gli utenti non possono aggiornare i record CRM in Microsoft Copilot for Sales a causa dell'accesso agli oggetti mancante in Salesforce CRM.

Nota

Microsoft Sales Copilot viene rinominato Microsoft Copilot for Sales a gennaio 2024. Lo screenshot in questo articolo verrà aggiornato con il nuovo nome a breve.

Chi è interessato?

Tipo di requisito Descrizione
App client Componente aggiuntivo Copilot for Sales Outlook
Piattaforma Client Web e desktop
Sistema operativo Windows e Mac
Distribuzione Gestito dall'utente e gestito dall'amministratore
CRM Salesforce
Utenti Utenti che tentano di aggiornare un record CRM da Copilot for Sales

Sintomi

Quando un utente tenta di aggiornare un record CRM dal componente aggiuntivo Copilot for Sales per Outlook, viene visualizzato il messaggio di errore seguente:

Per aggiornare Salesforce, richiedere l'accesso alla modifica per questo oggetto.

Errore relativo all'impossibilità di aggiornare i record a causa dell'accesso agli oggetti mancante in Salesforce CRM.

Causa

L'utente non dispone dell'accesso di modifica a un oggetto in Salesforce.

Quando un utente tenta di modificare un oggetto, Copilot for Sales verifica se l'utente ha accesso in scrittura all'oggetto in Salesforce. Se l'utente non ha accesso in scrittura all'oggetto, viene visualizzato il messaggio di errore.

È possibile verificare se l'utente che non ha accesso in scrittura all'entità è la causa radice del problema se viene visualizzato l'errore seguente nei log:

Exception thrown in VivaSalesContacts/UpdateContact -  
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId:<CLIENT REQUEST ID>-self --->  
System.Exception: {  
    "status": 400,  
    "message": "Object type contact is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name.  
                Please reference your WSDL or the describe call for the appropriate names\r\nclientRequestId: <CLIENT REQUEST ID>-self",  
    "error": null,  
    "source": "Salesforce.Common",  
    "errors": []  
} 

Nel messaggio Object type contact is not supported di errore precedente indica che l'utente non ha accesso in scrittura all'oggetto Contact .

Risoluzione

Per risolvere il problema, assicurarsi che l'utente disponga di:

  • Autorizzazioni a livello di lettura o scrittura per l'oggetto che l'utente sta tentando di modificare in Salesforce.
  • Autorizzazioni di lettura o scrittura per tutti i campi configurati per la modifica.

Per informazioni sulla sicurezza a livello di oggetto, la sicurezza a livello di campo e la sicurezza a livello di record in Salesforce, vedere Controllare chi vede cosa. È anche possibile contattare l'amministratore di Salesforce per informazioni su come impostare le autorizzazioni per gli oggetti nei profili.

Ulteriori informazioni

Se il problema non è ancora stato risolto, passare a Copilot for Sales - Microsoft Community Hub per interagire con i nostri esperti.

Dichiarazione di non responsabilità sulle informazioni di terze parti

I prodotti di terzi citati in questo articolo sono prodotti da società indipendenti da Microsoft. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilità di tali prodotti

Dichiarazione di non responsabilità di contatti di terze parti

Microsoft fornisce informazioni di contatto di terze parti per aiutarti a trovare ulteriori informazioni su questo argomento. Queste informazioni di contatto sono soggette a modifica senza preavviso. Microsoft non garantisce l'accuratezza delle informazioni di contatto di terze parti.