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Questo articolo illustra come risolvere i problemi di autenticazione durante la connessione a Salesforce CRM dal componente aggiuntivo Microsoft Copilot for Sales per Outlook.
Chi è interessato?
Tipo di requisito | Description |
---|---|
App client | Componente aggiuntivo Copilot for Sales Outlook e app Teams |
Piattaforma | Client Web e desktop |
Sistema operativo | Windows e Mac |
Distribuzione | Gestita dall'utente e gestita dall'amministratore |
CRM | Salesforce |
Utenti | Utenti che tentano di accedere a Salesforce CRM |
Sintomi
Quando si tenta di accedere a Salesforce CRM dal componente aggiuntivo Copilot for Sales per Outlook, viene visualizzato il messaggio di errore seguente:
Errore passato all'URL di reindirizzamento. error=OAUTH_APP_ACCESS_DENIED error_description=user non è approvato dall'amministratore per accedere a questa app
Causa
I criteri dell'app connessa di Microsoft Power Platform impediscono agli utenti di connettersi a Salesforce CRM.
Copilot for Sales si connette a Salesforce CRM tramite l'app connessa a Microsoft Power Platform. Per accedere a Salesforce CRM da Copilot for Sales, gli utenti devono fornire il consenso all'app Microsoft Power Platform per contattare Salesforce CRM per loro conto. Quando non è possibile fornire il consenso, il processo di accesso non riesce.
Risoluzione
Copilot for Sales usa l'app connessa Microsoft Power Platform per connettersi a Salesforce CRM. Garantire che i criteri dell'app Microsoft Power Platform sono configurati per consentire agli utenti di connettersi a Salesforce CRM.
Accedi al portale Salesforce CRM come amministratore.
Vai a Configurazione>Strumenti piattaforma>App>App connesse>App connesse gestite.
Nella pagina App connesse, seleziona Microsoft Power Platform.
Seleziona Modifica criteri.
In Criteri OAuth, seleziona uno dei seguenti valori per Utenti autorizzati:
Tutti gli utenti possono autorizzare automaticamente: questa opzione consente a qualsiasi utente autenticato di Salesforce di connettersi all'istanza di Salesforce tramite il connettore Microsoft Power Platform usato da Microsoft Copilot for Sales, Microsoft Power Automate e potenzialmente altre app per ottenere l'accesso a Salesforce, risolvendo così il problema.
Gli utenti approvati dall'amministratore sono pre-autorizzati: questa opzione consente agli amministratori di concedere in modo esplicito le autorizzazioni ai singoli utenti tramite profili e set di autorizzazioni. Per altre informazioni, vedere App connesse e Gestire l'accesso a un'app connessa.
Selezionare Salva.
Ulteriori informazioni
Se il problema non è ancora risolto, passare a Copilot for Sales - Microsoft Community Hub per coinvolgere gli esperti.
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