Errore "Richiedere le autorizzazioni di amministratore CRM per accedere a Salesforce usando le API"
Questo articolo consente di risolvere i problemi quando viene visualizzato un messaggio di errore dopo la connessione e l'accesso a Salesforce CRM in Microsoft Copilot for Sales.
Nota
Microsoft Sales Copilot viene rinominato Microsoft Copilot for Sales a gennaio 2024. Gli screenshot in questo articolo verranno aggiornati con il nuovo nome a breve.
Chi è interessato?
Tipo di requisito | Descrizione |
---|---|
App client | Componente aggiuntivo Copilot for Sales Outlook |
Piattaforma | Client Web e desktop |
Sistema operativo | Windows e Mac |
Distribuzione | Gestito dall'utente e gestito dall'amministratore |
CRM | Salesforce |
Utenti | Utenti che provano a usare Copilot for Sales con Salesforce CRM |
Sintomi
Dopo aver eseguito l'accesso a Salesforce CRM tramite il componente aggiuntivo Copilot for Sales per Outlook, viene visualizzato il messaggio di errore seguente:
Richiedere le autorizzazioni di amministratore CRM per accedere a Salesforce usando le API
Causa
Il problema si verifica quando non si dispone di autorizzazioni API in Salesforce. È possibile verificare se questa è la causa radice del problema se viene visualizzato l'errore seguente nei log:
Exception thrown in VivaSalesContacts/GetContactsByEmailAddress -
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self --->
System.Exception: {
"error": {
"code": 502,
"source": "{APIM SOURCE}",
"message": "BadGateway",
"innerError": {
"status": 502,
"message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}",
"error": null,
"source": "Salesforce.Common",
"errors": []
}
}
}
Risoluzione
Un amministratore può concedere l'autorizzazione API Abilitata all'utente o al profilo dell'utente interessato seguendo questa procedura:
Accedere a Salesforce come amministratore.
Nella casella di ricerca immettere Utente.
Nel riquadro di spostamento a sinistra selezionare Profili e quindi selezionare il profilo dell'utente interessato.
Nella sezione Autorizzazioni amministrative selezionare API abilitata.
Selezionare Salva.
Ulteriori informazioni
Se il problema non è ancora stato risolto, passare a Copilot for Sales - Microsoft Community Hub per interagire con i nostri esperti.
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