"Errore 1053: il servizio non ha risposto alla richiesta di avvio o controllo in modo tempestivo"

Questo articolo fornisce indicazioni per la risoluzione dei problemi relativi a un problema in cui SQL Server Agent non viene avviato e restituisce l'errore 1053.

Sintomi

Quando si verifica questo problema, vengono visualizzati i sintomi seguenti:

  • Il servizio SQL Server Agent non viene avviato dopo l'installazione di un aggiornamento di Windows recente.
  • Il servizio Registro eventi di Windows non viene avviato.

Se SQL Server Agent non viene avviato, restituisce il messaggio di errore seguente:

Windows non è riuscito ad avviare il servizio SQL Server Agent nel computer locale.
Errore 1053: il servizio non ha risposto tempestivamente alla richiesta di avvio o controllo.

Motivo

Questo problema si verifica se una o più chiavi del Registro di sistema nella HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\EventLog sottochiave usano il DWORD tipo anziché il tipo corretto REG_SZ (stringa).

Queste chiavi del Registro di sistema non valide impediscono l'avvio del servizio Registro eventi di Windows. SQL Server Agent dipende dal servizio Registro eventi di Windows. Pertanto, se il servizio Registro eventi di Windows non è disponibile, SQL Server Agent non viene avviato e restituisce l'errore 1053.

Importante

Se la chiave HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\EventLog del Registro di sistema non esiste, non sono configurati criteri del registro eventi per il sistema. In questo caso, la soluzione fornita in questo articolo non si applica.

Soluzione

Importante

Questa sezione, metodo o attività contiene passaggi che ti spiegano come modificare il registro. Tuttavia, potrebbero verificarsi gravi problemi se si modifica il registro in modo errato. Pertanto, assicurati che segui questi passaggi con attenzione. Al fine di protezione, eseguire il backup del registro di sistema prima di modificarlo, in modo da poterlo ripristinare in caso di problemi. Per ulteriori informazioni su come eseguire il backup e ripristinare il registro, consulta Come eseguire il backup e ripristinare il registro in Windows.

  1. Verificare che SQL Server Agent non sia stato avviato. Provare a avviarlo usando uno dei metodi seguenti:

  2. Se SQL Server Agent viene avviato correttamente, il problema viene risolto. Tuttavia, se SQL Server Agent non viene avviato e restituisce l'errore 1053, andare al passaggio successivo.

  3. Controllare i log di SQL Agent, che si trovano in %ProgramFiles%\Microsoft SQL Server\<Instance>\MSSQL\Log\SQLAGENT.OUT, dopo aver tentato di avviare SQL Server Agent. Se non vengono aggiunte nuove voci ai log, questa condizione conferma che SQL Server Agent ha esito negativo prima dell'inizializzazione. Andare al passaggio successivo.

  4. Provare ad avviare il servizio Registro eventi eseguendo il comando seguente in una finestra del prompt dei comandi con privilegi elevati:

    NET START EVENTLOG
    
  5. Se il servizio Registro eventi viene avviato correttamente, il problema viene risolto. Tuttavia, se il servizio Registro eventi non viene avviato (non vengono visualizzati log quando si apre il Visualizzatore eventi) andare al passaggio successivo.

  6. Controllare la cartella C:\Windows\System32\winevt\Logs registro eventi per i file di log eventi:

  7. Usare il controllo file di sistema (SFC) per ripristinare eventuali componenti di sistema danneggiati eseguendo il comando seguente nella finestra del prompt dei comandi con privilegi elevati.

    sfc /scannow
    
  8. Creare un backup delle chiavi del Registro di sistema esistenti prima di apportare modifiche al Registro di sistema. Usare uno dei metodi seguenti:

    • Aprire l'editor del Registro di sistema, fare clic con il pulsante destro del mouse sulla HKLM\SOFTWARE\Policies\Microsoft\Windows\EventLog chiave e quindi scegliere Esporta.

    • In una finestra del prompt dei comandi con privilegi elevati eseguire il comando seguente:

      reg export "HKLM\SOFTWARE\Policies\Microsoft\Windows\EventLog" "<Path_To_Store_Backup>/EventLog_Backup.reg"
      
  9. Aprire l'editor del Registro di sistema e passare a HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\EventLog.

  10. HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\EventLog Sottochiave e tutte le relative voci secondarie:

    1. Identificare ed eliminare tutti i valori del Registro di sistema configurati come DWORD tipo.
    2. Ricreare i valori eliminati DWORD usando lo stesso nome e il REG_SZ tipo.
  11. Eliminare la sottochiave problematica HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\EventLog eseguendo il comando seguente:

    reg delete "HKLM\SOFTWARE\Policies\Microsoft\Windows\EventLog" /f
    
  12. Riavviare il dispositivo per consentire a Windows di ricreare la configurazione del registro eventi usando le impostazioni predefinite.

  13. Dopo il riavvio del dispositivo, avviare il servizio Registro eventi di Windows eseguendo il comando seguente:

    NET START EVENTLOG
    

    Il servizio Registro eventi dovrebbe essere avviato correttamente.

  14. Avviare il servizio SQL Server Agent eseguendo il comando seguente:

    NET START SQLSERVERAGENT
    

    Il servizio SQL Server Agent dovrebbe essere avviato correttamente.