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Problema spn smarrito esplicito in SQL Server

Questo articolo consente di risolvere un problema di autenticazione coerente con SQL Server che influisce sul nome dell'entità servizio (SPN) smarrito esplicito.

Sintomi

Se il nome SPN specificato nella stringa di connessione esiste in un account del servizio non usato da Microsoft SQL Server, viene visualizzato un messaggio di errore di contesto SSPI (Security Support Provider Interface).

Se l'SPN non è registrato correttamente, è possibile che venga visualizzato il messaggio di errore seguente:

"Nome principale di destinazione scorretto. Impossibile generare il contesto SSPI."

Se si tenta di creare un nome SPN già esistente, viene visualizzato il messaggio di errore seguente:

È stato trovato un nome SPN duplicato, operazione di interruzione.

Causa

I nomi SPN smarriti espliciti possono causare problemi nell'autenticazione Kerberos e impedire ai client di connettersi al servizio.

Risoluzione

Se si verificano spn smarriti espliciti, potrebbe essere necessario creare o ricreare il nome SPN per il servizio. Per creare o ricreare il nome SPN usando il SETSPN comando , seguire questa procedura:

  1. Eseguire il SETSPN -L domain\svcacct comando per elencare i nomi SPN nell'account del servizio SQL Server.
  2. Eseguire il SETSPN -Q spnName comando per individuare l'account del servizio in cui è registrato l'SPN.
  3. Eseguire il SETSPN -D comando per rimuovere il nome SPN dal servizio.
  4. Eseguire il SETSPN -A comando per aggiungere il nome SPN al servizio.
  5. Spostare il nome SPN usando SETSPN -Do selezionare un nome SPN già esistente nell'account corretto.

Ulteriori informazioni

Problemi di autenticazione coerenti in SQL Server