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Questo articolo illustra come risolvere un problema di autenticazione coerente durante la connessione a SQL Server correlato a un servizio del sottosistema dell'autorità di sicurezza locale (LSASS) che non risponde.
Sintomi
Potrebbero verificarsi problemi del sottosistema di sicurezza correlati a LSASS. Il driver autenticazione di Windows potrebbe visualizzare il messaggio di errore "L'account di accesso proviene da un dominio non attendibile e non può essere usato con autenticazione di Windows".
Controllare se il log degli errori di Microsoft SQL Server mostra le voci seguenti:
Handshake SSPI non è riuscito con codice di errore 0x80090311, stato 14 durante la creazione di una connessione con sicurezza integrata; la connessione è stata chiusa. Motivo: AcceptSecurityContext non riuscito. Il codice di errore di Windows indica la causa del problema.
Handshake SSPI non è riuscito con codice di errore 0x80090304, stato 14 durante la creazione di una connessione con sicurezza integrata; la connessione è stata chiusa. Motivo: AcceptSecurityContext non riuscito. Il codice di errore di Windows indica la causa del problema.
È anche possibile che vengano visualizzati errori Kerberos nel registro eventi di sistema nel server che esegue SQL Server nello stesso intervallo di tempo. Il codice di errore seguente indica:
Errore - 2146893039 (0x80090311): non è stato possibile contattare alcuna autorità per l'autenticazione.
Causa
Questi errori si verificano quando LSASS smette di rispondere.
Risoluzione
Per risolvere gli errori LSASS, seguire questa procedura:
Controllare se il nome dell'entità servizio (SPN) è registrato correttamente nel controller di dominio (DC).
Usare il
setspn -Q
comando osetspn -L
per eseguire una query sul nome SPN e i nomi SPN, rispettivamente, nell'account.