Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo illustra come risolvere il problema che si verifica quando si apre Gestione configurazione SQL Server.
Versione originale del prodotto: SQL Server
Numero KB originale: 956013
Sintomi
Quando si apre Gestione configurazione SQL Server, è possibile che venga visualizzato uno dei messaggi di errore seguenti:
Impossibile connettersi al provider WMI. Non si dispone dell'autorizzazione o il server non è raggiungibile. Si noti che è possibile gestire solo i server SQL Server 2005 e versioni successive con Gestione configurazione SQL Server.
Spazio dei nomi non valido [0x8004100e]
o
Impossibile connettersi al provider WMI. Non si dispone dell'autorizzazione o il server non è raggiungibile. Si noti che è possibile gestire solo i server SQL Server 2005 e versioni successive con Gestione configurazione SQL Server.
Classe non valida [0x80041010]
Causa
Gestione configurazione SQL Server usare Strumentazione gestione finestre (WMI) per visualizzare e modificare alcune impostazioni del server. Quando ci si connette ai server, Gestione configurazione SQL Server usa WMI per ottenere lo stato dei servizi SQL Server (MSSQLSERVER) e SQL Server Agent. Questo problema si verifica perché il provider WMI viene rimosso quando si disinstalla un'istanza di SQL Server.
Questo file si trova nella %programfiles(x86)%
cartella .
Soluzione alternativa
Il file MOF per l'istanza DI SQL si trova nella %programfiles(x86)%\Microsoft SQL Server\nnn\Shared
cartella . Determinare il percorso del file MOF per la versione, usando la tabella seguente come riferimento:
Versione | nnn | MOF |
---|---|---|
Microsoft SQL Server 2022 | 160 | sqlmgmprovider.mof |
Microsoft SQL Server 2019 | 150 | sqlmgmproviderxpsp2up.mof |
Microsoft SQL Server 2017 | 140 | sqlmgmproviderxpsp2up.mof |
Microsoft SQL Server 2016 | 130 | sqlmgmproviderxpsp2up.mof |
Microsoft SQL Server 2014 | 120 | sqlmgmproviderxpsp2up.mof |
Microsoft SQL Server 2012 | 110 | sqlmgmproviderxpsp2up.mof |
Microsoft SQL Server 2008 R2 | 100 | sqlmgmproviderxpsp2up.mof |
Microsoft SQL Server 2008 | 100 | sqlmgmproviderxpsp2up.mof |
Microsoft SQL Server 2005 | 90 | sqlmgmproviderxpsp2up.mof |
Per risolvere il problema, è possibile usare una delle opzioni seguenti.
Opzione 1: ricompilare il provider WMI SQL usando mofcomp (compilatore MOF)
A tale scopo, seguire questa procedura:
Aprire un prompt dei comandi con privilegi elevati e modificare la directory nel percorso della cartella dal passaggio 1.
Per SQL Server 2022 e versioni successive, digitare il comando seguente e quindi premere INVIO:
mofcomp "sqlmgmprovider.mof"
Per SQL Server 2019 e versioni precedenti, digitare il comando seguente e quindi premere INVIO:
mofcomp "sqlmgmproviderxpsp2up.mof"
Note
Affinché questo comando abbia esito positivo, il file MOF deve essere presente nella
%programfiles(x86)%\Microsoft SQL Server\nnn\Shared
cartella .Dopo aver eseguito lo strumento mofcomp , riavviare il servizio WMI per rendere effettive le modifiche. A tale scopo, aprire l'applicazione Servizi , selezionare Strumentazione gestione Windows e quindi selezionare Riavvia. È anche possibile riavviare il servizio WMI eseguendo il comando di PowerShell seguente come amministratore:
Get-Service winmgmt | Restart-Service -Force
Opzione 2: ripristinare l'installazione di SQL Server. Per altre informazioni, vedere Ripristinare un'installazione non riuscita di SQL Server
Note
Questa opzione è obbligatoria solo se il file MOF non è presente nel %programfiles(x86)%\Microsoft SQL Server\nnn\Shared
percorso.