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Problemi di comunicazione in un agente di Data Protection Manager

Questo articolo illustra come correggere i messaggi di errore relativi ai problemi di comunicazione che si verificano in un agente DPM (Data Protection Manager).

Versione originale del prodotto: System Center Data Protection Manager
Numero KB originale: 970090

Sintomi

In un agente DPM vengono visualizzati i messaggi di errore seguenti relativi ai problemi di comunicazione:

Un agente DPM non è riuscito a comunicare con il servizio DPM nel <server> a causa di un errore di comunicazione. Assicurarsi che <il server> sia accessibile in remoto dal computer che esegue l'agente DPM. Se un firewall è abilitato nel <server>, assicurarsi che non blocchi le richieste dal computer che esegue l'agente DPM (codice errore: 0x800706ba, nome completo: <server>).

DPM non è riuscito a comunicare con l'agente protezione sul <server> perché l'accesso è negato. (ID 42 Dettagli: Accesso negato (0x80070005))

Errore 270: l'operazione dell'agente non è riuscita nel <server> perché DPM non è riuscito a comunicare con l'agente protezione DPM. Il computer può essere protetto da un altro server DPM oppure l'agente protezione potrebbe essere stato disinstallato nel computer protetto.

Causa

Questo problema si verifica se manca un account computer DPM da uno dei gruppi di sicurezza seguenti nel server protetto:

  • DPMRADmTrustedMachines
  • DPMRADCOMTrustedMachines
  • Distributed COM Users

Risoluzione

Se l'account del computer DPM non è presente in uno dei gruppi di sicurezza elencati nella sezione Causa, aggiungere manualmente l'account computer DPM.

Ad esempio, se il nome del server DPM è DPM01 e se questo nome appartiene al dominio Contoso , dovrebbe essere visualizzato Conotoso\DPM01 come membro di ogni gruppo nel server protetto.

In una situazione in cui il server protetto è un controller di dominio, un'installazione non riuscita dell'agente protezione potrebbe comportare la rimozione dei gruppi DPMRADmTrustedMachines e DPMRADCOMTrustedMachines . È possibile risolvere questo problema eseguendo il comando seguente:

<drive letter>:\Program Files\Microsoft Data Protection Manager\bin\SetDpmServer.exe -dpmServerName <DPM server name>

Ad esempio, l'ultima parte di questo comando potrebbe essere simile alla seguente:

SetDpmServer.exe -dpmServerName DPM01

Note

  • DPM01 è il nome effettivo del server DPM.
  • Questo comando creerà nuovamente i due gruppi in Active Directory e aggiungerà l'account del computer DPM a questi gruppi e al gruppo Utenti COM distribuiti.