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Errore 2927 (0x8033809d): impossibile aggiungere un host gestito in VMM 2012

Questo articolo illustra come risolvere un problema in cui si verifica l'errore 2927 quando si aggiunge un host gestito in System Center 2012 Virtual Machine Manager.

Versione originale del prodotto: System Center 2012 Virtual Machine Manager
Numero KB originale: 970923

Sintomo

Quando si aggiunge un host gestito in System Center 2012 Virtual Machine Manager, potrebbe non riuscire con i messaggi di errore seguenti:

Dalla console VMM:

Errore (2927)
Si è verificato un errore di gestione hardware durante il tentativo di contattare il server del server<>.
(Errore sconosciuto 0x8033809d))

Azioni consigliate
Verificare che WinRM sia installato e in esecuzione nel server server<>. Per altre informazioni, usare il comando "winrm helpmsg hrresult".

È anche possibile registrare l'evento seguente nel registro eventi di sistema:

Nome registro: sistema
Origine: Microsoft-Windows-Security-Kerberos
Data: 23/04/2009 2:08:30 PM
ID evento: 4
Categoria attività: Nessuna
Livello: Errore
Parole chiave: Classico
Utente: N/D
Computer: <server>
Descrizione: il client Kerberos ha ricevuto un errore di KRB_AP_ERR_MODIFIED dal server<>. Il nome di destinazione usato è HTTP/<server>. Indica che il server di destinazione non è riuscito a decrittografare il ticket fornito dal client. Che può verificarsi quando il nome dell'entità server di destinazione (SPN) viene registrato in un account diverso dall'account usato dal servizio di destinazione. Assicurarsi che il nome SPN di destinazione sia registrato e registrato solo in , l'account usato dal server. Questo errore può verificarsi anche quando il servizio di destinazione usa una password diversa per l'account del servizio di destinazione rispetto a quello del Centro distribuzione chiavi Kerberos (KDC) per l'account del servizio di destinazione. Assicurarsi che il servizio nel server e il KDC siano entrambi aggiornati per usare la password corrente. Se il nome del server non è completo e il dominio di destinazione (DOMAIN.COM) è diverso dal dominio client (DOMAIN.COM), verificare se sono presenti account server denominati in modo identico in questi due domini oppure usare il nome completo per identificare il server.

Causa

Questo problema si verifica perché due o più account computer hanno lo stesso nome dell'entità servizio (SPN) registrato. L'ID evento 11 viene registrato quando il Centro distribuzione chiavi (KDC) riceve una richiesta di ticket e il nome SPN correlato esiste più di una volta quando viene controllato nel catalogo globale (GC) per la verifica a livello di foresta.

Risoluzione

Per risolvere questo problema, individuare il computer o gli account utente con i nomi SPN duplicati. Quando si trovano i computer che dispongono dei nomi SPN duplicati, è possibile eliminare l'account computer dal dominio, disgiunrsi e ricongiunrsi al computer al dominio oppure è possibile usare ADSI Edit (Active Directory Service Interface Editor) per correggere il nome SPN nel computer con il nome SPN non corretto.

In Windows Server 2008 e versioni successive, per individuare gli account computer con i nomi SPN duplicati, usare setspn -x per rilevare automaticamente i nomi SPN duplicati.