Condividi tramite


Il ripristino di sistema potrebbe non riuscire con codice di errore 0x8007045b se nel punto di ripristino è presente contenuto crittografato

Questo articolo fornisce una soluzione alternativa per un problema a causa del quale ripristino di sistema potrebbe non riuscire con codice di errore 0x8007045b.

Si applica a: Windows 10 - tutte le edizioni
Numero KB originale: 3074925

Sintomi

Prendi in considerazione lo scenario seguente:

  • Si usa l'applicazione Mail in Windows 8.1 o Windows 8.
  • Si desidera utilizzare l'applicazione Posta per connettersi a un server di posta di Microsoft Exchange o Microsoft Office 365. (A tale scopo, è necessario accettare il Rendere il pc più sicuri criteri di sicurezza applicati dal server di posta elettronica.
  • Si esegue una delle azioni seguenti:
    • Usare il programma Ripristino di sistema in Windows per creare alcuni punti di ripristino.
    • Si tenta di usare i punti di ripristino creati automaticamente dal sistema.
  • Si tenta di ripristinare il sistema in uno dei punti di ripristino dopo aver accettato la sicurezza applicata.

In questo scenario, ripristino di sistema potrebbe non riuscire e viene visualizzato un messaggio di errore simile al seguente dopo il riavvio del sistema.

Ripristino di sistema non completato correttamente. I file di sistema e le impostazioni del computer non sono stati modificati.

Dettagli:

Ripristino di sistema non è riuscito a estrarre il file

C:\Users<User Name>\AppData\Local\Packages\microsoft.windowscommunicationsapps_8wekyb3d8bbwe....

Dal punto di ripristino.

Si è verificato un errore imprevisto durante il ripristino di sistema. (0x8007045b)

Causa

Questo problema si verifica a causa di un problema noto nel programma ripristino di sistema.

Dopo aver configurato l'applicazione Posta elettronica per connettersi a un server Exchange o Office 365 e accettare i criteri di sicurezza Rendi il mio PC più sicuro , alcuni file nel profilo utente verranno crittografati usando il file system di crittografia (EFS). E questi file verranno inclusi nel punto di ripristino se si usa Ripristino di sistema per creare un punto di ripristino. Quando si avvia il programma Ripristino di sistema per ripristinare il sistema, Ripristino di sistema crea un'attività di arresto per eseguire il lavoro di ripristino reale. Quando questa attività viene eseguita, la maggior parte dei servizi di sistema è già stata arrestata. Ciò include EFS.

Tuttavia, se un file viene crittografato da EFS nel punto di ripristino, il programma ripristino di sistema dovrà chiamare al servizio EFS per estrarre i file di questo tipo dal punto di ripristino. Tuttavia, poiché il servizio EFS è già stato arrestato e non può essere riavviato perché il sistema è in fase di arresto, il processo di ripristino ha esito negativo con codice di errore 0x8007045b. Questo codice indica ERROR_SHUTDOWN_IN_PROGRESS.

Soluzione alternativa

Per risolvere questo problema, seguire questa procedura per eseguire il riavvio in Ambiente ripristino Windows e quindi eseguire il programma Ripristino di sistema.

  1. Aprire un prompt dei comandi come amministratore e quindi eseguire il comando seguente:

    reagentc /boottore
    

    Note

    Se questo comando restituisce un errore di Ambiente ripristino Windows è disabilitato, eseguire il comando seguente per installarlo e quindi eseguire reagentc /enable di nuovo.

  2. Riavviare il computer. Il computer verrà riavviato nell'ambiente Ambiente ripristino Windows.

  3. In Ambiente ripristino Windows fare clic su Risoluzione dei problemi, su Opzioni avanzate, su Ripristino di sistema e quindi seguire la richiesta di avviare il programma Ripristino di sistema. Poiché EFS è sempre in esecuzione in Ambiente ripristino Windows e poiché Ripristino di sistema non deve creare un'attività di arresto per eseguire il lavoro di ripristino in Ambiente ripristino Windows, questo problema specifico non si verificherà in Ambiente ripristino Windows. Per altre informazioni sul comando REAgentC, vedere Opzioni della riga di comando REAgentC.