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Questo articolo descrive come risolvere un problema in cui gli utenti non possono accedere a Windows fino a quando non viene rimosso il driver non corretto.
Si applica a: Windows 10, versione 2004, Windows 10, versione 1909, Windows 10, versione 1903
Numero KB originale: 4563240
Riepilogo
Se si usa una smart card PIV (Personal Identity Verification) o qualsiasi dispositivo multifunzione che usa smart card PIV che si basano sul minidriver smart card di Windows Inbox, potrebbe essere stato ricevuto un aggiornamento non corretto del driver. Quando si tenta di usare una smart card per eseguire l'autenticazione a Windows, è possibile che vengano visualizzati messaggi di errore come "Impossibile utilizzare questa smart card" o "L'operazione richiede una smart card diversa".
L'aggiornamento non corretto contiene l'app del provider "FEITIAN - SmartCard - 1.0.0.3" che installa il driver di smart card xPass feitian. Si tratta di un aggiornamento legittimo e firmato pubblicato da un partner verificato. Tuttavia, era inavvertitamente destinato a un set di dispositivi più ampio di quello previsto originariamente.
Il driver è stato estratto dal sistema di pubblicazione di Windows Update. Per attenuare eventuali effetti negativi, qualsiasi utente che ha ricevuto l'aggiornamento deve eseguire manualmente il rollback al driver posta in arrivo di Windows. Per altre informazioni, vedere la sezione "Risoluzione".
Sintomi
Si osservano uno o più dei sintomi seguenti:
- Si tenta di accedere a Windows usando una smart card PIV o un dispositivo (ad esempio YubiKey) che supporta le smart card PIV e si basa sul minidriver smart card di Windows Inbox. Tuttavia, non è possibile accedere.
- Si tenta di accedere a Windows usando un dispositivo smart card PIV non feitian. Tuttavia, non è possibile accedere. Se il dispositivo supporta funzionalità FIDO (Fast Identity Online), ad esempio U2F o FIDO2, queste funzionalità continuano a funzionare.
- Il driver xPass Smart Card non valido non si interfaccia correttamente con altri dispositivi non Feitian che si basano sul driver posta in arrivo. In questo modo vengono generati messaggi di errore, ad esempio "Impossibile usare questa smart card".
Nell'esempio seguente vengono illustrati i risultati del comando certutil -scinfo eseguito in un computer interessato. I certificati sono stati generati come parte di una registrazione di Microsoft AD CS. Tuttavia, non sono più in grado di interfacciarsi con il dispositivo YubiKey PIV dopo l'installazione del driver xPass Smart Card.
Causa
Il driver feitian xPass smart card versione 1.0.0.3 specifica SCFILTER\CID_2777BE07-6993-4513-BD80-C184FCB0AB2D come identificatore compatibile nel file inf del pacchetto driver. Tuttavia, il minidriver della smart card windows per le smart card PIV (Identity Device (NIST SP 800-73 [PIV])) usa lo stesso identificatore compatibile. Se si connette un dispositivo non Feitian che usa il driver posta in arrivo al computer, Windows riconosce il driver Feitian come compatibile. Windows scarica, installa e carica il driver Feitian.
Per altre informazioni su come Windows seleziona i driver per un dispositivo, vedere Panoramica del processo di selezione driver e Modalità di selezione di un driver per un dispositivo da parte di Windows.
Risoluzione
Se il driver della smart card Feitian xPass è stato installato nel computer, è necessario rimuoverlo per ripristinare il driver Identity Device (NIST SP 800-73 [PIV]). Dopo aver rimosso il driver xPass smart card, Windows carica automaticamente il driver posta in arrivo per il dispositivo.
A tale scopo, è possibile eliminare manualmente il driver o creare ed eseguire uno script per eliminarlo.
Determinare se il computer è interessato
In Impostazioni selezionare Aggiornamenti e cronologia degli aggiornamenti della visualizzazione sicurezza>. Dovrebbe essere possibile identificare l'aggiornamento del driver nell'elenco.
Eliminare manualmente il driver
Per rimuovere manualmente il driver, seguire questa procedura:
Connettere il dispositivo smart card al computer.
Avviare Gestione dispositivi. È possibile avviare Gestione dispositivi da Pannello di controllo oppure premendo Windows + R e quindi immettendo devmgmt.msc.
Selezionare Smart card, fare clic con il pulsante destro del mouse su xPass Smart Card e quindi scegliere Disinstalla dispositivo.
Quando richiesto, selezionare Elimina il software driver per questo dispositivo e quindi selezionare Disinstalla.
Creare uno script per eliminare il driver
Per automatizzare la rimozione del driver, creare uno script che può essere eseguito in un file batch. Lo script identifica il nome del file con estensione inf del driver e usa PnPUtil.exe per eliminare il driver. Lo script può eliminare il driver anche se una smart card o un dispositivo smart card non è connesso al computer. Per creare e usare uno script di questo tipo, seguire questa procedura:
Creare un file batch contenente la sequenza di comando seguente:
@echo off for /r %windir%\System32\DriverStore\FileRepository %%i in (*eps_piv_csp11.inf*) do (@echo %%i pnputil /delete-driver %%i /uninstall /force) pause
Nel computer interessato eseguire il file batch in una finestra del prompt dei comandi amministrativa.
Ulteriori informazioni
Se hai seguito i passaggi nella sezione "Risoluzione", ma hai bisogno di assistenza aggiuntiva, vai al sito Web di supporto tecnico Microsoft.