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Sysprep ha esito negativo dopo aver rimosso o aggiornato le app di Microsoft Store che includono immagini di Windows predefinite

Questo articolo illustra un problema che si verifica quando si rimuove o si aggiorna un'app di Microsoft Store di cui è stato effettuato il provisioning usando Microsoft Store e quindi si esegue sysprep nel computer.

Si applica a: Windows 10 - tutte le edizioni, Windows 11
Numero KB originale: 2769827

Introduzione

Sysprep è uno strumento per gli amministratori IT che vogliono preparare un'installazione di Windows per la duplicazione, il controllo e il recapito dei clienti. Le linee guida contenute in questo articolo sono destinate all'uso da parte di agenti di supporto e professionisti IT. Se sei un utente domestico che riscontra problemi durante l'uso delle app di Microsoft Store, vedi Risolvere i problemi relativi alle app da Microsoft Store.

Diverse app di Microsoft Store sono incorporate in immagini di Windows. Queste app includono le app Mail, Maps, Messaging, Bing, Travel e News, tra le altre. Queste app sono note come app sottoposte a provisioning. Le app di cui è stato effettuato il provisioning vengono gestite in staging nell'immagine e sono pianificate per l'installazione per ogni utente dell'immagine di Windows al primo accesso. Oltre alle app predefinite, puoi trasferire localmente le tue app line-of-business in Microsoft Store nell'immagine di Windows senza doverle pubblicare in Microsoft Store. È possibile trasferire Appx localmente i pacchetti usando i comandi di manutenzione online o offline disponibili in DISM.exe o tramite il modulo DiSM di PowerShell.

Sintomi

Si considerino gli scenari seguenti:

Scenario 1

  • Si sta creando un computer di riferimento windows 10 o Windows 11 personalizzato che si vuole sysprep e acquisire.
  • Si desidera rimuovere alcune delle app di Microsoft Store di cui è stato effettuato il provisioning (Appx pacchetti) da questo computer di riferimento.
  • dism -online /Remove-ProvisionedAppxPackage /PackageName:<packagename> Eseguire per eseguire il deprovisioning dei Appx pacchetti.

Quando si esegue l'operazione sysprep in questo scenario, l'operazione potrebbe non riuscire con l'errore seguente:

Utilità preparazione sistema 3.14
Si è verificato un errore irreversibile durante il tentativo di sysprep del computer

Scenario 2

  • Hai un'immagine di Windows esistente e diverse app di Microsoft Store vengono trasferite localmente nell'immagine.
  • Si vogliono rimuovere alcuni dei pacchetti sideload Appx dall'immagine e personalizzarlo ulteriormente.
  • Avviare il computer di riferimento ed eseguire uno dei comandi di PowerShell seguenti per rimuovere il provisioning del Appx pacchetto:
    • Remove-AppxProvisionedPackage -PackageName <packagename>
    • Remove-ProvisionedAppxPackage -PackageName <packagename>

Quando si esegue l'operazione sysprep in questo scenario, l'operazione potrebbe non riuscire con l'errore seguente:

Utilità preparazione sistema 3.14
Si è verificato un errore irreversibile durante il tentativo di sysprep del computer

Scenario 3

  • Si sta creando un'immagine di riferimento di Windows 10 o Windows 11.
  • Ci si connette a Microsoft Store e quindi si aggiornano le app di Microsoft Store predefinite usando Microsoft Store.

Quando si esegue l'operazione sysprep in questo scenario, l'operazione potrebbe non riuscire con l'errore seguente:

Strumento preparazione sistema 3.14 Si è verificato un errore irreversibile durante il tentativo di sysprep del computer

Inoltre, nella SetupErr.log, è possibile notare le voci di errore seguenti:

<Data><e> ora dell'errore PackageFullName> del pacchetto <SYSPRP è stato installato per un utente, ma non è stato effettuato il provisioning per tutti gli utenti. Questo pacchetto non funzionerà correttamente nell'immagine sysprep.
<Data><e> ora errore SYSPRP Non è stato possibile rimuovere le app per l'utente corrente: 0x80073cf2.
<Data><e> ora, errore SYSPRP Codice di uscita del thread RemoveAllApps 0x3cf2.
<Data></ora>, errore [0x0f0082] SYSPRP ActionPlatform::LaunchModule: errore durante l'esecuzione di 'SysprepGeneralize' da C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP ActionPlatform::ExecuteAction: Error in execute action; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP ActionPlatform::ExecuteActionList: Error in execute actions; dwRet = 0x3cf2
<Data></ora>, errore SYSPRP SysprepSession::Execute: Errore durante l'esecuzione di azioni da C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2
<Data></ora>, errore SYSPRP RunPlatformActions:Failed durante l'esecuzione di azioni SysprepSession; dwRet = 0x3cf2
<Data></ora>, errore [0x0f0070] SYSPRP RunExternalDlls:Errore durante l'esecuzione di DLL sysprep del Registro di sistema, interrompendo l'esecuzione di sysprep. dwRet = 0x3cf2
<Date><Time>, Error [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep generalize internal providers; hr = 0x80073cf2

Causa

Sysprep ha un provider aggiuntivo aggiunto in Windows per pulire Appx i pacchetti e generalizzare l'immagine. Il provider funziona solo se il pacchetto è un pacchetto per utente o un pacchetto di cui è stato effettuato il Appx provisioning all-user.

  • Il pacchetto per utente indica che il Appx pacchetto viene installato per un account utente specifico e non è disponibile per altri utenti del computer.
  • Il pacchetto all-user indica che è stato effettuato il Appx provisioning nell'immagine in modo che tutti gli utenti che usano questa immagine possano accedere all'app.

Se un pacchetto all-user di cui è stato effettuato il provisioning nell'immagine è stato eseguito manualmente il deprovisioning dall'immagine ma non è stato rimosso per un determinato utente, il provider visualizzerà un errore durante la pulizia del pacchetto durante sysprep. Il provider avrà esito negativo anche se un pacchetto all-user di cui è stato effettuato il provisioning nell'immagine è stato aggiornato da uno degli utenti in questo computer di riferimento.

Risoluzione

Per risolvere questo problema, rimuovere il pacchetto per l'utente che esegue sysprep e rimuovere anche il provisioning. A tale scopo, eseguire la procedura seguente.

Nota

Per impedire a Microsoft Store di aggiornare le app, scollegare la connessione Internet o disabilitare gli aggiornamenti automatici in modalità di controllo prima di creare l'immagine.

  1. Esegui i cmdlet di PowerShell seguenti:

    Import-Module Appx
    Import-Module Dism
    Get-AppxPackage -AllUsers | Where PublisherId -eq 8wekyb3d8bbwe | Format-List -Property PackageFullName,PackageUserInformation
    

Nota

  • Nell'output di questo ultimo cmdlet controllare gli utenti per i quali il pacchetto viene visualizzato come Installato. Eliminare questi account utente dal computer di riferimento oppure accedere al computer usando questi account utente. Eseguire quindi il cmdlet nel passaggio 2 per rimuovere il Appx pacchetto.
  • Questo comando elenca tutti i pacchetti pubblicati da Microsoft e installati da qualsiasi utente del computer di riferimento. Poiché il computer deve essere sysprepped, si presuppone che questi profili utente non richiedano più il pacchetto.
  • Se è stato effettuato il provisioning manuale di app appartenenti ad altri editori, eseguire il comando seguente per elencarle:

Get-AppxPackage -AllUsers | Format-List -Property PackageFullName,PackageUserInformation

  1. Rimuovere Appx il pacchetto eseguendo il cmdlet seguente:

    Remove-AppxPackage -Package <packagefullname>
    
  2. Rimuovere il provisioning eseguendo il cmdlet seguente:

    Remove-AppxProvisionedPackage -Online -PackageName <packagefullname>
    

Se si tenta di eseguire il ripristino da un problema di aggiornamento, è possibile eseguire di nuovo il provisioning dell'app dopo aver seguito questa procedura.

Nota

Il problema non si verifica se si esegue la manutenzione di un'immagine offline. In questo scenario, il provisioning viene cancellato automaticamente per tutti gli utenti. Ciò include l'utente che esegue il comando.

Ulteriori informazioni

Per altre informazioni su come aggiungere e rimuovere app, vedere:

Raccolta dati

Se è necessaria l'assistenza del supporto tecnico Microsoft, si consiglia di raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni utilizzando TSS per le questioni relative alla distribuzione.