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Questo articolo fornisce una soluzione alternativa per un problema a causa del quale Windows Update si blocca e gli aggiornamenti appena installati vengono disinstallati dopo un riavvio del sistema.
Numero KB originale: 3064434
Sintomi
Prendi in considerazione lo scenario seguente:
- Si dispone di un computer che esegue Windows.
- Gli aggiornamenti vengono installati da Windows Update.
- Riavviare Windows quando viene richiesto di eseguire questa operazione.
In questo scenario viene visualizzato il messaggio seguente durante il processo di riavvio:
Uso degli aggiornamenti
13% completato
Non spegnere il computer
Si tratta di un messaggio previsto. Tuttavia, il sistema sembra smettere di rispondere (si blocca) per circa 15 minuti. Dopo questa volta, il sistema viene riavviato. Tuttavia, gli aggiornamenti installati vengono ora disinstallati.
Inoltre, è possibile registrare una voce simile alla seguente nel file CBS.log in %SystemRoot%\Logs\CBS:
Shtd: Timeout in attesa del completamento dell'elaborazione dell'arresto: nessun progresso rilevato negli ultimi 900000 millisecondi
Causa
Questo problema si verifica perché il servizio Programma di installazione attendibile non ha completato il processo di installazione entro il periodo di timeout predefinito di 15 minuti.
Soluzione alternativa
Per risolvere questo problema, impostare il valore di timeout su un valore maggiore nel Registro di sistema e quindi riapplicare l'hotfix. A tale scopo, effettuare i passaggi seguenti:
Avviare l'editor del Registro di sistema.
Individuare la seguente sottochiave:
HKLM\System\CurrentControlSet\Services\TrustedInstaller
Fare clic con il pulsante destro del mouse sulla chiave TrustedInstaller e quindi scegliere Autorizzazioni.
Concedere all'utente controllo completo il diritto al gruppo Administrators.
Modificare il valore BlockTimeIncrement in 2a30 (esadecimale).
Note
Questa modifica imposta il valore di timeout su tre ore. Questo dovrebbe essere sufficiente per la maggior parte delle situazioni. Tuttavia, potrebbe essere necessario provare un valore maggiore nell'ambiente.
Riavviare il server e quindi applicare nuovamente l'hotfix.
Stato
Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".
Raccolta dei dati
Se è necessaria l'assistenza del supporto tecnico Microsoft, si consiglia di raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni utilizzando TSS per le questioni relative alla distribuzione.