Condividi tramite


Errori di attivazione e notifiche (non originali) intorno all'8 gennaio 2019 nei client Con contratto multilicenza windows 7 Service Pack 1 del Servizio di gestione delle chiavi

Questo articolo fornisce una soluzione a un problema per cui gli utenti possono ricevere le notifiche di attivazione di Windows o "Windows non è originale" a partire dalle 10:00 UTC, 8 gennaio 2019.

Si applica a: Windows 7 Service Pack 1
Numero KB originale: 4487266

Riepilogo

Questo articolo si applica ai dispositivi Windows 7 Service Pack 1 con contratto multilicenza che usano l'attivazione Servizio di gestione delle chiavi (KMS) e hanno installato l'aggiornamento kb 971033. Alcuni utenti potrebbero ricevere le notifiche di attivazione di Windows o "Windows non è originale" a partire dalle 10:00 UTC, 8 gennaio 2019.

Il 9 gennaio 2019 è stata ripristinata una modifica apportata ai server di attivazione e convalida Microsoft. Per i dispositivi che continuano a segnalare l'attivazione e le notifiche "non originali", è necessario rimuovere i 971033 KB seguendo la procedura descritta nella sezione Risoluzione .

Le edizioni di Windows che supportano l'attivazione con contratti multilicenza includono quanto segue:

  • Windows 7 Professional
  • Windows 7 Professional N
  • Windows 7 Professional E
  • Windows 7 Enterprise
  • Windows 7 Enterprise N
  • Windows 7 Enterprise E

Per le edizioni di Windows che riscontrano errori di attivazione e "non originali" che non sono causati dalla modifica del server di attivazione e convalida Microsoft intorno all'8 gennaio 2019, è consigliabile seguire la risoluzione dei problemi di attivazione standard.

Sintomi

  1. Dopo l'accesso viene visualizzato un messaggio di errore non autentico di Windows.

    Screenshot di Windows non è un messaggio di errore originale.

  2. Una copia di finestre non è una filigrana originale viene visualizzata nell'angolo inferiore destro del desktop di Windows su uno sfondo nero.

    Screenshot della filigrana visualizzato nell'angolo inferiore destro del desktop di Windows.

  3. L'output segnala l'errore slmgr /dlv 0xC004F200.

    Screenshot dell'output del comando che segnala l'errore 0xC004F200.

  4. Le attivazioni effettuate tramite il slmgr /ato comando hanno esito negativo e restituiscono il messaggio seguente:

    Windows viene eseguito entro il periodo di notifica non originale. Eseguire "slui.exe" per passare online e convalidare Windows.

    Screenshot del messaggio restituito dopo l'uso del comando .

  5. Nel registro eventi vengono registrati gli eventi seguenti.

Log eventi Origine evento ID evento Descrizione
Applicazione Microsoft-Windows-Security-SPP 8209 Stato originale impostato su non originale (0x00000000) per id applicazione 55c92734-d682-4d71-983e-d6ec3f16059f
Application Microsoft-Windows-Security-SPP 8208 Acquisizione del ticket originale non riuscita (hr=0xC004C4A2) per l'ID modello 66c92734-d682-4d71-983e-d6ec3f16059f
Application Tecnologie di attivazione di Windows 13 Risultato di convalida originale: hrOffline = 0x00000000, hrOnline =0xC004C4A2
Application Microsoft-Windows-Security-SPP 8196 L'utilità di pianificazione dell'attivazione delle licenze (sppuinotify.dll) non è stata in grado di attivare automaticamente. Codice errore: 0xC004F200:

Causa

Un aggiornamento recente all'attivazione e alla convalida Microsoft ha causato involontariamente un errore "non originale" nei client Windows 7 con contratto multilicenza che avevano KB971033 installato. La modifica è stata introdotta alle 10.00.00 UTC l'8 gennaio 2019 ed è stata ripristinata alle 4.30.00 UTC il 9 gennaio 2019.

Note

Questo intervallo coincide con il rilascio degli aggiornamenti di gennaio 2019 (KB 4480960 e KB 4480970) rilasciati martedì 8 gennaio 2019. Questi eventi non sono correlati.

I dispositivi Windows 7 che hanno installato KB971033 ma non hanno riscontrato questo problema tra l'ora della modifica (10.00.00 UTC, 8 gennaio 2019) e l'ora della riversione di tale modifica (4.30.00 UTC, 9 gennaio 2019) non devono riscontrare il problema descritto in questo articolo.

KB971033 contiene il testo seguente:

"Nota Per un cliente Enterprise che usa Servizio di gestione delle chiavi (KMS) o attivazione multipla (MAK), è in genere consigliabile NON installare questo aggiornamento nell'immagine di riferimento o nei computer già distribuiti. Questo aggiornamento è destinato alle installazioni consumer di Windows tramite l'attivazione RETAIL."

È consigliabile disinstallare KB971033 da tutti i dispositivi basati su Windows 7 con contratto multilicenza. Sono inclusi i dispositivi attualmente non interessati dal problema menzionato nella sezione Sintomi .

Risoluzione

Per determinare se è installato 971033 KB, utilizzare uno dei metodi seguenti.

  • Aprire l'elemento Aggiornamenti installati in Pannello di controllo (Pannello di controllo> Windows Update>Visualizza>aggiornamenti installati) e quindi cercare Update for Microsoft Windows (KB971033) nell'elenco.

  • Eseguire il comando seguente in una finestra del prompt dei comandi come amministratore e quindi cercare "Microsoft-Windows-Security-WindowsActivationTechnologies-package~31bf3856ad364e35~amd64~~7.1.7600.16395" nei risultati:

    dism /online /get-packages
    
  • Eseguire il comando seguente al prompt dei comandi e quindi esaminare i risultati per indicare che è installato 971033 KB:

    wmic qfe where HotFixID="KB971033"
    
  • Eseguire il comando seguente in Windows PowerShell e quindi cercare nei risultati un'indicazione che kb 971033 è installato:

    Get-Hotfix -id KB971033
    

    Se 971033 KB è attualmente installato, usare uno dei metodi seguenti per rimuovere l'aggiornamento. È consigliabile riavviare il sistema dopo la rimozione dell'aggiornamento.

  • Nell'elemento Aggiornamenti installati in Pannello di controllo (Pannello di controllo> Windows Update>Visualizza>aggiornamenti installati), fare clic con il pulsante destro del mouse su Aggiorna per Microsoft Windows (KB971033) e quindi scegliere Disinstalla.

  • Eseguire il comando seguente in una finestra del prompt dei comandi come amministratore:

    wusa /uninstall /kb:971033
    
  • Eseguire il comando seguente in una finestra del prompt dei comandi come amministratore:

    dism /online /Remove-Package /PackageName:Microsoft-Windows-Security-WindowsActivationTechnologies-Package~31bf3856ad364e35~amd64~~7.1.7600.16395
    

Dopo la disinstallazione della knowledge base 971033 o dopo che non viene più visualizzata come installata, ricompilare i file correlati all'attivazione e quindi riattivare il sistema eseguendo i comandi seguenti in una finestra del prompt dei comandi come amministratore:

net stop sppuinotify
sc config sppuinotify start= disabled
net stop sppsvc
del %windir%\system32\7B296FB0-376B-497e-B012-9C450E1B7327-5P-0.C7483456-A289-439d-8115-601632D005A0 /ah
del %windir%\system32\7B296FB0-376B-497e-B012-9C450E1B7327-5P-1.C7483456-A289-439d-8115-601632D005A0 /ah
del %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform\tokens.dat
del %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform\cache\cache.dat
net start sppsvc
cscript c:\windows\system32\slmgr.vbs /ipk <edition-specific KMS client key>
cscript c:\windows\system32\slmgr.vbs /ato
sc config sppuinotify start= demand

Note

Nel primo comando cscript sostituire <la chiave> client del Servizio di gestione delle chiavi specifica dell'edizione con la chiave effettiva. Per altre informazioni, vedere Chiavi di configurazione di client del Servizio di gestione delle chiavi.

La tabella seguente elenca le chiavi client del Servizio di gestione delle chiavi per ogni edizione di Windows 7.

Sistema operativo/edizione Chiave di configurazione client KMS
Windows 7 Professional FJ82H-XT6CR-J8D7P-XQJJ2-GPDD4
Windows 7 Professional N MRPKT-YTG23-K7D7T-X2JMM-QY7MG
Windows 7 Professional E W82YF-2Q76Y-63HXB-FGJG9-GF7QX
Windows 7 Enterprise 33PXH-7Y6KF-2VJC9-XBBR8-HVTHH
Windows 7 Enterprise N YDRBP-3D83W-TY26F-D46B2-XCKRJ
Windows 7 Enterprise E C29WB-22CC8-VJ326-GHFJW-H9DH4

Note

  • Gli script che contengono la chiave di installazione client del Servizio di gestione delle chiavi devono essere destinati all'edizione del sistema operativo corrispondente.
  • Per i servizi che non dispongono di kb 971033 installati, ma riscontrano il problema menzionato nella sezione Sintomi , è anche possibile ricompilare i file correlati all'attivazione e riattivare il sistema usando lo script menzionato nell'elenco dei comandi di riattivazione.

Raccolta dei dati

Se è necessaria l'assistenza del supporto tecnico Microsoft, si consiglia di raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni utilizzando TSS per le questioni relative alla distribuzione.