Condividi tramite


L'errore 1058 viene visualizzato quando un servizio si arresta improvvisamente

Questo articolo fornisce una soluzione a un problema a causa del quale si verifica l'errore 1058 quando un servizio si arresta improvvisamente.

Si applica a: Windows 10 - tutte le edizioni, Windows 7, Windows Vista, Windows XP
Numero KB originale: 241584

Sintomi

Quando un servizio si arresta improvvisamente, è possibile che venga visualizzato il seguente messaggio di errore:

Errore 1058: Il servizio non può essere avviato, perché è disabilitato o perché non dispone di dispositivi abilitati associati.

È anche possibile che venga visualizzato questo messaggio di errore quando si tenta di avviare un servizio.

Causa

Questo problema può verificarsi se il servizio è disabilitato o se il servizio è disabilitato per il profilo hardware attualmente in uso.

Risoluzione per Windows 10, Windows 7 e Windows Vista

  1. Fare clic su Start, cercare Servizi e quindi fare clic su Servizi nel risultato della ricerca.

  2. Scorrere fino a trovare il servizio e quindi fare doppio clic sul servizio.

    Screenshot dell'opzione Tipo di avvio nella scheda Generale della finestra di dialogo Proprietà routing e accesso remoto (computer locale).

  3. Se il servizio è disabilitato, fare clic sull'elenco Tipo di avvio e quindi selezionare un'opzione diversa da Disabilitata.

  4. Fare clic su Applica.

  5. Fare clic su Start per provare ad avviare il servizio.

  6. Scegliere OK.

Risoluzione per Windows XP

  1. Fare clic su Start, scegliere Tutti i programmi, Strumenti di amministrazione e quindi fare clic su Servizi.

  2. Scorrere fino a trovare il servizio arrestato o disabilitato.

  3. Fare doppio clic sul servizio che non è stato avviato.

  4. Fare clic sulla scheda Accedi.

    Screenshot della scheda Accesso della finestra di dialogo Remote Procedure Call (RPC) Locator Properties (Local Computer).

  5. Verificare che il servizio non sia disabilitato per il profilo hardware in uso. Se il servizio è disabilitato per il profilo hardware, fare clic su Abilita.

  6. Fare clic sulla scheda Generale e quindi nella casella Tipo di avvio verificare che il servizio non sia disabilitato. Se il servizio è disabilitato, fare clic su Automatico per avviarlo all'avvio del computer.

    Screenshot della casella tipo di avvio nella scheda Generale.

  7. Scegliere OK.

Ulteriori informazioni

Se un servizio è impostato per l'avvio automatico, ma il servizio è disabilitato per il profilo hardware in uso, il servizio non viene avviato e non viene generato alcun messaggio di errore.