Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo fornisce una soluzione a un errore che si verifica quando si tenta di aggiungere una stampante IPP tramite HTTPS.
Si applica a: Windows 7 Service Pack 1
Numero KB originale: 2021626
Sintomi
Quando si tenta di aggiungere una stampante IPP a una workstation Windows Vista o Windows 7 tramite HTTPS, l'installazione della coda potrebbe non riuscire con l'errore seguente:
Aggiungi stampante
Connetti alla stampante
Windows non è riuscito a connettersi alla stampante. Controllare il nome della stampante e riprovare. Se si tratta di una stampante di rete, assicurarsi che la stampante sia attivata e che l'indirizzo della stampante sia corretto.
Causa
Questo problema si verifica perché Windows non considera attendibile o non può convalidare il certificato SSL utilizzato dal server di stampa oppure il server di stampa usa un certificato autofirmato.
Risoluzione
Questo problema può essere risolto in uno dei due casi seguenti:
- Configurazione del server di stampa per l'uso di un certificato SSL valido da un'autorità di certificazione esterna considerata attendibile dalla workstation.
- Se il server di stampa e la workstation si trovano nello stesso dominio, configurando il server di stampa in modo da usare un certificato SSL valido da un'autorità di certificazione aziendale.
- Se il server di stampa usa un certificato autofirmato, installare il certificato autofirmato nella workstation.
Come installare un certificato autofirmato del server di stampa IPP in un client Windows
Se il server di stampa usa certificati autofirmati, è possibile usare la procedura seguente per installare il certificato autofirmato nei client in modo che possano usare la stampante.
Note
Questa operazione deve essere eseguita solo per i certificati SSL dai server considerati attendibili.
- Accedere al client come amministratore
- Trovare Internet Explorer nel menu Start, fare clic con il pulsante destro del mouse su di esso e scegliere Esegui come amministratore.
- In Internet Explorer passare al server di stampa usando HTTPS (ad esempio,
https://PrintServerName/
) - Nella barra degli indirizzi le parole "Errore certificato" dovrebbero essere visualizzate sul lato destro accanto a un'icona di scudo rosso. Fare clic sull'errore.
- Fare clic su Visualizza certificati.
- Nella finestra del certificato fare clic su Installa certificato....
- Selezionare Inserisci tutti i certificati nell'archivio seguente.
- Fare clic su Sfoglia.
- Selezionare Autorità di certificazione radice attendibili e fare clic su OK.
- Fare clic su Avanti, quindi su Fine.
- Verrà visualizzato un avviso di sicurezza che indica che si aggiunge un certificato da un'origine che non può essere convalidata. Fare clic su Sì per considerare attendibile il certificato SSL.
- Chiudere Internet Explorer.
- È ora possibile installare la stampante.
Raccolta dei dati
Se è necessaria l'assistenza del supporto tecnico Microsoft, si consiglia di raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni utilizzando il TSS per i problemi relativi all'esperienza utente.